Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Cannot Get SoD to Work on GOG

Hey guys!

So a few days ago, I started another complete run of the Baldur's Gate Series, using a number of mods (Baldur's Gate NPC Project, Unfinished Business, G3 BG2 Tweaks Pack, and Baldur's Gate Romantic Encounters). Upon starting the playthrough, I noticed that SoD wasn't playing nice with BG NPC, with Imoen suddenly channeling her demonic side, pulling lines from SoD (including a very scary "halt your assault" line). I uninstalled the expansion using GOG Galaxy (un-checked the box under the DLC section). Imoen stopped being a terrifying soothsayer, problem solved. However, now that I am about to tackle the final battle with Sarevok, I decided to re-install SoD (and install the Jaheira recast mod) so I could jump right into the next leg of saga. Thing is, after reinstalling the expansion, I can't start the game up. I've tried installing it via GOG Galaxy (again, checkbox). I've tried directly downloading it from the GOG website. I've tried the verify/repair option on GOG Galaxy to address any problems. Nothing works. The game just refuses to open with SoD installed. When I uninstall it, the game starts up just fine. This is baffling for me, since I didn't have this problem during my first SoD playthrough. Some additional info:

- I am playing on PC.
- Baldur's Gate is currently updated to version 2.3
- Both the Jaheira Recast mod and Modmerge seem to be unable to detect a SoD installation despite GOG Galaxy saying that it is installed
- There is a folder titled "sod-dlc" in my game folder with a number of BIF files in it

Anyone capable of helping me out with this?


  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 19,811
    Did you use Modmerge? You mention it in your post, but I think you didn't install it. Just put modmerge.exe into the folder with the game (the one with chitin.key). After that, install mods.

  • NightingaleNightingale Member Posts: 59
    I tried this, but it did not work. I uninstalled all my mods and the game opened up with SoD installed. Afterward, I ran the modmerge.exe, but it didn't look like it did anything (It asked me if I wanted to continue and upon saying yes, shot a bunch of rapid-fire characters on the screen and then closed the window before I could read them). It is in my game folder with the chiten.key, so I assumed it worked and proceeded to reinstall the mods. As soon as I did, the game refused to open yet again. What's more, the Jaheira Recast mod continues to say that I don't have SoD installed, which is impossible, as I just saw that it was functioning without the mods.

    Also, I was looking through the folder and noticed a sod-dlc.disabled file in there. Is this part of the problem?

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 19,811
    It looks like you had Modmerge installed, and then unchecked the sod checkbox in GoG Galaxy.
    But GoG Galaxy doesn't know anything about modmerge/extracted files.

    Your saves are in My documents, so they are safe. I would recommend to reinstall the game, then manually delete all the left subfolders, install the game again, then install modmerge and mods.

  • NightingaleNightingale Member Posts: 59
    @JuliusBorisov I followed your advice, and after making a "dlc" folder and moving the zip to that folder before running the .exe, everthing is working like a charm.

    Thank you for your help. I really appreciate it :smile:

Sign In or Register to comment.