Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

BG2:EE running very slow

Gabeg21Gabeg21 Member Posts: 43
Hi all,

I have played this game for years and the newest update on Beamdog (2.0 patch download) has slowed the game down to a crawl when entering a building, loading, saving moving to a new map etc... The gameplay itself is still perfectly fine, so i don't think it's the Intel issue or a graphics card issue. I can move around the map with no lag, cast tons of spells with no lag, but when I save or go to a new area, it takes almost 2-3 minutes to proceed. I'm not sure if this is related mods, but I play with the following (with this install order):

weimer item upgrade
d'arnise romance
unfinished business (uninstalled, as i thought this was causing the issue, it wasn't)
dungeon be gone
the undying
g3 bg2 tweaks

I also tried a few NPC mods (Fade, Kelsey), but have uninstalled them as well, thinking that may have been the issue, again, ho change.

I'm not sure if it's related to newest upgrade (patch 2.0) or not, but I am almost certain that that is when is started sowing down.

I have tried uninstalling and reinstalling numerous times, no change. I've restored to original version, no change.

Just two weeks ago, I had no issues at all, which was the first time playing the game in nearly a year. And that is when i noticed the "update". When it first started, it was just every 4th or 5th time or so when going to a new area. Now it is every single time, and any time I save or load a game.

It also crashes occasionally at the same times. I really am not a computer guy, so an help would be greatly appreciated.

Thank you all!


Comments

  • GusindaGusinda Member Posts: 1,588
    Hi @Gabeg21 - Welcome to the Forum. There are a number of things we can try but need to know more info.

    - I am guessing you are running on a Windows platform but which version?
    - Tablet / laptop / desktop?
    - Discrete graphics card (if so what)?
    - Windows 10 has had a major update since you last played and may have changed drivers for your devices. Have you updated any drivers.

    Recommend that you make sure that both Video Card and Sound card have updated drivers. Also recommend that you install DirectX 9.0c (which can be installed on the same system with DirectX 10, 11, and 12 depening on what version of Windows you are using).


    It seems that a lot of these type of problems could be fix changing from OpenGL to DirectX (or vica verca).
    To do tihs, edit your baldur.lau (..\My Documents\Baldur's Gate - Enhanced Edition\baldur.lau) and change the line below.

    SetPrivateProfileString('Graphics','Backend','0')
    to
    SetPrivateProfileString('Graphics','Backend','1')

    If it is a 1, then try changing it to 0; if it is a 0, then change to 1. 1 = DirectX, 0 = OpenGL

    Just doing this by itself could fix the prob, but I recommend updating your drivers anyway. If it doesn't fix, then please provide some more info about the system.

    Good luck
    Gus

    JuliusBorisov
  • Gabeg21Gabeg21 Member Posts: 43
    Thanks for the quick reply and the welcome. Been coming on here for years, just never posted.

    I first tried switching to DirectX in the lua file, it was 0, so i changed it to 1, didn't help.

    I am running Windows 10, my drivers are up to date, or at they said the best driver is already installed. Toshiba laptop, Directx12 (i did install 9c as well, per your recommendation. Graphics is Intel HD 3000.

    Here are the contents of my baldur.lua file for graphics.


    SetPrivateProfileString('Graphics','Use Character Highlights','1')
    SetPrivateProfileString('Graphics','Greyscale On Pause','1')
    SetPrivateProfileString('Graphics','Use Nearest Neighbour Scaling','0')
    SetPrivateProfileString('Graphics','Use Sprite Outlines','1')
    SetPrivateProfileString('Graphics','Zoom Lock','0')
    SetPrivateProfileString('Graphics','Scale UI','0')
    SetPrivateProfileString('Graphics','version','OpenGL version 3.1.0 - Build 9.17.10.4459 - build XXXX')
    SetPrivateProfileString('Graphics','Backend','1')
    SetPrivateProfileString('Graphics','Show Black Space','1')
    SetPrivateProfileString('Graphics','renderer','Intel(R) HD Graphics 3000')
    SetPrivateProfileString('Graphics','Hardware Mouse Cursor','1')
    SetPrivateProfileString('Graphics','vendor','Intel')

    Anything stand out?

  • GusindaGusinda Member Posts: 1,588
    Hi @Gabeg21 - Did you change the .lua when the game was closed? Although I can see you have changed the Backend to 1, this line suggests that it hasn't changed internally (not sure why this would happen).

    SetPrivateProfileString('Graphics','version','OpenGL version 3.1.0 - Build 9.17.10.4459 - build XXXX')

    This is what my profilestring looks like:
    SetPrivateProfileString('Graphics','version','DirectX 9.0c')

    What should happen is that the change to the backend automatically rewrites baldur.lua on next startup to reflect the change to graphics engine.

    I can suggest two approaches to continue the testing DirectX.
    Make a backup of your baldur.lua
    - Delete baldur.lua and start the game.
    - Close game.
    - Edit baldur.lua and change the backend to 1.
    - Start the game and load a saved game.
    - Close down game and have a look at the baldur.lua to see if DirectX has been picked up as the graphics version. You could do this while the game is running but make sure you close before doing the next step.
    - If it hasn't, replace the profilestring
    SetPrivateProfileString('Graphics','version','OpenGL version 3.1.0 - Build 9.17.10.4459 - build XXXX')
    with
    SetPrivateProfileString('Graphics','version','DirectX 9.0c')
    and restart the game...

    The other way is not to delete baldur.lua but to edit the current one by replacing the strings above. I just like to clean out all the webs first... (and it tests to see if there was something else happening for it not to change initially).

    Next step if this doesn't work is to run 'DXDIAG' (type this into a command prompt; or your search/Cortana), save and place the results in a response?

    Hope all goes quickly and smoothly...
    Gus



    JuliusBorisov
  • Gabeg21Gabeg21 Member Posts: 43
    edited July 2017
    Well, thanks for the help, but it still isn't working right. It did not auto change it to directx, but i did copy and paste what you recommended. When I first opened the game and went to a new area, it loaded super quick. Then I saved, went to a new area, and it went back to the same super slow load time. When this happens, it locks up for about 45 seconds. I click randomly, and then get the little blue circle, like a crash, then loads the area, or saves the game and goes back to the game screen after another 45 seconds or so.

    Here is my dxdiag document:

    ------------------
    System Information
    ------------------
    Time of this report: 7/18/2017, 06:29:40
    Machine name: GABE-PC
    Machine Id: {5A0C75E1-5775-4A9E-A759-A5ED2361BBF0}
    Operating System: Windows 10 Home 64-bit (10.0, Build 15063) (15063.rs2_release.170317-1834)
    Language: English (Regional Setting: English)
    System Manufacturer: TOSHIBA
    System Model: Satellite A665
    BIOS: BIOS Date: 03/28/11 17:52:56 Ver: AMI APTIO 1.80
    Processor: Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz (8 CPUs), ~2.0GHz
    Memory: 6144MB RAM
    Available OS Memory: 6050MB RAM
    Page File: 2881MB used, 9313MB available
    Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 12
    DX Setup Parameters: Not found
    User DPI Setting: Using System DPI
    System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
    Miracast: Not Available
    Microsoft Graphics Hybrid: Not Supported
    DxDiag Version: 10.00.15063.0000 64bit Unicode

    I notice it still says DirectX 12, but i did install the 9c and put that into the baldur.lua folder.

    I am no expert, but this doesn't seem like a graphics issue. I only say that because of the fact the gameplay itself is flawless, no bugs etc... It only happens when going to a new area and saving/loading a game. I could be wrong, and frankly, I hope I am.

    Thanks again for all the help!

    Post edited by Gabeg21 on
  • GusindaGusinda Member Posts: 1,588
    @Gabeg21 - Sorry about this. The DXDIAG dialogue has a 'Save All Information' button near the exit button. This saves all the diagnostic info to a text file. Could you try again. Thanks.

    As far as the DirectX 12 goes, this is no probs and is expected.

    Can you also check and see if your baldur.lua reverted back to the OpenGL for the graphics version?

    Gus

  • Gabeg21Gabeg21 Member Posts: 43
    Hey Gus,

    I sent you a message with the contents of the save info folder. It was too large to post on here.

    Also, the baldur.lua still shows directx9c, not OpenGL.

    Thanks

  • GusindaGusinda Member Posts: 1,588
    Hi @Gabeg21, all received. Video drivers appear up to date but your Sound card is well out of date (dated 2010). Could you update these?

    You will be able to find the latest driver (dated 11 Jul 2017) from the Microsoft Update Catalog (the 76.9 MB is 32 Bit, the 131.3 MB is 64 Bit). If you aren't aware how to install from a .cab file, then have a look at this post or post a question here. Thanks btw, I now have updated drivers myself; mine were last years model... I have tested the driver (quick test only) on my system and all appears to work.

    I narrowed down the search to just the driver version that is the latest, but for any future searches you might want to do, use the Microsoft Update Catelog site and search for "Realtek Semiconductor Corp. - MEDIA" (without ""). It will list all the drivers with latest at the top.

    As far as the large post goes, you could just use the 'attach file' (document icon in the edit menu above) and attach the dxdiag.txt file (all a learning process).

    Happy that it kept DirectX 9. Don't forget that your old baldur.lua has all the changes you may have made manually such as 'debug', 'pathfinding' etc, so you will want to put those back in at some time (preferably when we get it going smoothly).

    Step by step...

    Off to venture forth [err] continue testing my new sound driver.
    Gus

    JuliusBorisov
  • Gabeg21Gabeg21 Member Posts: 43
    Ok, got the audio driver updated. No change to the game however. Still takes forever when going to a new area and saving.

  • GusindaGusinda Member Posts: 1,588
    Hi @Gabeg21, we are at a point to do some consolidation. Just want to summarise things and check we are both in the same mindset...

    Can you confirm the following:

    System:
    - Windows 10 v1703 (can be checked in Setttings / Update / Update History)
    - Video and Audio drivers updated - all good.
    - DirectX 9.0c installed - all good.
    - Screen resolution set to 1366 x 768

    Game:
    - BG2:EE version 2.3.67.3 - Beamdog/GOG/Steam ?
    - Currently vanilla - no mods
    - Set to run DirectX in baldur.lua (when this was set, did you delete the .lua and let the game create new or edit the one in place?).
    - Do you run the game zoomed in / zoomed out

    Prob:
    - The problem only occurs when you change area. Once the blue circle (which is likely to be a Windows wait icon) goes away, does the game settle down and preform as expected until you go to a new area or does it remain slow.
    - Has the prob completely crashed the game / system or it is just the pause?
    - Does the pause only occur in BG2EE?
    - Does the problem occur with BG:EE or IWD:EE/PS:T:EE (if you have them), or any other game/application?
    - What other applications are running (incl type of Virus checker) in the background?
    - Do you have a full party when it pauses, does it occur if it is just CHARNAME.
    - Have you started a fresh game to make sure this isn't a problem with current saved game (could be corrupted).

    Have alook at these and I will ponder what else it could be...
    Gus

    JuliusBorisov
  • Gabeg21Gabeg21 Member Posts: 43
    System:

    All good

    Game:
    Beamdog download, most current
    I tried it vanilla, same problem, so currently, I have Weimer Item Upgrade, Dungeon be Gone and bg2 tweaks
    baldur.lua I edited and saved the existing one
    as for the zoom, i'm not 100%. Whatever the standard is I guess. It does zoom at times when I move to quick on the mouse pad, but I zoom back out to where it was. I can't stand it when it is zoomed in close

    Problem:
    Correct. New areas mostly, sometimes in a building on a map, sometimes not (Waukeens ,Umar and Temple seem to be fine when entering a building on those maps, but most others it lags. Once it resumes, it is all good until I leave the area. It also does this when I load a game, or save a game.
    It has crashed it a few times, maybe like 3 times in the past week or so when loading. All 3 were when entering an area, never during a save or load.
    I only play BG2:EE, so yes, only there.
    This is a screenshot of my apps on startup
    I haven't tried it with just charname in the party. It has done it with charname+1NPC all the way up to a full party.
    I have started about 10 new games since it started this to try to trouble shoot on my own. I have deleted them all, unistalled game, started over etc....

    On a side note, I have read a few others probelms, and some say it was related to a bag of holding (bag30) I believe it was and also when the get the Elven Chain Mail. The first time it did it, i did have the Elven Chain Mail. I loaded from an earlier save and disregarded it. No change. I've tried numerous different NPC combow to see if anything would help as well. Again, I have not tried solo. If that is what is causing this, then I guess I will stop playing as IMO, it is no fun by yourself.

    I may sound like a broken record, but I really believe this had something to do with the Windows 10 update. Could be coincidental, but I think when that updated, this is when the problem started. I initially thought it may have had something to do with BG2:EE update, but I think I played for a day or two with no issues until the Windows update.

    Hopefully, some of that info helps.

    Thanks again Gus, I do appreciate all the help so far.

  • GusindaGusinda Member Posts: 1,588
    No probs @Gabeg21. I agree that it had something to do with the update, we just have to find out what was corrupted... I am still thinking graphics drivers, so we are going to go for broke!

    Because we are having a bit of difficulty sorting the problem, lets start from scratch and rule out the game engine, mods or saved games...

    Could you do the following:
    1. Rename ..\My Documents\Baldur's Gate II - Enhanced Edition to ..\My Documents\Baldur's Gate II - Enhanced Edition.old if you want to keep all your old settings, portraits and saved games etc...
    2. Uninstall BG2EE.
    - This should get the old BG2EE out of the way. Now, in with the new.

    3. Download new video drivers from the Microsoft Update Catalog. You should see the drivers listed as lines 2 & 3. Look on the version column for 9.17.10.4459. I don't have an Intel HD 3000 (and therefore couldn't test) but downloaded them and found that the 99.6 MB is 64 Bit and 59.2 MB package is the 32 Bit driver. Again, unpack the .cab file, rename the folder to indicate what the driver is etc.
    4. Install the Video card drivers. If they refuse to install due to already being there, uninstall the current set of drivers and install new package.
    4. Reinstall DirectX 9.0c
    5. Download and Install new version of BG2EE (keep vanilla) and run to create baldur.lua. Exit BG2EE.
    6. Open baldur.lua and edit to read:
    SetPrivateProfileString('Graphics','Backend','1')
    7. Start BG2EE and check if baldur.lua was updated to change graphics engine to DirectX
    SetPrivateProfileString('Graphics','version','DirectX 9.0c')
    8. Start new game and test. If all goes well, then when installing your mods, install one at a time and test again (just to see if it was one of the mods that was a prob).
    9. If all is still going well, try loading one of your old saved games that was known to have the problem.
    10. If all doesn't go well, then uhm, we will cross that bridge then.


    [Turns to nearest good Cleric and ask for a 'Chant' prayer and Prot from Evil 10' spell]
    Gus

    JuliusBorisovGabeg21Gate70Aerakar
  • GusindaGusinda Member Posts: 1,588
    @Gabeg21 - no problems whatsoever, glad to help. I think the Cleric might have given us an extra Blessing as well.

    ronaldoJuliusBorisov
  • HwestaHwesta Member Posts: 11
    i found a solution worked well for me. i opened intel control panel. and changed 3d settings from performance to private settings. and change texture quality to "balanced" from preformance and all other settings is "use app. settings". and all my problem solved.

    Gusinda
Sign In or Register to comment.