Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Slight problem with custom portaits and EEKeeper.

Hi there!

Ok! Basically, I'm having an issue with the 'small' portrait appearing in game, anywhere other than the character creation screen. The portrait to the right of the game screen, when you're playing, is showing the 'medium' portrait instead of the small one.

As you can't choose and select the small portrait in game, I figured I would open up EEKeeper, and manually select it that way - buuut, this has lead me to my second issue, none of my custom portraits are appearing in EEKeeper. I thought I may have an old version, but I have just downloaded and installed the latest version, and it's exactly the same, no custom portraits.

That's the issue! Any help would be appreciated! I'm just trying to get a small portrait to work!


I'm gonna go through what I've done step by step, if that helps anybody understand, but feel free to skip this over if it's not relevant.

I created three portraits, they are as follows:

dbmL.bmp (210x300px, I know this is not needed, it just looks good on the character creation screen)
dbmM.bmp (169x266px)
dbmS.bmp (54x84px)

The 'L' and the 'S' both show up on the character creation screen, although obviously the small portrait is very pixelated, being shown that big.

I select the Large portrait, make the character, everything is fine. Except, in game, where the small portrait should be, it is showing my medium portrait instead (in fact, it may be showing the large one, both my large and medium are identical - it's just the small one that is a close up of the face.) On the character information screen, the medium portrait is showing up fine. The issue is just this dang small portrait not appearing.

Alright, so I opened up EEKeeper to try and select the small portrait manually, but it appears none of my custom portraits are showing up whatsoever. As I wrote above, I downloaded and installed the latest version of EEKeeper, but the same thing is happening. I would very, very much like to fix this!

I have the full BGEE trilogy installed, on Steam, including Siege of Dragonspear.

My portraits are stored in this folder - C:\Users\(me)\Documents\Baldur's Gate - Enhanced Edition\Portraits

I think that's all the info I can give, any help would be amazing!

Thanks for reading!


  • GusindaGusinda Member Posts: 1,588
    edited September 2017
    G'Day @Legend, you could try and drop one of the sized portraits.

    In my config, I only use dbmM.bmp (210x330) and dbmL.bmp (420x660). All of the filename except L or M is in lowercase. I have no probs now (naming convention was a gotcha earlier). The M.bmp shows up in the sidepanel ingame and the L.bmp shows up in the character sheet.


    Edit: Your folder is good.
    As extra info, using these sizes I have had no problems adding the portraits using vanilla Character creation ingame, EEKeeper and with 'Lefreuts Enhanced UI' mod in-game.

  • LegendLegend Member Posts: 36
    Ah thanks for the tip, I will give it a shot!

    Can you (or anybody) think of any idea why my custom portraits aren't showing up in EEKeeper though? I'm not being dense and there's a button to import them all or something is there?

  • SeeweadSeewead Member Posts: 9
    edited September 2017

    Why do you want to use pictures with such a resolution so very small as 169x266 or even 54x84? They look rather horrible when used on a decent monitor-resolution, don't they? As Gusinda already wrote in the post above: Go for more! You can use pictures with a resolution up to 652x1024. If the game should need it, it can downsize your picture on its own.

    You can see more on this topic right here:

    To the path of your portrait-folder: The path you mentioned should be alright, but for many people it only seems to work if you move your portrait-folder into your game-directory (or better put it in both places). Just give it a try.

    As to your S-pictures: My EE-Keeper only lets me choose two pictures per person (a big one and a small one). Not three pictures. So you wouldn't get any help with EE-Keeper anyway. Or am I wrong here? I guess, there will be a reason for this - maybe nowadays the game only allows for two different pictures? Don't know, seems to be ages since I used three pictures.

    But if this should be really really important for you, there used to be an other (if a little more complicated) way to change the portrait-pictures. You could try it out:

    You have to take the pictures that you want to asign to a certain NPC and give it the right name.
    Then you have to copy this new-named picture in your override-folder (in the game directory).

    The right names for the portraits you can find here:

    Hope it helps, Seewead

    edit: small spelling-error

  • LegendLegend Member Posts: 36
    Ok that IS interesting, so far I had just been following this page, which listed the dimensions I've been using..

    But I am 100% up for better quality portraits, so I will certainly look at the page you mentioned.

    As far as EEKeeper though, yeah it only lets you choose small and medium. But that would be acceptable as the only one you don't choose is the character creation portrait.

    I am familiar with how to do the override thing with NPC portraits (though thank you anyway!) - but the issue I'm having is with my charname player character.

    I really, really don't understand why my portraits aren't showing up in EEKeeper. I will try copying the portraits folder to the game directory and see if that helps at all!

  • ThacoBellThacoBell Member Posts: 10,025
    You can use this site to convert any portraits you want to use to the proper size and format.

  • LegendLegend Member Posts: 36
    ThacoBell said:

    You can use this site to convert any portraits you want to use to the proper size and format.

    Thank you, but mmm, getting the size and format isn't really an issue. I am absolutely fine with using photoshop, I know what I'm doing. I just can't understand why they're not showing up in EEKeeper.

  • LegendLegend Member Posts: 36
    I've got it working!! Putting the portraits folder in the game directory (as well as in the documents folder) has caused the portraits to show up in EEKeeper. Woop! Thank you everyone so much for your help!

  • GusindaGusinda Member Posts: 1,588
    Hi @Legend, Re EEKeeper. I think it may be your path settings for 'User Save Data Directory'. I don't have a copy of my portraits in the games directory and they show up OK. Another thought is that it may be the naming convention used for the portraits. As indicated earlier, I have all lowercase except for the M/L at the end.

    However if it works, it works.

Sign In or Register to comment.