Skip to content

Rasaad quest not firing after all conversations

BGEE v1.3 from Mac App Store, now running on High Sierra.

I am really feeling the pinch on STR with my party, so recruited Rasaad purely to do his quest to get the belt. We have had the critical conversation about his brother, but no matter how long I bounce around the sword coast, I am not getting mugged by the monks that trigger the next stage, when I go to the docks. There have been numerous reports about this in the past that usually seem to be folks not waiting long enough, or not going to the right place. I have been bouncing around for 30-50 in game days now, just trying to trigger this thing, without success.

Is it purely on a timer (that is not triggering for some reason), or Is it just a random chance each time I visit, so I just need to keep trying, and wait for a random number generator to spit out a good value?

(I have shuttled between Nashkel and the docs more than a dozen times now, that route is getting old fast)


  • ThacoBellThacoBell Member Posts: 12,235
    Its not a timer. Once you get the two dialogues from Rasaad, the ambush SHOULD trigger in the docks at night. I have never figured out why its so inconsistant though. Sometimes I get it right away, other times I get tired of trying after about a month straight in game of zoning in and out and give up.
  • GreenWarlockGreenWarlock Member Posts: 1,354
    Thanks, wan't sure about the night bit, so only around 1/3 of my trips arrived by night, so I can try again aiming for that.
  • GreenWarlockGreenWarlock Member Posts: 1,354
    Hmm, just tried bouncing around again, deliberately wandered around the city so that I could visit on every hour through to midnight in case that was a trigger, still no luck.

    Has anyone had success persevering for months of gametime at a go, or do we always give up after a month or so, as it will not happen. now? I think I have invested over 100 days of gametime doing nothing but this now, although cannot be 100% sure when I started.
  • GusindaGusinda Member Posts: 1,913
    Hi @GreenWarlock, have you tried this at all? If it is the same, it appears to be a known problem for 1.3. Not sure if it is fixed for 2.x.

  • ThacoBellThacoBell Member Posts: 12,235
    I still have problems on 2.x, dont know if its that particular, but it is still an issue.
  • ilduderinoilduderino Member Posts: 773
    edited February 2018
    I recall there is a bug so that if you don't get Rasaad to join early before he assists you against that bounty hunter that attacks you after Nashkel Mines then you cannot get the trigger in the BG docks district to work unless the console helps (not me as I am on ipad). It happened to me once and now I always get Rasaad to join on first reaching Nashkel and then drop him for later - have never had the bug since but it really should be fixed as this has now been years!
  • AerakarAerakar Member Posts: 937
    Since I started conversing with Rasaad in Nashkel before the Nimbul fight, I have never been able to repeat this issue. It happened to me regularly prior in 1.3 if I would not talk with Rasaad prior to the Nimbul fight, where he joins in to help you. I have not had this problem in 2.x, but then again I have now trained myself to always at least converse with Rasaad in Nashkel early whether I plan on using him or not. This bug may or may not have been addressed in 2.x.

    On the triggering of the Rasaad docks cut-scene, it is not consistent, same as Dorn's quest not always firing at the bridge once BG opens up. I sometimes have to leave the map or reload a save to get either to fire. But they do in the end always fire. If Rasaad's does not fire within 2 weeks of the last conversation, I would guess it never will.
  • GreenWarlockGreenWarlock Member Posts: 1,354
    Thanks all - my conclusion is mt game is bugged, and I either enable the console to fix it, or soldier on without. I have an aversion to the console almost as strong as to modding (preferred playstyle, no judgement on others :)) and this is not gamebreakinig - just frustrating that my party of original NPCs will not have access to some EE content in order to snag an overpowered item that we could always beat the game without. I'm good, time to swap Quayle back in for Rasaad, and wonder what happened to my front line :)

    It would be nice to know if this issue is going to be resolved before BGEE 2.5 hits the Mac App Store, or if it has already been fixed in the 2.x series?
  • BelacRLJBelacRLJ Member Posts: 51
    I am having the issue with EE 2.5. Does anyone know what value the global variable for Rasaad's plot has to be to get it to trigger?
Sign In or Register to comment.