Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

We need your feedback on the new forum text editor switch.
Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Toolset hell - Creature properties crash

flyinghtcherflyinghtcher Member Posts: 21
edited June 18 in Builders - Toolset
Ohh jeeze, I tried working with the toolset from Beamdog, and it seems to work fine on mods created with it, but I wanted to add some work to an old mod with CEP 2.65 and it crashed 80% of the time I tried to view Creature properties, So I decided to try it on a NON cep mod that was an old one, crashed about 50% of the time.. Had to hack the mod I wanted to work on and drop the version down to 1.69 so I could use my GOG version. works fine now in GOG's, but the Beamdog one is just Garbage to me. RANT over.

Edit, so it even does this with a clean fresh mod made with the NWN EE toolset. Just not as often.

Post edited by flyinghtcher on

Comments

  • dTddTd Member Posts: 161
    Sorry you're having such a hard time and I'm not really sure why you are. My experience is much different after moving quite a large pw module over from cep2.65 nwn1.69 to EE. Everything was smooth as butter and I find the EE toolset much more responsive. This makes me wonder what exactly is different about your modules from mine?

    DerpCityflyinghtcher
  • TerrorbleTerrorble Member Posts: 52
    My mod was working fine under WinXP with my Radeon HD 6850 for years. Using the same card in Win10 with that card caused it to crash nearly every time I viewed properties. I've since gotten an nVidia card and have 0 problems so far. (I too am finding the toolset nicely responsive.) Any chance you have a Radeon card?

    flyinghtcher
  • flyinghtcherflyinghtcher Member Posts: 21
    edited May 12
    I'm using a Radeon HD 6900 at the mo. Windows 7 - 64

  • TerrorbleTerrorble Member Posts: 52
    I have a laptop that I could switch my building over to and was just about to upgrade the desktop anyway so I didn't do any troubleshooting, really. If I had to, however, I'd see what previous driver versions they have for those cards.

    If it is similar to what I had going on, I didn't have any trouble playing the game with the 6850 even under Win10-64, just using the toolset.

    flyinghtcher
  • flyinghtcherflyinghtcher Member Posts: 21
    edited May 15
    Think I'll just write in in 1.69 for now, I hope they can fix what ever is causing it. Even if they can the mods going to be more backwards compatible if I do it this way. Just a shame cause I wan't to play with all the new toys.

  • raz651raz651 Member Posts: 175
    I can't find it, but I am sure I read about this sort of problem before and it was suggested that when you first opened up and older mod in the toolset you should immediately save it before you started working with it.

  • dTddTd Member Posts: 161
    One other thing I found when first working on a module in nwnee toolset, script debugging is enabled hence it doubled the size of my modules, had to disable it and delete the debug files manually.

  • flyinghtcherflyinghtcher Member Posts: 21
    raz651 said:

    I can't find it, but I am sure I read about this sort of problem before and it was suggested that when you first opened up and older mod in the toolset you should immediately save it before you started working with it.

    I tried this it Had no effect

  • PhantasmaPhantasma Member Posts: 21
    I had the same problem 100% of the time with bringing up either the Creature or Door properties window. Replacing my fairly old Radeon card with a relatively cheap Nvidia card resolved the issue. Not an ideal or optimal solution, but it's what worked for me. I'm sure it was related to those windows displaying '3d models' in the main 'pane' - you could try raising a bug and uploading your crash files to see if Beamdog can assist.

    pscythedTd
  • dTddTd Member Posts: 161
    It seems most of the toolset crashes are from radeon users.

  • pscythepscythe Member Posts: 116
    edited June 15
    Hmm... I got an integrated Intel GPU and the toolset crashes just like it was a Radeon. lol The game works fine though until v1.75 and its area transitions. In the Toolset, creatures either just flicker or not displayed at all in the preview window, they show up correct in Edit Properties but then crashes after a few views or edits.

    Phantasmaflyinghtcher
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 15,848
    edited June 15
    Please, make sure these crashes are reported at support.baldursgate.com with details about how it happens, your system spec, and a module if it is only crashing with one specific module.

  • flyinghtcherflyinghtcher Member Posts: 21
    Already done Julius, and you thank'd me for it back on the 21st May. :wink:

  • pscythepscythe Member Posts: 116
    Disabling Use Environment Mapping on Creatures and Items in options seems to do the trick. Haven't had a crash since I turned it off. In hindsight it looks pretty obvious. LOL



Sign In or Register to comment.