Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

ToB (SPOILERS) Dorn Quest Bug

Thank you Beamdog for resurrecting an all-time classic and making it even better!

On to the bug:

So, after finishing off Yaga-Shura I kill off my alternate reality self and his party of ne'er do wells in the pocket plane. I remember reading in a guide that this is a good time to do some of the NPC's quests (Hexxat, Rasaad, and Dorn) so I pick up Dorn and drop Keldorn (I had Dorn in my party previously - meaning, I recalled him through the portal - but his quest wouldn't initiate no matter how much I traveled on the world map so I kicked him and had Keldorn back in my party to do the Yaga-Shura quest) and he says his usual, "So, you've come to your senses," etc. and rejoins my party. We go through the pocket plane portal back to Faerun and it dumps me in the siege camp just outside of Saradush. I walk up to the corner of the map and click to bring up the world map. I click on Watcher's Keep and hit Travel. Lo and behold, Dorn's side quest cut scene opens up - looks just like an ambush area - but a funny thing happens: Dorn says something like, "Hold! Something approaches" but when the dialogue box goes away to play out the scene, Dorn is the only one of my party visible on the screen (and he can't move from the lower left corner). Oddly, the camera pans, as if it were following a party of six adventurers as they walk up the path to meet the ambushers, only my party didn't make it onto the scene - only Dorn, and he can't move!

I've tried to work around this by clicking on different destinations on the world map but that doesn't seem to matter. I've also tried selecting my main character from the sidebar (he's just not on the screen) and hitting his pocket plane ability which brings us all back to the plane but when I go back, Dorn is still in the corner - stuck - but my main character is able to move about now. Weird. And I didn't see anything like this in any of the other forum discussions so I thought I'd write it up here to see if anyone else has run into a similar problem.



  • ShalickGyroShalickGyro Member Posts: 1
    I have also had this problem. I try to travel on the world map, I end up in the place where the planetar attacks you, Dorn has his short dialogue stating that something is approaching, and then he gets stuck. Only my main character and Dorn are visible, and neither of them can move. I've messed around with changing party formation and switching which party slot Dorn is in, since I've seen that resolve some other similar issues, but it didn't accomplish anything. Anyone out there have a solution?

  • BorekBorek Member Posts: 513
    i have noticed that 2.5 has an occasional bug where if you have more than 1 member in the group it will sometimes select exactly the same spot for a move command when you move 2+ chars at once, resulting in them rarely coming stuck occupying the same spot and needing a console teleport command to get them unstuck. Unsure if it's related, but if you are on 2.5 perhaps it's linked?

  • trebuchettrebuchet Member Posts: 7
    Hmmm. That's interesting. What is that console teleport command, exactly? I'd like to give it a whirl and see what happens.

  • Joan_DaroJoan_Daro Member Posts: 109
    trebuchet said:

    Hmmm. That's interesting. What is that console teleport command, exactly? I'd like to give it a whirl and see what happens.

    Ctrl + J when debug mode is on.

  • adam777adam777 Member Posts: 14
    Just encountered the same bug.
    Area seems completely broken.
    The most I managed was going in and out of the pocket plane, which caused dorn and my protagonist to appear in walking state (the rest of the party was nowhere to be seen).
    After finishing them off with only those 2 guys, on next attempt to reach the area, no member of the party is available.
    Pretty much a show stopper...

  • trebuchettrebuchet Member Posts: 7
    So I may have inadvertently come across a work around.

    Taking Borek's idea that teleporting the party out of their "stuckness" using the console, I opened up the console - but instead of using the on-screen teleport command - I scrolled down on the location menu that pops up and found "Dorn - Forest Clearing". I selected that and hit TRAVEL and voila! My entire party newly entered the map, not in the lower left corner but from the northwest. The encounter played out exactly to spec and I finished the quest. At the end of the quest, however, I stumbled into yet another bug - but this time, not game breaking.

    After you leave Lunia, your party gets dropped back onto the forest clearing where the portal used to be. You have a little dialogue with Dorn then regain control again. I moved my party to the eastern edge of the map and clicked to leave. The world map popped up, per usual, and I selected Amkethran (the forest clearing doesn't show up on the world map, just like an interrupted ambush scenario) but instead of dropping me in Amkethran the darn game dropped me back onto the forest clearing...with my party stuck in the corner AGAIN! So I quickly brought up the console and selected Amkethran from the list of locales and got out of there. Whew!

    1) The bug may be specifically related to a bug I've heard mentioned before where Dorn's forest clearing keeps occurring for people well after they've completed Dorn's quest. Like, every time you click on the edge of the map and select a destination, you would end up - EVERY TIME - back at the forest clearing.

    2) *SPOILER* In SoA, my Dorn rejected both demonic patrons and ended up a free ork, beholden to no one. He gets nerfed pretty hard (imagine a paladin abandoning his deity, right?) but it was a narratively satisfactory conclusion to Dorn's path for me. However, in ToB, Dorn is again shackled to a demonic power. While in Lunia, for example, he demands that we despoil the Sacred Tree because Azoteth requires it of him. I found this terribly annoying and totally out of character to the Dorn in my particular storyline. This led me to consider that perhaps the ENTIRE Dorn quest in ToB is just buggy and rather incomplete.

    3) Hoping the Neera and Hexxat quests turn out better (not doing Rasaad because I'm romancing Viconia).

    Anyways, hope this helps until a new patch comes along!

  • helmo1977helmo1977 Member Posts: 364
    Same happens here. I am playing on ipad version

  • helmo1977helmo1977 Member Posts: 364
    And the problem with ipad is that I have no idea how to use console, ot if it will work

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 21,465
    @helmo1977 Please zip and attach your save in the troubleshooting area so that we could help.

  • MarinaMarina Member Posts: 2
    I had the same problem and managed to solve it by getting to the cleaning from a different direction. Unfortunately it only worked for the first time and now I'm stuck in Amkethan.

  • Paulan969Paulan969 Member Posts: 13
    This bug is so common, hope they will fix it eventually! Had similar situation last night! Every character of my party was put in same spot on the map corner. I was able to move only my hero fortunately its Kensai so I was able to solo this planetar and its companions, after dirty work dorn talk to us even if we r on the other side of the map, and the portal opens anyways. Also its possible to go through with 1 person only and it teleports whole team. Ofc its not perfect solution but it worked for me.. so if you have some strong solo fight character you can be able to make it 'good'...

  • GLoBaLGLoBaL Member Posts: 13
    Just encountered this bug after leaving watcher's keep on way to Amkethran.
    We stuuuuuuuuuuuuuuuck

  • iosfrustrationiosfrustration Member Posts: 153
    Happens to me all the time on iPhone, so frequent that it almost doesn’t register.
    What seems to happen is that two chars occupy the same space, then neither can move because each is in the others way.
    iPhone means no console, so no ctrl-j. It’s either a load from quick save, or select one of the stuck characters and continuously click randomly until they become “unstuck” and move somewhere else. This breaks the logjam and everyone moves normally again (for a few minutes until it happens again)

    This whole “characters can’t move through other characters”, combined with rotten path finding was a common and crappy anti-pattern for late 99’s and early 2000’s games.

  • ZaxaresZaxares Member Posts: 1,208
    I also got this bug in Dorn's ToB quest. Since I play on PC I was able to rectify it with Ctrl-J, but yeah, if you were on a console and got this bug I think it would be a showstopper since the quest forces you to spawn in the map when you leave Amkethran and there's no way to avoid it. :/

  • BCaesarBCaesar Member Posts: 321
    @helmo1977 Please zip and attach your save in the troubleshooting area so that we could help.

    I had the same bug. I attached my saves, both a save when it's happened already and the auto save right before I got there. I also get characters stuck on each other before but always managed to eventually get them apart, but not this time.

  • ThelvarThelvar Member Posts: 1
    Hello currently playing on my phone and completely stuck offscreen and cant move nor go to any other area. I have tried even getting rid of everybody in my group and still no go. This bug has to be fixed soon please.

  • sakurazukasakurazuka Member Posts: 1
    I found quite easy workaround. When bug happens simply use your Pocket Plane then return. My main character got unstuck so I could do encounter (solo). Luckily you can easily win battle by summonging planetar and waiting (just like all new character quests in this game).

Sign In or Register to comment.