Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

BGEE Long Saves and Map Movements

SocratesB1SocratesB1 Member Posts: 4
Hi Everyone!

So, I've looked at a few other discussions concerning this issue, and I have tried some of the mentioned options, but nothing seems to have worked.

I'm going to target @Gusinda because the ideas that I found on other discussions mostly originated there. I'm not too much of a computer whiz, but I used the link you provided in an older discussion to download what I assumed to be DirectX 9.0c (it specified that it was the June 2010 edition or something). I then texted the game, but nothing really changed.

I think the main difference here and why my problem persists is perhaps because I am attempting to run a multiplayer game with only myself controlling six characters, as opposed to a single player game where this may have solved the problem.

After the DirectX solution alone did not work, I attempted to switch the two lines in baldur.lua as suggested (SetPrivateProfileString('Graphics','Backend','0') --> SetPrivateProfileString('Graphics','Backend','1'). However, when I did that I was unable to click anything on the screen that displayed my characters on which I would check their "ready" boxes. Therefore, I was never able to really check if that method was a solution.

I am running Windows 10 on a laptop that is certainly not stellar but does have plenty of RAM, hopefully somebody out there can help. It's not detrimental but it certainly is annoying.

Thank you all,
Socrates

Comments

  • GusindaGusinda Member Posts: 790
    Hi @SocratesB1, welcome to the forum. I feel I must say something philosophical but unfortunately I can't speak Greek...

    With regard to your problem, we can only but try... It shouldn't be a concern that you are running multiplayer (MP) but I will get you to try single play mode anyway to see f the problem still exists.
    I also suspect that your system is enough to run it (simply based on running Windows 10 unless it is Wundows 10S). There have been some problems with Intel Graphics where the problem just doesn't go away but Beamdog are working that.

    A couple of quick questions then some requests to get us started:

    - Has this always been a problem since installation or has it started recently?
    - If you have the problem in MP, does it also appear in single player mode?
    - Are you using any cloud synch at all (One Drive, Google Drive etc) or any cloud saves for your game? If so, could you disable and try without them.
    - When you started in DirectX mode (backend = 1), you said that you were unable to tick anything. Was it greyed out or just would tick when you clicked it. If the later, could you try again and see if it is a delay (leave it for a minute or two) or just doesn't tick at all.

    Some requests:
    - Could you run DXDIAG (by clicking on the search 'magnifying glass' near Start and typing dxdiag), let it do its scan then 'Save All Information...' to a text file and upload.
    - Could you also copy your baldur.lua as baldur.txt and upload that as well.

    I think this is a good starting point to understand your system, then we can try some fault finding. If you need any assistance in uploading, then just holler.

    Thanks
    Gus

  • SocratesB1SocratesB1 Member Posts: 4
    Wow @Gusinda, you're pretty quick. So, to answer your questions.

    - When I started playing the saves worked just fine, but they have gotten increasingly longer the longer I play, and the cross-map travels have gotten slower the longer I play and the more places I explore as well.
    - I haven't tried single player on this computer yet but I'll have to try it soon to check it out, and I'll update this post when I do.
    - I'm not using any cloud saves to the best of my knowledge, at least, I haven't set anything up to do that.
    - About the ticking, nothing was greyed out. There was a massive delay between when I clicked and when the box became checked. Sidebar, if this is understandable, I noticed that I would move my cursor to the box, and the cursor would move on the screen. However, the little description "scroll" - the one that pops up to explain what certain buttons do if the cursor is left there for a while - would pop up in a completely different part of the screen. It was almost as if the game didn't realize I moved the cursor even though it moved on the screen just fine.

    Hopefully those answers and the attached files can help you to help me figure this out. What a process!! I'll let you know how that single player goes when I get a chance.

    Thanks for all the help!
    Socrates

  • GusindaGusinda Member Posts: 790
    edited August 12
    Thanks @SocratesB1, had a quick look and it looks as if only the sound driver appears out of date. I will make a post later today with an update for you.

    As far as specs go, I have a tablet that has 2gig less memory and runs at 1.4GHz (Atom instead of Celeron processor) which is similar to the one you have. Is there any chance you could also zip up a saved game (or all of them if there aren't too many) that is having a problem and I will try it out on my system.

    I forgot to ask which version of the game are you playing. 2.3.x or 2.5.beta, and from where did you buy it?

    Also, another test for when you try the single player mode:
    - could you rename your 'Documents\Baldur's Gate - Enhanced Edition\mpsave' folder to mpsave.old. This will keep any possible corrupt saved games out of the initial load and give you a clean start. If the single player mode works fine, then could you also try start a new multiplayer game.
    - Do you use Quicksave or Save Game method to save your games? Quicksave has been known to corrupt some games in the past.

    You are playing in OpenGL mode, but I am still keen to try later on to move the game into the DirectX backend so later (after I try on my system) on I will give a procedure on how to try to get there without the big delays.

    Thanks
    Gus


    Edit:
    For your sound driver, if you go here, should should be able to download the driver that will take you to v6.0.1.7576. Once that is updated, reapply DirectX 9.0C.

    While you are here, you could probably update your Synaptics Driver (under Mouse) as well. It shouldn't make a difference to the speed of the game though...

    Your Bluetooth driver could also out of date as the version here is dated 31 May 2018. If you don't use BT, then I wouldn't worry about it.

    Post edited by Gusinda on
  • SocratesB1SocratesB1 Member Posts: 4
    Ok @Gusinda, I've had a bit of a chance to look at some of this.

    - I bought the game from Steam, and I'm pretty sure it's the 2.5.beta version just based on my Steam Settings (always updating games) and the current version on Steam at the moment is 2.5.beta.
    - For single player mode, the problem is there. Although I haven't played through it too much. Nonetheless, I still plan to do the whole DirectX 9.0c thing if I can. But - just so you know - I tested single player after switching the lines in baldur.lua. The game was simply very slow. My characters moved slowly, enemies too.
    - I have used both quicksave and save game to save my games (MP and SP), and they both take a heck of a long time to finish saving. I used quicksave other times I played the game on different computers and on disc versions with no problem, but if that's the issue then I can switch to just using save game.
    - I'll attach a zip file for you of my game (as long as you don't make fun of it), that way you can check everything out for yourself.
    - The other thing I went ahead and did is, after I updated the drivers, checked to see if I could change the lines in baldur.lua. But once again, the ticking boxes issue occurred, so my problems continue.

    Thank you so much, and good luck with the zip file,
    Socrates

  • GusindaGusinda Member Posts: 790
    edited August 16
    Hi @SocratesB1, thanks for that. I have tried the saved games and get the slow down on saves and the slow down when in DirectX mode using your baldur.lua. This is good because I have never had this problem (that couldn't be fixed by going to DirectX) before, but I didn't play much of 2.3.x on the tablet, mostly 1.3.x. I bought a Hybrid and use that now when I need a portable gaming fix.

    I don't have the Beta installed (bought BG series from GoG), so I reinstalled BGEE on my tablet without SoD as I am sure that you also don't have SoD installed; doesn't work with the Beta.

    I am now playing with various fault finding methods to try and resove the problem.

    Things I have tried already:
    - I created a new game with a full self made team created with Multiplayer, but played as Singe Player by copying the saved game into \save folder from \mpsave. All worked well until I made a couple of Quick Saves, from then it was in slow save mode all the time (using OpenGL). It even was slower that normal when saving using DirectX but quicker than OpenGL. Will try with new saved game again, but only using normal saved mode and see how that goes in both OpenGL and DirectX.

    Have deleted the baldur.lua and let it create a new one on install. Suprisingly the games saved at normal speed until I reloaded. Tried deleting the file again with similar results. Next step here is to try again to see results and if the same again, go through the each line and "remark or delete" them out until I can see if any actually make any difference. Back to square one if none do. If one does, then play around with the setting and see.

    Also need to try different drivers to see how they go.


    Things you could try:
    - With Windows 10, there is a mode called 'Gaming'. Due to the speed of your PC, you could try turning it off in Settings (unless of course you use it to stream your games). That way, it isn't taking CPU time...

    - I am unsure how you start your game. I don't use Steam so I can only guess that you might use it's launcher to start BGEE. If you do, you could close down the Steam Launcher (again so it doesn't use the CPU) and start the game directly from 'baldur.exe' in the game folder. If you are not aware of where it is installed, it should be in the '...Steam\steamapps\common' folder (which could be be in the Program Files folder) The shortcut to start should tell you. I am not sure what happens here with Steam Achievements; if they matter.

    - You could also start without the Internet connected if you don't alreay. If you find that you can't start BGEE due to Multiplayer requiring the network, then copy the saved game into your \save folder and it will start as a normal Single player game. This would prevent any synching (if anything does) of folders.


    Will let you know if I get better results.
    Gus

    Edit: Spelling

    Post edited by Gusinda on
  • GusindaGusinda Member Posts: 790
    edited August 16
    @SocratesB1, well I have tried all manner of changes. I seem to get some to response when I update the drivers and reinstall OpenAL but that is short lived. After a couple of saves (quick or named), it reverts to slow saves again...

    This is likely to be the problem that has been ticketed...

    Sorry
    Gus

  • SocratesB1SocratesB1 Member Posts: 4
    @Gusinda,

    You have done wonders. I'm sure I'll survive long saves - it'll teach me patience and I'll just have to get better at the game so I don't die as much and don't have to reload. I appreciate everything you've done and all the time you've spent.

    Thanks for all the help, despite the result,

    Socrates

    Gusinda
Sign In or Register to comment.