Skip to content

[ALL GAMES] Yet another no sound fix

FicjuszFicjusz Member Posts: 20
edited February 2021 in Troubleshooting
I had no sounds in PST:EE, so I've tried all methods of fixing it described in this thread. It's now closed, but it's still the first thing that pops up in Google when trying to search for this particular issue. Unfortunately none of the methods worked for my HP laptop. I managed to found another which did the trick for me. It goes like this:

1. Download the latest OpenAL binaries ("openal-soft-1.21.1-bin.zip" by the time I'm editing this post) from this site.
2. Unpack it and go to \bin\Win32.
3. You'll find a file named "soft_oal.dll". Copy it into the game directory.
4. Rename "soft_oal.dll" to "openal32.dll".
5. Open the game and see if the issue is fixed.

...Or you can just simply download the file I've attached to this very post and put it into the game directory.

And - nope, installing open AL from the Creative Labs or putting the original openal32.dll file into the game directory didn't work in my case; it allowed the game to start but the sound wasn't there. And I don't use any external sound card whatsoever, only the thing that was built-in.
Post edited by Ficjusz on
JuliusBorisovMalkieGusindaLeiiberanoir

Comments

  • MalkieMalkie Member Posts: 1
    edited May 2020
    I had to register just to say thank you very much. Took me all day to find your post, tried lots of other solutions, but this one worked perfectly. Thank you!
    JuliusBorisov
  • WaifuGateWaifuGate Unconfirmed, Member Posts: 1
    Registered just to say thank you for going through the trouble of making the file accessible and explaining how to apply it! Struggled with no sound for a few hours until this post fixed everything!
  • VinlandrVinlandr Unconfirmed, Member Posts: 1
    I love you OP
  • LeiiLeii Unconfirmed, Member Posts: 1
    DAMN! i might be really late but THANKS SO MUCH for the Fix, been wanting to play this game REALLY BADLY but the no music/sound thing was killing it for me, now i can enjoy it, ty again!
  • beranoirberanoir Member Posts: 1
    thank you so much
  • FicjuszFicjusz Member Posts: 20
    edited February 2021
    Thanks for your kind words. I hope that your posts will make this thread more accessible for other people with the same issue. I'm surprised that it still persists and Beamdog did nothing about it.
    I've edited the first post a bit here and there to correct some typos and whatnot since I'm not an native English speaker and I'm still impoving. I've also updated the link to the OpenAL binaries.
    Please continue bumping the thread so it can help more people.
    JuliusBorisov
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 22,139
    The 2.6 patch now makes the game install OpenAL as part of the game install.
  • mdibfilhomdibfilho Unconfirmed, Member Posts: 1
    Simply genius! Amazing how this solution still works after six years. I've tried every other solution available but this was the only one that did the trick. I too subscribed just to say thanks!

    P.S. I used the /bin/Win64 soft_oal file. Also, this seems to work on both steam and gog version.
  • DrkMatr1984DrkMatr1984 Member Posts: 2
    All of this still didn't work for me, but I had Intel Video Audio through HDMI cord. I found out there's a bug with openAL and the Intel drivers so I just plug in headphones or use a Bluetooth speaker and the sound works!
Sign In or Register to comment.