Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

NWN: EE - Constantly crashing - probably on model load / armor change

Hi Beamdog devs,

I've just purchased Neverwinter Nights: Enhanced Edition but unfortunately it keeps crashing, it looks that any armor change or encounter trigger can cause that. It looks like it's struggling to load models properly.

I can crash game immediately from prelude by taking off / changing my default armor. I can leave prelude room, speak to tutorial dwarf from the shop (next area door opens fine), if I zoom out or change the angle to see the open room nothing happens but when I approach it it crashes (I think an encounter is spawning NPC there). Same thing happens in both expansions. The Hordes of Underdark cinematics works fine. I can also fight the initial assassin fine, only when I leave the room it crashes immediately.

I use Windows Defender with no Access Control, no other AV software running. No custom content or modules have been loaded yet. Stock installation.

My rig:

Windows 10 x64 Pro OS build 17134.523
Intel Core i7-3770K 3.5 GHz
nVidia GTX 1070
16 GB RAM
Samsung SSD
Native resolution 2560 x1440
Acer Predator monitor with G-Sync
Asus D2X sound card

What I've tried so far:
- Lowering all graphics details, textures and in-between combinations (some low some high), including advanced graphics settings in nwn menus
- Lowering resolution, changing menu scaling
- Tried with and without V-Sync
- Tried with and without G-Sync
- Tried with refresh rate of 60 Hz and 120 Hz
- Tried disabling sound cards in Device Manager in case it was down to sound card
- Tried updating nVidia graphics drivers to the latest (it was running stock drivers without GeForce experience initially from Windows Update)
- Testing different campaign modules and races
- Tried BETA (8184) and Developer Steam builds
- Getting OpenAL drivers from their website

Please help!

Regards,
Marcin

Comments

Sign In or Register to comment.