Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

NWN EE bugs

Hey, I've been streaming NWN EE everyday at twitch.tv/tamaxlia and I've encountered one urgent bug and one that is just annoying:

Lich doesn't open Door:
At the end of the Luskan Mage tower I freed the lich and he was supposed to open a door to the inner sanctum, to face Maugrim. He teleported away and the door is still locked. I have googled to try to find a solution and didn't manage to get anything. Unfortunately this meant I had to finish the stream early and my veiwers were quite disappointed. Is there a solution to this or a console command to get around it?

Paladin mount bugged:
A couple of days ago my mount started moving at normal speed instead of mounted speed. I tried dismounting and it wouldn't do that. I tried mounting as I thought the game might think I had dismounted and that doesn't fix it. I also tried summoning a new mount as I thought it might be a graphical error and my mount was dead but that didn't work either. This one doesn't really matter too much except for quality of life. I have not tried dying to fix it yet because of the XP penalty.

I'm hoping to stream it again first thing in the morning so if there is a solution please get back to me asap. I don't want to have to stream Hearthstone. ;p

Comments

  • TressetTresset Member, Moderator Posts: 7,184
    edited February 11
    Ok, I made a custom script for you that will forcibly break that door when it is activated. Download the file I attached and extract its contents to the game's override folder. Once that is done, load your save file and open the console by hitting the tilde key and type "Debugmode 1" to enable debug mode. Next, open the console and type "dm_runscript breakdoor". This should destroy the door and allow you to continue. When that is done, disable debug mode by typing "Debugmode 0".

    The horse issue sounds somewhat familiar to me, but I don't remember how to fix it. I would suggest dismounting and unsummoning the mount and summoning it again to see if that works. Failing that, I would suggest asking @Proleric, who I seem to recall being something of an expert on horses.

    TorgrimmerJuliusBorisov
  • TamaxliaTamaxlia Member Posts: 4
    Thanks very much! I'll give that a go in the morning. Dismount doesn't work on the mount I use the command and it just stays mounted but it's not that big a deal.

    TorgrimmerJuliusBorisov
  • ProlericProleric Member Posts: 417



    The official fixes are here.

    I'd try x3_fix_horse first.

    TorgrimmerJuliusBorisov
  • TamaxliaTamaxlia Member Posts: 4
    I had to work out that it was DebugMode not Debugmode but after that they both worked! Thank you very much!

    JuliusBorisov
Sign In or Register to comment.