Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Android PST Download failed because you may not have purchased this app

thebeardedninjathebeardedninja Member Posts: 13
Hi, I have been trying to install Planescape on my Redmi Note 7 and it appears in the play store fine. Once installed I get the error download failed because you may not have purchased this app. I have checked all the forums and spoken to Google who have confirmed my purchase in October last year, followed all steps I can find, clearing data/cache on the app and google play. Rebooting each step etc. Google logged on to my phone and followed the steps and they couldn't resolve either as it doesn't appear to be a licence issue.

Can you please help as I'd love to play the game I purchased but nothing seems to be working and I've seen the issue appear on the forums but nobody appears to have a fix.

c911zeng82wm.png
s4rnu8pnbibw.png

Comments

  • thebeardedninjathebeardedninja Member Posts: 13
    Just to reiterate I've scoured and tried all the links in the forum to various fixes, the only one I'm unsure of is removing any app that might conflict as one guy had a backup app that stopped it working but I don't have any apps like that installed. Has anyone fixed by removing an app and if so what app?

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 18,011
    Hello! Please try these suggestions:

    https://forums.beamdog.com/discussion/comment/1042868/#Comment_1042868

    It happens sometimes on GP for some reason.

  • thebeardedninjathebeardedninja Member Posts: 13
    Yes as mentioned I've been through all the fixes on the forum and still have the issue. I don't use any downloaders, I've reinstalled about 6 times so far and same issue. I've rebooted in between each step, I've cleared the data and cache, I've cleared Google Play, I've spoken to google and they've shared my screen while I install and seen the issue. I've tried setting the clock to manual (It was the correct time) and none appear to be working unfortunately.

    JuliusBorisov
  • thebeardedninjathebeardedninja Member Posts: 13
    To me it seems like the verification check on the obb file doesnt appear to work, I've double checked and the location it installed from the play store appears ok, it's main.566.com.beamdog.pstee.obb in the come.beamdog.pstee folder. I've tried copying to SD just on the off chance and no change. Ive tried without wifi and data but it just doesn't want to verify the data installed from the store. I'm really at a loss and it would be a shame to lose out on a great game that I never managed to play and that Ive paid for.

  • thebeardedninjathebeardedninja Member Posts: 13
    So according to that link would you recommend I try and find the files from another source and not google play?

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 18,011
    What does Google say - because it reads like a GP issue?

  • thebeardedninjathebeardedninja Member Posts: 13
    edited June 7
    Google said they were unable to help and to contact yourselves. They screen shared and followed through the download from the store, the install and then the error. They also e-mailed confirming the fact
    Thank you for contacting Google support.

    I'm Peter, the support representative with whom you had a chat earlier today. As promised, I wanted to follow up with you over email.

    I understand that you're seeing an error message, which is asking you to pay again ignoring the fact that it was already bought. Please be assured, I've tried best of my ability to help you with this.

    Firstly, I must appreciate all your efforts in performing all the troubleshooting steps and I'm glad you were able to download the app. However, I'm sorry to see that it was asking about the purchase when you open the app.

    I've gone ahead and checked this with my resources and I can confirm that you've purchased this app in question. Here are the details:

    Planescape: Torment: Enhanced Edition purchase from Google Play for 1.79 GBP (order ID: ****) on date 10/2/18 was Charged.
    At the outset, please reach out to the app developer and let them know about this situation. Rest assured, all of our developers know that we expect them to support their apps, respond to user questions about paid apps or in-app purchases in a timely manner.

    You can contact them at: [email protected] Also, you may view their website. I'm positive that the developer would be able to help you further in this regard.

    If you've any other query, please write back to me. I'd be happy to help.

    JuliusBorisov
  • thebeardedninjathebeardedninja Member Posts: 13
    So no response? I'm at a loss on how to resolve this... can you confirm if you're still looking into this or have I wasted my time trying to get it working?

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 18,011
    I've asked our dev team about this but haven't heard back. The previous list of suggestions was an extensive list straight from our QA, who looked at the issue many times. This is a sad situation.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 18,011
    Have you checked your android device? Sometimes games install data incorrectly due to a misplacement of the folder, so it might be the case.

  • thebeardedninjathebeardedninja Member Posts: 13
    Yes I've checked the location in android obb and all appears ok assuming the correct location is com.beamdog.pstee and the file is main.566.com.beamdog.pstee.obb. I'm really at a loss as all appears ok but it certainly seems like it's not checking the correct data location, I've removed all cache and data, reinstalled many many times and this keeps occurring :(

    JuliusBorisov
  • DoubledimasDoubledimas Member, Mobile Tester Posts: 1,159
    Maybe this is also a solution here?

  • thebeardedninjathebeardedninja Member Posts: 13
    Thanks, I had a look but I don't get the option to purchase on the play store just to install. I guess if I remove the cache for the store after uninstalling I might be able to catch it but I don't think the licencing works the same way as on ios.

  • thebeardedninjathebeardedninja Member Posts: 13
    Still no joy today.. same error. Can someone confirm that the obb file and location in obb directory are definitely correct please? The only other solution I can see is if Google will refund me the game and cancel the licence then I try to rebuy it as I honestly cant think of a solution to this. There is a lot online but most if not all end up with no solution. This is the only game I've had this issue on, all others that require verifying the data files on first install are fine.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 18,011
    Apps should download into the "ops" folder to the phone. If the app is in the "downloads" folder, it is recommended to install a file manager to copy the data from the downloads folder, extract it, create a folder with the exact same name in the ops folder, and paste the data into that

    Have you also cleared your cache? Go into Settings > Apps > Google Play Games and Services > Clear Data

  • thebeardedninjathebeardedninja Member Posts: 13
    I haven't downloaded the app per se, I've installed from the Play store so the data is located in android/data and android/obb and clarified the locations a few posts up.
    Yes I have cleared my cache and also data and logged back in etc but still no joy

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 18,011
    edited June 13
    OH MY GOD!

    This is so good to hear. (don't forget to update the Reddit post ;))

    Enjoy the game!

  • thebeardedninjathebeardedninja Member Posts: 13
    I have done as well, thank you for your patience and responses I really appreciate the time everyone took out to suggest fixes. So pleased I can get stuck into this amazing classic once more!!

    JuliusBorisov
Sign In or Register to comment.