Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[BG2TOB] mouse cursor gets out of the game screen in 3D mode

nhesterrnhesterr Member Posts: 3
edited August 21 in Troubleshooting
Hello,

I have a BG1 Saga running on BG2's engine with easyTuTu, hence the tag in the title. I have two displays connected to my machine, with the second screen being on the left of the main screen. When I run the game and move the cursor to the left side of the screen, the screen won't scroll left, instead the cursor exits the game screen and lands on the second display. This only happens in the 3D mode, as if that was a "fullscreen windowed" mode, but when I click anywhere on the second screen, the game minimizes. Is there any fix for that to hold the curson in the game screen? I tried finding some on my own, but didn't succeed.

Thanks,
nhesterr

Comments

  • GusindaGusinda Member Posts: 1,564
    HI @nhesterr, although I don't have it installed, I recall having the same problem.

    From memory (and a poor one it is)... the game needs to start in full screen mode on the primary screen, and you need to stay playing the game. If you where to ALT-TAB out of the game, it loses focus on the screen boundaries and remains that way (even when you ALT-TAB back into the game) until you restart. If you want to ALT-TAB for some reason, then you can still use your keyboard keys to travel around the area. Painful I know...

    Are you using the Widescreen mod and the DDRAWFIX?

    Gus

    JuliusBorisov
  • nhesterrnhesterr Member Posts: 3
    Hi @Gusinda, thank for answering. Unfortunately, the issue is present when I start the game. I have even disabled the intro movies to go directly to the game menu, and the cursor is already able to move outside of the game. I'm using Widescreen mod, but the issue was already present before I installed, with native 800x600 resolution. I haven't installed DDRAWFIX as to my understanding it fixes some rendering issues only, plus it disables vsync.

    Thanks for your help,
    nh

  • GusindaGusinda Member Posts: 1,564
    Well... @nhesterr, I installed last night just to see if my memory was as I thoguht. It was, it is a very poor memory!

    Couldn't get the mouse cursor to stay focused at all so I am thinking that you would have to use a one of the third party programs (like this) that make the cursor stay on a particular window. No good if you want to have the other window operating for some reason as well.

    Although, it would be easier just to disable the secondary monitor while playing (WIN-P if you are using Windows 10).

    Gus

    JuliusBorisov
  • nhesterrnhesterr Member Posts: 3
    That's a great tip, thanks!

    GusindaJuliusBorisov
Sign In or Register to comment.