Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

IWDEE Certain areas in Kuldahar are inaccessible

Hi,

I cannot enter the following areas in Kuldahar:
  • Oswald's Laboratory
  • Temple of Ilmater
  • Townsperson's home next to the tiny bridge to the East
  • Townsperson's home to the right of the Root Cellar tavern
When I click the entrance for one of those areas, and when my party reaches the moment where they would normally enter the area, all ambient sound and sound effects get muted, and my party continues to shuffle and move about the entrance as though I had clicked just off the correct point (even though I had not). Opening and closing the map restores the sounds.

If I use the cheat console to instant-travel to the above areas, they're empty of NPCs, and all exits are disabled, meaning the cursor doesn't change when I hover it above where an exit should be.

It's like the areas are somehow disabled.

I have a save for when I entered Kuldahar, and in that everything works fine and I can enter the areas normally. Sadly, I played quite a bit after that before noticing this issue. My next save, chronologically, is from when I entered the Vale of Shadows, and in that one Kuldahar is already broken.

Any ideas how I could maybe fix this?

I've tried setting and unsetting various global variables (e.g., "AR2107_VISITED", "KNOW_OSWALD") in EE Keeper, but, alas, to no avail. I also had a friend try one my broken-Kuldahar saves in his IWDEE installation, and he got the same inaccessibility issue, so I'm pretty sure this has nothing to do with my specific software or hardware setup.

Comments

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 19,166
    Can you please zip and attach (to a comment) your save.

    dreameling
  • dreamelingdreameling Member Posts: 4
    Apologies for the late reply. I was expecting email notifications on other people's replies, but got none. Anyways, please find attached a save for debugging purposes. (I edited the save to make everything as generic as possible, as I feel oddly exposed about sharing my saves publicly.)

  • BubbBubb Member Posts: 694
    @dreameling: Somehow these areas got corrupted in your save:

    AR2105 - (Townsperson's home next to the tiny bridge to the East)
    AR2106 - (Townsperson's home to the right of the Root Cellar tavern)
    AR2107 - (Temple of Ilmater)
    AR2108 - (Oswald's Laboratory)

    They are mostly 0'd out, I have no idea how something like this could have happened to be honest. Doesn't matter how it happened though - your save can be fixed by deleting these areas, (the engine will regenerate them). If you want, you can PM me the real save and I'll fix it for you.

    If not, you can use Near Infinity to do it yourself. Navigate to your save's BALDUR.sav file, hit Decompress, select the area codes listed above, and Delete file for each. Close Near Infinity, compressing the save when prompted, and everything should be good to go.

    RaduzielJuliusBorisovGusindadreameling
  • dreamelingdreameling Member Posts: 4
    edited November 14
    Many thanks for the info, @Bubb!

    I've used EE Keeper to occasionally edit my saves, so could that be the culprit? Apart from those few inaccessible areas, I haven't experienced any problems with the game, though.

    In any case, I'll try resetting the areas myself. If I fail my skill check, I'll PM you.

    Again, thank you!

    Bubb
  • dreamelingdreameling Member Posts: 4
    @Bubb, it worked! I can now access the four areas. Sweet.

    Thank you!

    Bubb
Sign In or Register to comment.