Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Multiplayer (LAN & Online) can't see enemies' attack animations (MELEE ONLY).

ZolaZola Member Posts: 6
What the title said, currently playing with my brother through LAN with no mods (steam version)

He noticed when we fought against Sarevok during his coronation. The problem is that the enemies' attack animation only show up when initiates his attack.

After that, no matter how high his attacks per round (APR) is, he cannot see the animations; Though the attack rolls are still calculated.

I had no problem like this as a host and in my screen Sarevok has like around 4 APR.

We didn't realize this until now. Tested it on the Black Pits expansion and still the same result. Figures it would be the same with Siege of Dragonspear. So we had no idea if this is meant to be for those who joined, not hosting.

Anybody experiences the same thing? Any help would be appreciated. Thanks.

Post edited by Zola on

Comments

  • Humanoid_TaifunHumanoid_Taifun Member Posts: 1,041
    I do not think I can be of much help. But have you tried reversing the situation? Set his computer up as the host and see if you can see the combat animations?

    Zola
  • ZolaZola Member Posts: 6
    I have tried that. Sending the mp save files and all. If he's the one who's hosting and I'm the one who joined, I got the same result as he. Enemies attack animations only show once for his initial attack.

    Figured our game files are corrupt or something so we verify our game files on steam to no avail.

    Planning to reinstall the whole thing and do a new game and attacking candlekeep's watcher to see his animation.

    This bug (if it is) happens even if we turned off "no cosmetic attacks"

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 19,348
    Try (and ask another player to try) Options - Feedback - Disable Cosmetic Attacks.

  • ZolaZola Member Posts: 6
    Already did. No difference.

  • snw364snw364 Member Posts: 3
    edited November 17
    This is Zola's brother and we are playing the enhanced edition version with no mods (BG1 EE Steam). Basically when I see an enemy, any enemies, when he/she/it attacks, I only saw one attack animation when the enemy engages with our party. Only once. For example if we fight against an Ogre, he only swings his club once, then he is going to stand still not doing anything, not swinging his club. The attack roll is still registered, so my party will get hit when all the enemies just stand around doing nothing.

    We are using no cosmetic attacks setting and we also try to turn it back off like the default but the issue still persists.

    I've really been enjoying BG but this really kills the enjoyment for me, anything you guys know to fix this could be appreciated.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 19,348
    I can't repro the issue. Can you check: does the bug happen when you play in the MP mode but alone? Does it start when the client joins? Is it the same for what the host sees and the client sees?

  • ZolaZola Member Posts: 6
    edited November 18
    You can't repro the issue? So you've tested with another person and the one who joined can see enemies' continuous attack animations when he stay still and being attacked? (Party AI off).

    The bug only happens when playing MP as I stated above. If anyone joined it doesn't matter because I'm the host. I can still see the animations even if I stand still and let them attack me.

    What my brother and me sees is the same. The enemy AIs cast the same spell with the exact timing and all. Only problem he (joined) can't see attack animation.

  • snw364snw364 Member Posts: 3
    This issue persists even as we switch hosts. The client (who joins) will have trouble seeing attack animations. Cosmetic attack on or off it doesnt matter. Please test this through the client computer, party AI off, dont attack and see what happens.

    The enemy ONLY animates his attack when he try to hit our party the first time, and when he got hit.

    So fighting against a high level fighter with 5 APR, he will only attack ONCE, if none of the party manages to hit him. ONLY happens for the client, host is unaffected.

    Zola
  • snw364snw364 Member Posts: 3
    The strange thing is this only happens to melee animations. Ranged and spellcasting animations have no problem. It could be this is an overlooked bug that can be fix easily as the other animations are working fine. If spellcasting and range animations works fine, why shouldn't melee?

Sign In or Register to comment.