Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

New version and wine

fot1fot1 Member Posts: 63
Hello folks,

I've been developing a module and took a break for vacations. Now that I'm back, I'm having a couple of issues when running the toolset with wine.

The first issue is related to test module action (F9). It won't load the game. After some research, I figured out is related to dropping 64bit support to the game launcher, and my wine is running on a 32bit prefix. Unfortunately I was not able to use this feature even using a 64 bit prefix, because I believe the .NET won't work properly on 64 bit prefixes. Does anybody found a way to make this work?

output when running on a 32 bit prefix:
0085:err:process:create_process 64-bit application L"nwmain.exe" not supported in 32-bit prefix

output when running on a 64 bit prefix:
001c:err:module:import_dll Library MSVCR100_CLR0400.dll (which is needed by L"C:\\windows\\Microsoft.NET\\Framework64\\v4.0.30319\\mscorsvw.exe") not found
001c:err:module:import_dll Library mscoree.dll (which is needed by L"C:\\windows\\Microsoft.NET\\Framework64\\v4.0.30319\\mscorsvw.exe") not found
001c:err:module:attach_dlls Importing dlls for L"C:\\windows\\Microsoft.NET\\Framework64\\v4.0.30319\\mscorsvw.exe" failed, status c0000135
000f:err:service:process_send_command service protocol error - failed to write pipe!
003c:err:module:import_dll Loading library OpenAL32.dll (which is needed by L"Z:\\home\\username\\.local\\share\\Steam\\steamapps\\common\\Neverwinter Nights\\bin\\win32\\nwmain.exe") failed (error c000007b).
003c:err:module:attach_dlls Importing dlls for L"Z:\\home\\username\\.local\\share\\Steam\\steamapps\\common\\Neverwinter Nights\\bin\\win32\\nwmain.exe" failed, status c0000135


The second issue is that in both prefixes, I can't hear anything while using the toolset. I can hear some sounds that represent errors sometimes, but activating the sounds on the three buttons in the top of the viewport won't work. Similarly, I can't hear the preview while painting sounds or selecting the area background music.


I wonder if those issues are related to my environment. So if you happen to have the toolset working fine through wine, please let me know.

Thanks for reading through.

Aron

Comments

  • virusmanvirusman Member, Developer Posts: 141
    You're right, issue #1 is due to a 32-bit wine prefix. I'm not sure how to make 64-bit wine work, never tried.
    Issue #2 is not related to Wine, it's a known bug in the Toolset build in 1.79. We're working to fix it for the next patch.

    Aronfot1JuliusBorisov
  • fot1fot1 Member Posts: 63
    Well, about the first issue its is all right, it can be worked around by loading the native Linux client on the module for testing.
    ./nwmain-linux +LoadNewModule mymod
    

    However I tend to use that for quickly go to the module when creating a new area to see if it feels right. I'll give another go on how to run NWN on wine64 later today.

  • fot1fot1 Member Posts: 63
    I've managed to make it work. All you need is wine 3.0 and .Net 4.0

    With wine 3.0, assuming you want to create a new prefix on `/home/user/wineprefix/toolset`, do the following commands:
    WINEPREFIX=/home/user/wineprefix/toolset WINEARCH=win64 wine wineboot
    WINEPREFIX=/home/user/wineprefix/toolset winetricks dotnet40
    WINEPREFIX=/home/user/wineprefix/toolset wine /path/to/toolset
    

  • gpeddinogpeddino Member Posts: 18
    I'm having the same problem, even though I'm not great with Wine. Can someone explain better what I should do to solve this?

  • fot1fot1 Member Posts: 63
    @gpeddino all you have to do is type the commands I've highlighted in the last post. Make sure to instead of using `/home/user/wineprefix/toolset`, use an empty directory path. Also, on the last line, instead of `/path/to/toolset`, you need to use the path for your toolset. For instance, mine is
    $HOME/.local/share/Steam/steamapps/common/Neverwinter Nights/bin/win32/nwtoolset.exe
    

    If you have a command not found error on wine or winetricks you need to install those commands on your distro, using your distro package manager.

Sign In or Register to comment.