Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Need help with Ranger Stronghold bug

I helped the dryad with the lord cutting down trees in his search for the mithril amulet, but after that delon never showed up while i was playing through many quests, now i have been kicked out of my ranger stronghold.

Does anyone know the global variables to change via EEkeeper to reset the quest back to just before the 2nd quest?



  • KhyronKhyron Member Posts: 544
    I'm not sure you can do that in ee keeper, thinking you need to use console.

    In which case, googling for quest variables and playing with them in console is probably your best bet.. there's no risk involved anyway, if you just remember to backup your save.

  • ThacoBellThacoBell Member Posts: 12,009
    Not necessarily a bug. Delon could have spawned, but you left the map he was on before he could talk to you.

  • JLEJLE Member Posts: 51
    edited May 2020
    I've had the same issue just now. Delon has never showed up at all that I've seen - or if he did, he may have spawned, walked away and I mistook him for a peasant... But I never get the quest to come and save the Umar Hills from an orcish invasion.

    I'm currently on day 65, having gone back to an older save (in Athkatla after finishing the Red Wizard enclave). If I go there instantly, the people are still friendly. If I take a couple of days to go to the Wild Mage Refuge first, I find that I've been kicked out of my job, I lose access to the cabin, and one of the three merchants will no longer talk to me. But I've never actually had the warning that there *were* orcs to save the village from, because Delon never appeared.

    Another thing; I have Mazzy in my party, and I'm a couple of days short of having her friend Danno Fairfoot come up and ask her to save Pala. So, however long she needs to have been in the party for that to happen (I believe it was something crazy like 20 days in the original game but has been considerably reduced in the EE?), it's shorter than that. I did the Tombelthen ranger quest in the Temple Ruins with no issue, then went to Neera's Wild Mage sanctuary to discover they'd all been abducted by Red Wizards, and spent the next day rescuing them.

    How do I fix things to actually receive the quest? Is there a specific command or series of commands I can type in to the cheat console in-game to receive the quest?

    If Delon did spawn, is there a way to discover what map he is on, and where he is on it?

    Why does the timer to complete the quest apparently begin at some point other than the end of an actual conversation with Delon?

    Post edited by JLE on
  • JLEJLE Member Posts: 51
    edited May 2020
    Further information:

    I am currently in the Wild Mages' Refuge, having returned to it after clearing out the Wild Mage sanctuary in Athkatla and freed the mages.

    It is 24 hours to the Umar Hills (Imnesvale village) from here. And at least that amount of time to anywhere else.

    The time on the relevant save-game is 67 days 1 hour. Neither Delon (for the Ranger Stronghold quest) nor Danno Fairfoot (for Mazzy's Pala quest) has appeared yet. Both are expected soon.

    (1) If I rest in the Wild Mages' Refuge, Delon spawns as soon as I wake up, and tells me to come to Imnesvale. This is now at 67 days 9 hours. Allowing a further 24 hours for the travelling, I arrive there at 68 days 9 hours, and both Nelleck and Minister Lloyd tell me about the ogron attack, and Madulf being holed up in the cave protecting a kid. Danno Fairfoot shows up and gives me Mazzy's Pala quest before I can talk to Nelleck, so I've got to rush straight off to Trademeet after shooting the ogrons.

    (2) If I travel directly without resting before I travel, I arrive there 24 hours EARLIER - at 68 days 1 hour - having not met Delon. But Min Minling won't sell to me, Nelleck and Minister Lloyd tell me to push off, I've lost my job without ever having had the quest. Danno Fairfoot shows up and gives me Mazzy's Pala quest.

    (3) If I use the console to travel there directly, the travel is instant, and I arrive there at the current time of 67 days 1 hour. Danno Fairfoot spawns immediately (I assume the reason he does not spawn in the Wild Refuge is that he cannot spawn there?), and gives me Mazzy's Pala quest. I walk over to Imnesvale village. They are still cheering my previous achievements. Delon has not spawned yet, but if I *now* rest, suddenly Delon appears - the time is now 67 days 9 hours, as in (1) above - and tells me to come to Imnesvale (where I already am).

    (4) If I go to any of the other "regular" places on the map - e.g. anywhere in Athkatla city, Trademeet or De'Arnise Keep, all of which take as long as or longer than the 24 hours above - the same happens as if I went directly to the Umar Hills: Delon never shows and I get back to the Umar Hills to find that I've been kicked out, as in (2) above. Danno shows up for Mazzy at the first available opportunity: this appears to be consistent across all variations.

    (5) If I cheat-console travel to one of the other places (e.g. De'Arnise), then the same happens as if I cheat-console travelled to the Umar Hills. Danno shows up first for Mazzy, then if I rest, Delon shows up and tells me to come to Imnesvale urgently, and if I set off at once, I make it in time - even though the resulting time of a successful arrival, having seen Delon, is LATER than the 68 days 1 hour of the failed arrival having not seen Delon, of (2) above.

    (Side conclusion: I assume Danno was scheduled to show up first, but he is for some reason prohibited from showing up in the Wild Mage Refuge, however nothing prevents Delon's appearance there.)

    And finally, the weirdest bug of all:

    (6) If I go to the one and only place on the map that's closer than 24 hours, namely Watcher's Keep, which is only four hours away, from the Forest Refuge or from the Wild Forest... then my party either never gets placed on the map at all, or only one of them (the protagonist) appears, in an illegal place in the top left corner in the sea! Instead of at the usual place at the southeast corner.

    (Whereas I can travel to Watcher's Keep quite normally, and arrive in the correct place, if I go from one of the "regular" areas.)

    Post edited by JLE on
  • ThacoBellThacoBell Member Posts: 12,009
    Well fudge. If Delon isn't appearing on the first map transition, and you lose the stronghold right away after travel, he probably already spawned somewhere. I'm afraid I don't know how to find him though. You probably need to use the console to set a flag and reset the timer. Maybe force a Delon spawn too at that point. I don't know the right commands though, sorry.

  • ThacoBellThacoBell Member Posts: 12,009
    Okay, I ran into this same issue. I don't think its just a case of the player missing Delon. I've done some looking around, and this seems fairly common AND it always seems to be for the Ogron quest. So its fairly consistent.
    What seems to be happening is that Delon is spawning while the player is in a dungeon. For me it was the Planar Sphere. Since Delon can only appear outdoors, he cannot reach the the player. So if the 3 day time limit runs out before the game succeeds in spawning Delon outside, you lose the stronghold. He spawned for me after I finished the sphere and traveled to an outdoor area and rested outside, where he then re-did his dialogue with Minsc to get the Umar Hills quest started in the first place.
    This fix from CamDawg worked for me. Copy pasted since its from an archived thread:

    'Had this reported to me in G3's Discord, so I poked around. Basically the quest can fail if you happen to be in Imnesvale when the timer to spawn Delon expires (details here).

    If you're already in Imnesvale, you can work around this at the console with:


    This resets the Delon spawn timer and un-fubars the quest. Once you leave the village, in any outdoor area use


    to force Delon to appear."

    @JuliusBorisov Do you know if this is known and worked on for 2.6? Its seems like this is a bug that's been around since vanilla.

  • biffyclangerbiffyclanger Member Posts: 216
    I tried this but it seems to have broken minister Lloyd, he has nothing to say now...

Sign In or Register to comment.