Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Stealth bug? Can hardly manage to sneak even with high skill level

ValkhyrValkhyr Member Posts: 12
Has anybody else noticed any difficulty entering/maintaining stealth in Siege of Dragonspear?

I recently started a new playthrough with a FMT imported from BGEE. My character has adjusted values of 115 Hide In Shadows and 110 Move Silently (at level 8/8/9, due to XP cap removed on BGEE). At some point in the first chapter I realized I had a hard time entering stealth. When I say "having a hard time" I mean "almost never works". Same for other characters (Minsc, Safana), though I did not notice as much since they have lower skill levels. UPDATE: Strike that, other characters seem to have no such trouble, they simply had lower skill and therefore legitimately failed more often. My character fails regularly though he is high skilled. Come to think of it, I believe the only times I was able to enter stealth were indoors, and even there much less reliable than I recall from BGEE.

At first I put this down to me trying it in crowded city areas and figured Beamdog may have added additional constraints on stealth, i.e. counting neutral NPCs for as detectors.

However, now I'm in the first woodland area and still cannot seem to sneak, whether at day or night, in shadow or not, and with no other NPC, monster or animal on screen. For comparison, this same character would succeed ~50 in BGEE in broad daylight, and nearly every time without fail in shadow or dark.

This effectively breaks my enjoyment of the game entirely since I always play heavily stealth-focussed :-/ I previously played through SoD about 2 years ago (a shadowdancer) and recall no such issue. If anybody has found this and has any idea what the issue might be, please let me know.

FWIW I'm on Android P, latest game version.

Comments

  • sarevok57sarevok57 Member Posts: 5,376
    first of all, unless you are a shadow dancer it is IMPOSSIBLE to stealth while there are hostile enemies within line of sight

    also, bright areas give you a penalty ( although im not sure what that is )

    so if you are trying to stealth in combat, then that is why you are failing so often, if you want to stealth in combat you must get out of the line of sight of enemies first to do so

    ThacoBellJuliusBorisov
  • ValkhyrValkhyr Member Posts: 12
    Thanks for the response.

    I'm aware of both of those things - I have been playing Infinity Engine games since the late 90s, and all my PCs have been stealth-focussed 😉

    As I noted in my post, I tested repeatedly (a) at night (b) in shadow (c) without any enemies around.

    That said, the effect "feels" exactly as if there were unseen enemies around within sight of my character, however there are none.

    My speculation is that at some point some effect got attached to my character that marks him as "within sight of an enemy", but I'm not familiar enough with IE effects to confirm this.

    I was hoping somebody here might bw familiar enough with effects or global variables or other things that can be inspected on a save game or CRE file to tell me if there is something to look for. I currently do not have EEKeeper (this is on Android), but I could probably get SOD + IEKeeper (or NearInfinity, though I'm less familiar with that) to run on my Linux machine and poke at the save.

    Otherwise I'm midly capable of deciphering hex files of save games based on IESDP specs in a hex editor directly on Android, but would need some very specific idea of what to look for.

    Lastly, I should point out that the game is unmodded except for XP cap removal (it's Android, mods are not easy to install, and I've never been a huge modder). The same applies to the original save in BGEE where the character originates - only mod in that playthrough was XP cap removal. In addition to that I did some very basic hex editing on the character to (a) change the animate id from fighter to thief and (b) reassign the value of one weapon proficiency (changing a single byte basically). Both of these edits were done very early in the BGEE playthrough and did not cause this problem, I'm just pointing them out for completeness sake since people might suspect I messed with the save/CRE record with side effects. Further, I have not edited the character or save game at all since importing into Siege of Dragonspear (I did import the entire save, as opposed to a single character).

    Æmryssarevok57
  • ValkhyrValkhyr Member Posts: 12
    Came back to this after laying off the game for a week (basically moved on straight to SOA, but this didn't give me peace).

    Loaded a save from before I remember the issue first happening. Found a strong correlation with Corwin tailing me around the city during the inital chapter (recruitment drive).

    Whenever she has dropped me off at a location and is waiting for me to do what I came there to do, stealth works fine. But when I leave the building and she follows me around outside, I can't stealth. E.g. when at Three Old Kegs, while she is waiting at the bar I can stealth *both inside and outside the building* with the success rate I'd expect from 100+ HIS/MS. Once I tell her I'm done and she follows me out, I can't stealth at all. Then we move to the next location to talk to recruit Safana, and I can stealth just fine again after Corwin drops me off and waits.

    Not 100% sure yet about this (there may be other factors involved), but my current working hypothesis is that there is some script that messes with your main character's stealth while she is following you. I suppose this is already a bug in and of itself, but worse, I suspect in my previous save this bad state somehow got attached to my character even after that chapter ended.

    On the weekend I will try and finish that chapter again and avoid triggering this (avoid sneaking while she is tailing me), see if I can get into the next chapter without this bug sticking around.

    Wondering if anybody with a stealthy CHARNAME can verify similar behaviour in the city while Corwin tails them?

    ThacoBellIsewein
  • BubbBubb Member Posts: 804
    Very few factors go into stealth checks - aside from the character skills, area lightmap, and LoS to enemies, a character's Luck is the only thing that can further alter stealth rolls. Perhaps this value got wacked somehow? Wouldn't explain why it's situational, though.

    I would be interested in testing out your save, if you still have a copy lying around. Brute-forcing 10,000 stealth checks while Corwin is shadowing me shows no change in the success percentage, at least on my end. Have you tried reproducing this bug on a new character? Would be telling if it only occurred on this particular save / character.

  • ValkhyrValkhyr Member Posts: 12
    edited June 20
    @Bubb thank you very much for the response 🙂

    After some more experimentation today, I also no longer think it is strictly related to Corwin shadowing me - it may be *one* of the things that triggers the bug, but it's certainly not the only one.

    I have not yet tried creating a new character. I was playing SOD as part of a whole series run with the same character (plus ideally my final BG party continuing through SOD), I'd need to do a lot manual editing of characters to approximate that on a newly generated character. I'm absolutely open to trying a new character when I have a bit of time on my hands - but since I imported the same character from BG into BG2 and have no issues, I am concerned that the bug originated in SoD itself and may happen again randomly.

    Thank you very much for offering to test some of my saves - I'm attaching two saves that show different scenarios:

    Save titled "1" (file 000000089-1.zip):
    - start with PC outside the Three Old Kegs and Corwin inside waiting. I can stealth reliably.
    - go back in, don't talk to Corwin yet. Can stealth reliably.
    - talk to Corwin to leave the place, go outside. Corwin tails me, I fail to stealth every time I try

    Save titled "2" (file 000000090-2.zip):
    - beginning of chapter 8, start in the Flaming Fist camp
    - walk into the bottom left corner of the shadow of Belegarm's stall (left-down from him) -> I can stealth reliably
    - walk to any other shadow in the vicinity (particularly tried various places right to the east, before the wolves hunting a deer) -> can't stealth at all in most places

    Note that all tests were done with my charname, and I tried ~5 times in each location. I'm on Android and can't/don't know a way to brute force a statistically significant number of stealth checks as you did, so when I say "can't stealth" I mean "never succeeded on 5 tries" and "can stealth reliably" means "succeeded on most or all attempts".

    Again, thank you for the help and let me know if you have any ideas or need more info 🙂

  • ValkhyrValkhyr Member Posts: 12
    edited June 20
    @Bubb While my response posted without issues I got a pop up saying I'm "not allowed to upload files in this category. I will try to send them to you via PM 🙇‍♂️

    EDIT: either I'm missing it, or there is no way to send files in a DM. Here is a dropbox link to a shared folder 🙂

    https://www.dropbox.com/sh/iqb99ura66ynls3/AAAvH6NL9QU_PsBd2YoNYt9ta?dl=0

    Please let me know if this does not work for you.

    If anybody else feels curious to try these saves and see the issue, please feel free to do so 🙂

  • BubbBubb Member Posts: 804
    @Valkhyr: Thanks! All of my tests show nothing out of the ordinary on your save - your protagonist's Stealth always works as expected; sorry I don't have anything more to report. Maybe it's a mobile-only bug? I would test it out if I had the Android version of SoD, but unfortunately, I do not.

    It would be interesting if someone else could test your save on mobile, and see if the same weird probabilities occur.

  • ValkhyrValkhyr Member Posts: 12
    @Bubb Thank you for testing, really appreciate it!

    If anybody with an Android install drops by this thread and can see if they can reproduce it, I'd be very much obliged 🙏

    I think I'll give uninstalling and reinstalling SoD a shot as well - not that I expect much from that, but it's quick and does not hurt to try (and is certain to come up if I want to formally report this as a bug)😕 Will also install on my Linux laptop and test there to compare as well, though I prefer actually playing on the phone.

    If that does nothing, once I have a bit more time on my hands I'll create a new character from scratch on a fresh install and try that as well. Then I'll give up and formally submit a bug 😑

  • ValkhyrValkhyr Member Posts: 12
    OK, so I tried both uninstalling (after deleting associated data) + reinstalling on Android, and installing on Linux and playing there.

    Both are as expected:
    - reinstalling, then copying back the same save and trying it, does not fix the issue.
    - on Linux, the issue does not manifest

    I don't have another Android device on which I could try this to compare behaviour across versions etc...

    Hopefully one of these days I'll get around to spending a few hours making a new character and trying it.

    Assuming I can reproduce the issue again on another character, does anybody here have experience with how quickly Beamdog address user bug reports?

  • ThacoBellThacoBell Member Posts: 11,897
    @Valkhyr "Assuming I can reproduce the issue again on another character, does anybody here have experience with how quickly Beamdog address user bug reports?"

    Beamdog doesn't really do hot fixes. So they'd take for internal tracking pretty quickly, but you wouldn't see it resolved until the full patch dropped. There's no knowing how long until 2.6 drops, so you might see a fix then if you report soon enough.

    Valkhyr
  • SirBaldurSirBaldur Member Posts: 76
    Was this ever fixed?

    My char is a shadowdancer imported from bg1 and has 100 ms 115 his, never had any problem hiding in chapter 7. I noticed it when leaving ducal palace - was working fine inside, stops working outside entirely, whereas historically I would expect it to work at least 50% of the time outdoors.

    Corwin is outside and not inside, I wonder if that could be related as speculated. I accepted her offer to join my party and the ability has never returned. Being a shadowdancer, this is game breaking of course. I'll have to see if I can use my old saves to see if her presence is the problem.

  • SirBaldurSirBaldur Member Posts: 76
    After more testing, I believe this is a bug that happens when stealthing outdoors (probably only on android, which is what I have, similar to op).

    Stealth works reliably indoors, but I find that it almost always fails outdoors even at night when in a shadow. However, there are certain spots - seemingly random, often in broad daylight, typically away from any bystanders or buildings or trees - where it works reliably. Wild guess is the calculation about shadows is off in android, or the input values about whether it's night/shadows is being reversed or something but only outdoors.

    I always stealth a lot in my characters (shadowdancer definitely my favorite) so this is a huge showstopper.

  • ThacoBellThacoBell Member Posts: 11,897
    I was always under the impression that it was just harder to hide outdoors. Shadows and nighttime are supposed to make it easier, but its still outdoors.

  • SirBaldurSirBaldur Member Posts: 76
    ThacoBell wrote: »
    I was always under the impression that it was just harder to hide outdoors. Shadows and nighttime are supposed to make it easier, but its still outdoors.

    Possibly, but ive found that in somewhat random (or at least I haven't figured out the pattern) places in sod, i can reliably stealth in brightest daylight without shadow. It's almost like things are reversed from expected when outside (maybe android only).

    Also, having taken shadow dancer through bg1, which is very much outdoors, i definitely never experienced anything like 95% failure in outdoor nighttime with 200 ms+his. Often I would sleep until night just for the purpose of reliable outdoor stealth.

    Such a bummer.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 21,121
    Before we qualify that as a bug, we need a reliable repro. So far, this thread had (before your necro-ing) only custom posts implying there might be an issue but never anything beyond that.

  • SirBaldurSirBaldur Member Posts: 76
    edited 5:13AM
    Before we qualify that as a bug, we need a reliable repro

    Sure that makes sense. How to go about that? OP had some test files, confirmed no prob on linux, seems like it might be an android thing.

    Also noticing in op description that he has success indoors but then went outside and stopped working, which was my same experience. Every outdoor location had this problem for me, except I can find very random specific spots where it behaves as expected.

    Let me know what I should try or suggestions about reproducing. I have an android phone that I could load up the save file on

Sign In or Register to comment.