Skip to content

Bug with constant "electric" effect of some spell.

I ran into some nymphs or sirens on one of the Sword Coast maps. I do not know the exact spell that started it, the battle was quite confusing. But after the battle, my party was constantly going around getting "shocked" like the spell still has effect. It looks like an electrical aura accompanied by a sound effect of crackling electricty. It happens again every time I save, sing a bard song, move to a new location or simply at random intervals. It is very annoying. I supposed it will wear off, but it doesnt. Is there any way to make it stop? Unfortunately I have no previous save before I realized this might be a bug.

Comments

  • jmerryjmerry Member Posts: 2,449
    Definitely a bug.

    Sirines cast Improved Invisibility on themselves and Dire Charm on you (in both cases, the standard arcane spell). They attack with arrows of biting (the player-usable kind) at range and with an attack that inflicts temporary confusion and feeblemind status on a failed save in melee.

    None of these have an electric visual effect.

    So now, troubleshooting. Does the issue persist if you save and quit, then come back and reload? If so, you could upload your save so that people could try to find the cause and/or edit the save to remove it. If not - then you're clear.
  • smyth25smyth25 Member Posts: 219
    edited September 2020
    Could you have been struck by lightning during the battle (as in the weather effect)? I think it's still bugged behaviour that the electrical effect keeps playing, but that might be the source of the bug at least.
  • CassoCasso Member Posts: 3
    edited September 2020
    Yes, it is possible that I was struck by lightning because it was raining. It is also possible I was struck by the lightning my own druid created. Even if I quit the game and then reload, I find the same thing going on in my saves and quicksaves.
    I uploaded the save file here (I took it from the mpsave folder).
    http://download.johnny-dockal.cz/000000040-wtf.rar

    If anyone found how to get rid of this effect, I would really appreciate it!
  • CassoCasso Member Posts: 3
    So, I found the cause of the constant electric sparks. It is caused by Yeslick's innate ability "Dispel Magic". I still have not figured out how to get rid of it.
  • djonslaughtdjonslaught Member Posts: 6
    edited February 2021
    Did you ever figure out how to get rid of it?

    I'm experiencing the same thing and had cast Yeslick's dispel magic just previous to it. Unfortunately my closest save game before casting the spell is 20 days ago!
  • MagneVikingMagneViking Member Posts: 1
    Same bug. According to steam community:

    "Just had the same problem, but figured out a fix. You need to download EE Keeper and go to the "effects" tab on each character. There will be one or two entries with labels called "sprotect" and "spin112". Delete them on each character and save the edited game. Problem solved. "

    https://steamcommunity.com/app/228280/discussions/7/2843417619890774156/
    Grond0JuliusBorisov
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 22,140
    You can also activate the console and Ctrl+R on the affected party member to clear that effect.
    MagneViking
  • _Luke__Luke_ Member, Mobile Tester Posts: 1,518
    [SPIN112.SPL] This issue seems to be caused by opcode #215 (resource : "SPROTECT.VVC").

    It has a Timing Mode of 1 (Permanent), that's why it lasts indefinitely.

    To be honest, I do not think that opcode should be there... I mean, its divine counterpart "SPPR303.SPL" does not have it (ditto for its arcane counterpart "SPWI326.SPL"...)
  • GalactygonGalactygon Member, Developer Posts: 412
    The issue is known and fix for that has already been submitted internally.
    JuliusBorisovMagneViking
Sign In or Register to comment.