Skip to content

Workaround for Android Import

If you are like me, you hoped that Android versions of the Beamdog BGEE series would give you months of enjoyment while allowing you to import and grow your character across the entire series.

Judging by previous threads, this originally worked as intended. Then, at some point, a change required us to use either a PC or third party file manager to import files. This was still fine, until at some point... it wasn't.

The Android/com.beamdog.* file structure has instead become completely inaccessible to PCs and file managers. Many threads have been opened, but we are always pointed towards the older threads about the earlier issue. Nothing is acknowledged, and nothing is done, even though this is demonstrably a Beamdog issue (every other non-beamdog folder is accessible). In short, there is now no way to use the Import feature.

Today I have a new workaround to offer. This is annoying, and should be totally unnecessary, and wastes extra space on your device that I have no method to recover... and I actually feel that I am owed an apology to my daughter for the daddy time that was diverted into its development.

While these Beamdog folders appear empty to PCs/file managers, the data is just hidden. The folders themselves are locked from accessing the contents or even deleting the folder by hand. So we cannot copy or move the files by hand. However, are NOT locked from renaming the folders!

By renaming these folders, you can manipulate them to a point that you will be able to import them into your desired game.

For example, to import from BGEE to SoD:

1. Rename com.beamdog.siegeofdragonspear to com.beamdog.siegeofdragonspear.old
2. Rename or duplicate com.beamdog.baldursgateenhancededition to com.beamdog.siegeofdragonspear
3. Import game

Voila! You now have access to your characters.

To reiterate, com.beamdog.siegeofdragonspear.old in this example would still contain data, and is still locked from deletion or editing. It lives rent free on your phone just taking up space. And until they acknowledge that this is THEIR issue and fixes it, it will continue to do so.

Hope I've made your day better.

Comments

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 22,464
    Thanks for sharing this workaround.
  • AgerioAgerio Member Posts: 19
    com.beamdog.siegeofdragonspear.old in this example would still contain data, and is still locked from deletion or editing.
    Have you tried renaming it to com.example and clearing example's data on settings?. Also, are you on android 13?
Sign In or Register to comment.