Skip to content

BG2EE Help Wanted: Persistent Game Freezes

Hey there folks, been playing Shadows of Amn Enhanced Edition with the G3 Tweaks Anthology and some EEKeeper tweaking and it's been going great up until now. I've had a couple crash-on-rest problems here and there but I've been able to track them to specific things I put in with EEKeeper that I then remedied.

The serious problem now is that I've hit some kind of persistent freeze.

First time it happened was when I tried to progress the second stage of Hexxat's quest, heading to the graveyard so we can get warped to where the Shroud of the Unproved is. It played the "whoosh" teleport animation, and then nothing happened. The UI disappeared but everything was otherwise still running, but the game wouldn't take any commands. I had to close it via Steam or via Task Manager.

I went elsewhere and got the same problem after heading to DeArnise Keep and talking to the Majordomo. He says that Captain Cernick wants to speak with me, and when I agree, the game locks up in the same way. UI vanishes, everyone still idling, music playing, but game won't take any commands.

Figured these were sidequests and not vitally important, so I went to pay up the 15k gold to Gaelan Bayle. It played the Chapter 3 text scroll cutscene, and when loading back into his house, got the same freeze problem. UI gone, game locked up.

I've attached my WeiDU mod log. Any help would be appreciated. I'm not sure what recourse I have at this point, and I'd rather not restart the entire game. Thanks folks.

Comments

  • jasteyjastey Member Posts: 2,330
    Seems cutscenes hang for you. I am not sure what yould cause so many cutscenes to not perform the actions.
    What exactly did you tweak with EEKeeper?
  • IroIro Member Posts: 3
    edited September 18
    Changed characters' ability scores, added some items (mostly potions, ammo, armor) and kit innate abilities. Haven't touched any variables.
  • IroIro Member Posts: 3
    edited September 19
    Update: tried walking around the city a bit, got an exchange in the tavern in the Docks district between a former slaver and Jaheira. It ends with someone casting a spell on her, which also consistently crashes the game, but this one is a hard crash that gives an error pop-up and everything. Not sure if it's related.

    Second update: I reloaded a save from 2-3 hours before the problem began and things seem to be working fine. Computers might as well be black magic, I swear.
    Post edited by Iro on
  • KhyronKhyron Member Posts: 574
    Be careful and have several saves to go back on.. for the infinity engine is dark and full of (t)errors.
  • jasteyjastey Member Posts: 2,330
    Khyron wrote: »
    the infinity engine is dark and full of (t)errors.
    LOL! That's priceless. :D

Sign In or Register to comment.