Skip to content

Hexxat bug

So just started a new game recently, did Hexxat's companion quest first thing. First time ever doing it so I don't know where things went wrong but I probably wasn't supposed to re-recruit the fake Hexxat. Full story - I fought through Dragomir's tomb, got everyone in that last room and got the real Hexxat cutscene. Real Hexxat bounced after the chat, and then fake Hexxat made to leave as well but I talked to her before she could. I got what seemed to be the standard "you're dismissing me?" companion speech from her and invited her back into the party. For some reason her name was still Hexxat and not Clara. Leaving the tomb, ran into real Hexxat again, gave her the cloak, and agreed to meet back at the Copper Coronet in a couple hours. Now the bug hit - upon entering the Copper Coronet, fake Hexxat disappeared from the map, preventing me from ever leaving the CC because my party was not gathered. I also could not dismiss her with the reform party option - going through the process seemed to remove her, but upon completion nothing happened. I tried replacing her with real Hexxat, but it was like she got added back into the party immediately, the 7 party member dismiss one screen kept popping up. I tried reloading a save, but that crashed the game and now I can't load any of the saves with fake Hexxat in the party, which unfortunately are all of them past the chapter 2 start - I wiped out the CC enter autosave seeing if fake Hexxat had dialogue with Salvanas before I replaced her - she did not, adding insult to injury. Is this a known bug with a solution or do I need to redo the chapter 2 I've done so far?

Comments

  • thatguythatguy Member Posts: 4
    Small update - I was actually able to load some of the saves after restarting the game. Unfortunately they're all after I entered the Copper Coronet, so Hexxat is off the map and cannot be dismissed, trapping my party in the building. If there's some way to force delete her from the party that might work.
  • thatguythatguy Member Posts: 4
    So I ended up restarting chapter 2 since this didn't get any replies for a few days - looks like fake Hexxat was supposed to die originally in the cutscene and the bug was that she didn't for whatever reason. On the restart she died properly. Maybe I had a death ward spell active on her originally or something. I still have the broken save file, but no help needed anymore.
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 22,494
    Hi! Sounds like you got affected by a rare bug: https://forums.beamdog.com/discussion/23818/hexxat-bug-massive-spoilers
  • thatguythatguy Member Posts: 4
    That does sound exactly like what happened. I coulda sworn I searched for similar threads before making this one, thank you for finding that. Looks like they didn't have a fix either beyond reloading anyway.
Sign In or Register to comment.