Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Bug: Balthazar & Melissan Teleporting Into Abazigal's Lair

Hey guys I am having an issue where Balthazar and Melissan are teleporting into Abazigal's Lair after he dies, forcing a confrontation that I believe should actually happen in the Palace itself.

I have come across a couple other examples but no solutions:

"I have a weird bug in ToB. Right after I killed Abazigal, there is a cutscene that shows Balthazar and Melissan in Balthazar's palace. And after that ends, the same cutscene happens back in Abazigal's lair too, with Balthazar and Melissan somehow teleported there. But this time, you intervene the talk. I selected to support Balthazar, and Melissan summoned some monsters and a fight broke, Balthazar on my side. We killed everyone, but Melissan can't be killed. She becomes near death and stays at that condition. Because the fight was never ending, I left Abazigal's lair and went back to Amkethlan, to Balthazar's palace. But, there is noone inside the palace, completely empty. So, I can't progress further at this point. "

Any suggestions here? Perhaps variables I could toggle and reset?

Any help is appreciated. Thanks


  • iosfrustrationiosfrustration Member Posts: 153
    I’m guessing you are using some mods? I’ve never been given the option to do anything but support Melissan and fight Balthazar.

  • IseweinIsewein Member Posts: 404
    This is a bug that occurs with Wheels of Prophecy, I believe. I don't remember the workaround, however. If you have that mod installed, best contact @DavidW for support.

  • Jeulz95Jeulz95 Member Posts: 10
    edited June 2020
    Thanks both. I think you are right that it is related to Wheels of Prophecy. I found another example of the problem here, except Balthazar and Melissan spawned in Sendai's Enclave after she was killed:

    I didn't realize WoP was intended to allow for different orders (I went the traditional Sendai>Abazigal>Balthazar).

    I'll try reaching out on the G3 forums. Until then, anyone else with any suggested variables to tinker with?

    Edit: There is a much more detailed post with some scripts here ("Cutscene problem at Abazigal's Lair (AR6005)"):

    I am not familiar with the cutscene/area files, but it seems the issue is not related to WoP. CUT235A.BCS should load (taken back to Pocket Plane with Solar) but instead DW#BALC2.BCS loads (Balthazar and Melissan in the palace). I will try tinkering with some of these variables.

  • Jeulz95Jeulz95 Member Posts: 10
    I believe I was able to get around the issue.

    Before fighting Abazigal, I set Global("HadBhaal25Dream3","GLOBAL",0) from 0 to 1.

    After the fight, the cutscene of Balthazar and Melissan talking in the palace played. I believe normally the Pocket Plane Solar cutscene should follow, however it did not since the variable above was set =1. I made another save file where I set the variable back =0 (i.e. just removed it) and upon reload, the Pocket Plane Solar cutscene immediately began as expected. I traveled back to the palace and the regular cutscene with Balthazar began (although Melissan was already taken away and the first dialogue option was to ask where she was). I am not sure how this normally unfolds with Wheels of Prophecy since this is my first time playing ToB in over 10 years, but I think this is good enough to progress the plot.

  • ratamoratamo Member Posts: 16
    Jeulz95 wrote: »
    Before fighting Abazigal, I set Global("HadBhaal25Dream3","GLOBAL",0) from 0 to 1.

    This bug ruined my EET playthrough at it's final steps. Hopefully I can finish my game now.

  • ratamoratamo Member Posts: 16
    edited September 2020
    The end wasn't as smooth sailing as I thought. For some reason I cannot destroy the pocket plane. I've killed sendai, abazigal, balthazar, raveger and done the other four pocket plane challanges.

    When I leave the pocket plane I'm only returned to saradush, where I came from.

    I thought this was because of wheels of properchy mod, so I uninstalled it, loaded from before I killed sendai and went back to the end. No change.

    Would you have a suggestion what I can EEkeep so that I would go to the throne of blood from the pocket plane?

    It's not the Neera-bug, I already tried it.

    Also tried teleporting to the Throne of blood. It breaks the conversations. Irenicus appears, bodhi doesn't and after killing him nothing happens.

Sign In or Register to comment.