Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Mouse problem with Windows 10

BelanosBelanos Member Posts: 968
edited October 2015 in Troubleshooting
I recently installed Windows 10 on my system and have had to download all my Steam games again. But now I'm having a very strange problem with the Baldur's Gate game. It seems that my mouse pointer is offset considerably and I have a very hard time clicking on any buttons, to the point that I can't even start a new game. For instance, on the Baldur's Gate 1 main menu, if I click on Credits, the Baldur's Gate button will activate. Is this a known problem with some sort of work around by any chance? Both of the Baldur's Gate games are doing this.

So I re-downloaded Icewind Dale as well, which I bought from Beamdog and not Steam, and I'm having the same problem. I had a similar problem with an old disc copy of Knights of the Old Republic 1, but the problem seemed to get fixed when I de-selected the "Enable Hardware Mouse" option. Fortunately, if worse comes to worse, I'm running a dual boot system along Windows 7 so I'll still be able to play the games on that OS. I've been coming across a few other titles that don't seem to like Windows 10 as well.

Post edited by Belanos on


  • Gate70Gate70 Member, Developer Posts: 3,664
    Hi @Belanos
    You might want to check you have a suitable driver for your graphics card for Windows 10. There were a few reports of cards that have no recent drivers e.g.

    If you post up your system information as per that post it may help around options.

  • BelanosBelanos Member Posts: 968
    edited October 2015

    I do have a suitable driver for my video card, I made sure to get one before I installed Windows 10. The problem is occurring because of the hardware mouse option. I ran Icewind Dale with my Window 7 OS, which worked perfectly, then disabled the hardware mouse in the Graphics options screen there. I then copied the ini file over to my Windows 10 partition, and ran the game again with that OS. It worked perfectly then as well.

    I did the same thing after that with the two Baldur's Gate games, and they're also functioning normally now. Because the mouse was so screwed up, I wasn't able to access the Options screens in order to fix the problem when first running the games in Windows 10. It was something of a Catch-22 situation all around. But they are all now working as intended. It looks like there's been some change in how Windows 10 deals with mouse operation that's not compatible with the default game settings.

  • BelanosBelanos Member Posts: 968
    @Gate 70

    I ran into another post where someone was having the same problem:

    The issue is being caused by increasing the size of text, apps etc. by 125%, or more. I too have had to do that because I have a high resolution monitor and I have trouble reading anything at the default setting. I tried reducing the size to normal and running the game and it worked as intended.

  • BelanosBelanos Member Posts: 968

    I found a fix on the Steam forums. Just right click on the .exe file, go to Compatibility and select "Disable display scaling on high DPI settings". The game will work properly without having rescale the desktop back to 100%.

Sign In or Register to comment.