Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Unable to get Server Posted to Server List

So I'm just trying to get a test server setup and showing on the NWN:EE server list, but so far I've been unsuccessful after several attempts over the last few weeks. I have a NWN 1.69 server running on a Windows 7 server on my network (192.168.0.10). Because of that, have been trying to use port 5301 for the NWN:EE server on my Windows 10 test server (198.168.0.2). I have the following setup for the router, Windows firewall, and NWServer itself. From what I can tell, port 5301 should be visible/accessible to the outside world......right?


However, when I launch EE and go to Join Internet Game on the test server, or from a laptop on my local network, I always see my external (static) IP for the server showing "Contacting Server" and grayed out, which eventually changes to "Offline".


Can someone tell me what I'm doing wrong? I have been hosting a PW for the last 10 years, so I'm really confused that the normal methods I've used to get that displayed on NWN List aren't working for NWN:EE.

Comments

  • TheGmorkTheGmork Member Posts: 37
    My advice would be to turn of Windows Firewall and rely on your Physical Firewall that is your router. If some one goes to the effort to get through the physical router, windows defender will only slow them down a little.
    If you do not want to do that, then remember that Windows Firewall blocks outgoing info as well as incoming.

  • JimbobslimbobJimbobslimbob Member Posts: 206
    TheGmork may be onto something there, try opening up the "advanced firewall" in Windows and create rules for all profiles for the executable for inbound and outbound and restart the server to try again.

  • IndyWendieGoIndyWendieGo Member Posts: 62
    edited December 2017
    If that doesn't work, try opening the relevant ports through NAT and port trigger through your router's firewall. Also, from my experience, I had to be running the Beamdog client (not really sure if that has anything to do with it or not) along with it.

    Edit: I don't think the Beamdog Client would have anything to do with it (just tried it through both and was still listed), but still try opening ports through NAT and port trigger through the router's firewall. If all of the above or this suggestion fails, it could be DMZ related. Let us know how it goes!

  • JimbobslimbobJimbobslimbob Member Posts: 206
    edited December 2017

    ...port trigger through your router's firewall...

    I would recommend against port triggering. It's not the same as port forwarding in that ports are opened and closed when the router thinks it needs to. It can cause lost packets and problems when the router fails to do its job properly and I have heard of others having issues using it. Port forwarding is much more reliable.

  • IndyWendieGoIndyWendieGo Member Posts: 62
    edited December 2017

    ...port trigger through your router's firewall...

    I would recommend against port triggering. It's not the same as port forwarding in that ports are opened and closed when the router thinks it needs to. It can cause lost packets and problems when the router fails to do its job properly and I have heard of others having issues using it. Port forwarding is much more reliable.
    Sometimes, you may not have an option- like in my case. The same can be said about Port Forwarding as well in terms of cyber security, as advised by larger games such as ESO which you can read here (especially in post #4). Truthfully, it really depends on the hardware, how it's set up (especially if you're somehow behind double routing), along with a slew of other variables.

    I've port triggered for the past 6 and a half years for NwN. Never had an issue. You just do what you have to do to make something work.

  • JimbobslimbobJimbobslimbob Member Posts: 206


    I've port triggered for the past 6 and a half years for NwN. Never had an issue. You just do what you have to do to make something work.

    Words to live by, for sure.

    Yeah, just wanted to point out that I had seen cases where it caused issues before. Like you say, if there is no other option then go for it.

  • IndyWendieGoIndyWendieGo Member Posts: 62
    edited December 2017
    Yeah, I think it goes without saying that doing anything with port forwarding/triggering/NAT should be approached through treipdation (though NAT is relatively more flexible for the most part, each one has the ability to screw up in packet loss in one fashion or another depending on your ISP and what they control).

    Pretty much for me, when it came to hosting with NWN- It was sorcery. Though nowdays I know it's a lot to do with what the user has access to along with the ISP (controlled firewalls, locked out of settings, etc). Which is why I had to do both forwarding through NAT and use port triggering through the firewall. Which is probably why I never had any of those networking issues because I wasn't just triggering. But nonetheless, while anecdotal- definitely was my Hail Mary in terms of hosting. xD



    Only other things I can recommend in combination of the other suggestions for the OP are;

    - Definitely try the firewall stuff that the others suggested.
    - Use the default port 5120/5121 with the Windows 10 version to see if it's something to do with ports.
    - Try hosting it (NWN:EE) on the Windows 7 server (again with default ports) to see if it's specifically tied to Windows 10.
    - Investigate other settings, including DMZ (though if you never bothered with it and were able to host NwN, that shouldn't be an issue).

  • BalanorBalanor Member Posts: 172
    Hey guys. Thanks for the replies and insight. Last night I did try setting up inbound and outbound rules for the EE NWServer in the Advanced Firewall, but that had no effect. Then, I decided to temporarily turn off the Windows Firewall altogether and put the machine I was testing on (192.158.0.2) in the router's DMZ. Unfortunately even with the Firewall off and the entire machine in the DMZ the server would still not display on the server list in the client.

    I guess I'll try running it on the Windows 7 server I have running my 1.69 server, and use the default port of 5121 to see if that makes a difference.

  • JimbobslimbobJimbobslimbob Member Posts: 206
    Good luck! As a side-note, is there any AV or VLAN software that could be interfering with it?

    IndyWendieGo
  • BalanorBalanor Member Posts: 172
    Another day of bashing head against wall, with still no luck. There is not AV on the machines I've tested from, and I don't have VLAN software on them. I don't see any options for port triggering in my router. I only have the option to enable or disable NAT on the router (no port options there), but if I disable it then there is no availability to the outside world (no internet).

    Yesterday I tried -

    -Running the NWServer for EE on 3 different Windows 10 machines and 1 Windows 7 machine on my network for various ports, typically around 5122-5124, and port 5301.
    -Putting each of the machines in the router's DMZ *and* forwarding the applicable port to the machine's IP address.
    -Completely turning off Windows firewall for Domain, Private, and Public on any machine I was testing from

    This is...frustrating...

  • GorgonGorgon Member Posts: 22
    Just a shot in the dark, but do you have the old "Master Server Authentication Required For Player Login=0" set in your nwnplayer.ini, under [Server Options]? That blocks it showing up for me even in local testing.

  • IndyWendieGoIndyWendieGo Member Posts: 62
    Hm.. I really don't think your ISP would be using a firewall controlling ports if you're able to host the 1.69 version. Definitely try Gorgon's suggestion, though I had the same setting and was able to host- so that could be something.

    Also are you using NWServer that came with NWN:EE or are you using the version here on the forum? I wouldn't think that'd have anything to do with it, but that too is also a shot in the dark.

  • GorgonGorgon Member Posts: 22
    edited December 2017
    Actually, you are right, and that was just my dyslexic brain remembering things wrong. I was testing what happens when I blocked access to the MS, plus had that and the "Account validation required during Master Server down times" settings enabled.

    So yeah, I doubt it will help here.

    *edit* One other "I doubt it will matter" suggestion is to use the "-publicserver 1" command line option when starting it, instead of the nwnplayer.ini setting for it.

  • IndyWendieGoIndyWendieGo Member Posts: 62
    Yeah, that was one of the other things I was actually thinking about because that was something that was being a pain when I was troubleshooting hosting for myself back in 1.69. NWServer wasn't going online, but hosting through the client people could connect.

    Also @Balanor - If you're using your internal IP to connect to your server in NWN:EE, try using your external IPs instead and see what happens. That might at least get you past the time out check.

  • BalanorBalanor Member Posts: 172
    Thanks again everyone. Really appreciate the ideas/help. I have had this problem with both the standalone version niv posted (installed on Windows 7 and a Windows 10 machine) and the full client version of NWserver (installed on two other machines). Starting the server with the "-publicserver 1" command line option, or changing those master server lines in the nwnplayer.ini from 0 to 1 and back again didn't change the behavior either, though.

    However, I may have had a minor breakthrough.

    I was once again messing with my first Windows 10 test machine and had the Windows firewalls turned off for domain, private, and public profiles. I was using port 5301 and had the router setup not only to port forward 5301, but I also put that machine's IP (the 192.168.0.2) in the router's DMZ. Logging into the client on any computer on the server's network still wouldn't show my test server in the EE's server list - just the external IP and port with the "Contacting server" message that eventually changes to "offline".

    However, a short time ago, as I was glaring in frustration at the NWServer which was still running after my latest attempt...someone logged in! (Thanks go to "Max" for choosing to login to a server with a name of "Server" and a module called "test" :D )

    So, it appears that the problem is not that it isn't listed, but that it's just not visible in the EE serverlist from other computers on the same network. I'm not exactly sure if there is a way to remedy this, but I'm really hoping there is as I'd rather not rely on guesswork to tell if my server is truly visible in the EE server list if no one is logged in.

  • MadHatterMadHatter Member Posts: 145
    Does the server show up on the LAN game listing?

  • BalanorBalanor Member Posts: 172
    Well, in EE there is no LAN game listing - unless I'm missing something.

    However, I can connect to the loopback address of 127.0.0.1 if I launch the EE client from that machine. Or I can use the internal IP address of 192.168.0.2:5301 from EE on another machine on the network to connect as well. And once I do that, I can always see it in the History section, and it does show lit up/available and accessible there. But it doesn't seem that is a good/true indicator the server is available to the world since it still shows grayed out and with a status of "Contacting server" on the main EE server list.

  • IndyWendieGoIndyWendieGo Member Posts: 62
    Balanor said:

    Thanks again everyone. Really appreciate the ideas/help. I have had this problem with both the standalone version niv posted (installed on Windows 7 and a Windows 10 machine) and the full client version of NWserver (installed on two other machines). Starting the server with the "-publicserver 1" command line option, or changing those master server lines in the nwnplayer.ini from 0 to 1 and back again didn't change the behavior either, though.

    However, I may have had a minor breakthrough.

    I was once again messing with my first Windows 10 test machine and had the Windows firewalls turned off for domain, private, and public profiles. I was using port 5301 and had the router setup not only to port forward 5301, but I also put that machine's IP (the 192.168.0.2) in the router's DMZ. Logging into the client on any computer on the server's network still wouldn't show my test server in the EE's server list - just the external IP and port with the "Contacting server" message that eventually changes to "offline".

    However, a short time ago, as I was glaring in frustration at the NWServer which was still running after my latest attempt...someone logged in! (Thanks go to "Max" for choosing to login to a server with a name of "Server" and a module called "test" :D )

    So, it appears that the problem is not that it isn't listed, but that it's just not visible in the EE serverlist from other computers on the same network. I'm not exactly sure if there is a way to remedy this, but I'm really hoping there is as I'd rather not rely on guesswork to tell if my server is truly visible in the EE server list if no one is logged in.

    If anything, we can private message and set up some time where I can try to log in through a campaign or something and help troubleshoot further. :open_mouth:

  • birdman076birdman076 Member Posts: 27
    Always had the problem of not seeing my own server listed from other PC's on my network. One other note, I would go up quite a bit on your IP assignment especially if you are running DHCP on your router. 2 is pretty low and could be snatched up by DHCP assignment from your network if there is a lul in down time or any down time at all. I typically run static internals starting at 150 and up so there is no chance of something else getting assigned to that IP...

  • BalanorBalanor Member Posts: 172
    Just wanted to close the loop on this -

    So I took my laptop over to a friends house the other day and was indeed able to see and login to the server with only port 5301 forwarded through the router (no DMZ and the Windows firewall on the test machine was re-enabled). It appears all my head bashing against that poor wall was for nothing.

    @birdman076 I'm assuming not being able to see your own server available in the server list may have been the case in 1.69 as well. I guess it's just been so long ago that we had a master server listing I forgot about it. It doesn't seem this is the case for everyone though, but be that as it may, I'll try to learn to live with it. As for not using 192.168.0.2, I definitely hear ya and won't be using that for anything other than brief testing.

  • FaerûnFaerûn Member Posts: 39
    Hey @Balanor,

    I'm having the same issue with currently no way to test your theory other than using NWNScry, which after having waited more than a few refresh cycles in, still fails to show my server. Were you able to see yourself in NWNScry?

    Sweetness
  • BalanorBalanor Member Posts: 172
    I've been able to see the server listed in the NWNEE Multiplayer tab for some time. They recently made a number of changes (like NAT punching) that should make a lot of the problems back from a few months ago go away.

    One thing though - your NWNEE server will not show up in NWNScry/NWNList Scry since that is a listing service only for NWN1 (non-EE) and NWN2 servers.

    Sweetness
  • SherincallSherincall Member Posts: 387
    See https://nwn.beamdog.net/

    You can also "GET" https://api.nwn.beamdog.net/v1/me from your server to diagnose any problems.

    Sweetness
Sign In or Register to comment.