Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

2.5 patch

Hi!
I read in the news section that the 2.5 patch had arrived. However, when I start the game there is no install button (I have the Beamdog Client version) and it still says I have version 1.4. Am I missing something?
/J

Comments

  • DoubledimasDoubledimas Member, Moderator, Mobile Tester Posts: 1,081
    MrSexton said:

    Hi!
    I read in the news section that the 2.5 patch had arrived. However, when I start the game there is no install button (I have the Beamdog Client version) and it still says I have version 1.4. Am I missing something?
    /J

    if you have the Beamdog Client, the retail version should allow you to update. I just did some days ago. So either you have the old Beamdog Client or you are on the beta branch which doesn't allow you to update.

    JuliusBorisov
  • MrSextonMrSexton Member Posts: 368

    MrSexton said:

    Hi!
    I read in the news section that the 2.5 patch had arrived. However, when I start the game there is no install button (I have the Beamdog Client version) and it still says I have version 1.4. Am I missing something?
    /J

    if you have the Beamdog Client, the retail version should allow you to update. I just did some days ago. So either you have the old Beamdog Client or you are on the beta branch which doesn't allow you to update.
    I've never done anything beta so how do I get the new client? I've always been able to update without problems before (BGEE, BGIIEE and SOD).
    /J

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 15,523
    Make sure you use the client that is supported - https://www.beamdog.com/about/client

  • MrSextonMrSexton Member Posts: 368

    Make sure you use the client that is supported - https://www.beamdog.com/about/client

    I think I used the word "client" wrongly. The way I've updated the Beamdog games before is simply by starting them and then pressing "Update" (there are two buttons "Update" and "Play Game"). Is this no longer the case?

    /J

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 15,523
    Yes, most likely you talk about Legacy launchers which are no longer supported.

    Don't worry about using the new Client much - if you won't like then you can just launch the games from their .exe directly.

Sign In or Register to comment.