Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

There's currently a forum problem with avatars not showing in reactions.
Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

How to report bugs you find in NWN:EE

ShaidenShaiden Member, Developer Posts: 140
edited November 2017 in Technical Support

Step 1: Check for Mods

Make sure that you have no mods installed, and that you have not edited your save game. If you do, try to reproduce the issue with a new game on a clean installation. We can’t fix issues with mods, and it’s often hard to tell where a bug came from if it’s only being reported on a modified game. If you can reproduce the issue with no mods installed, move to Step 2.

(If it turns out the issue was caused by one or more of your mods, check out the Modding forum and see if the mod's author can help you identify the cause of the problem. Your issue may help a mod designer/maintainer make their mod better!)

Step 2: Reproduce the issue.

If it’s a gameplay issue, try to go through the same steps you took to make it happen. The simpler the steps are the better, but it’s important to be precise so that we can isolate the cause and fix the problem. Be sure to create a saved game just prior to the steps you took, so that we can retrace those steps exactly.

If the issue is related to graphics or text, take a screenshot. On Windows and Mac, pressing PrntScrn during play will generate a screenshot in your \Documents\Neverwinter Nights\screenshots folder; you don’t need any external programs to make it work.

Step 3: Report the issue

Bug reporting will be handled using Redmine. If you do not yet have an account, register there first! For those who tested with us before, we're using a drastically simplified approach - so no worries!

There are separate projects in Redmine for each game. For NWN:EE, use https://support.baldursgate.com/projects/nwn-ee-public-bugs.

From there, you want to click on the "Issues" tab and look through or search to see if the issue has already been reported.

For each new issue, click on the "New Issue" tab, and fill in the following details:

In the Tracker: box, Select whether you think the issue is a Bug or a new Feature

In the Subject: box, A title that includes your platform in brackets and clearly states what is wrong.
Try to formulate the subject as a "should" or "should not" statement.

Example: [Windows] There should be no audio distortions while the movies play.

The following three items go in the Description Box:

A numbered list of exact steps that will reproduce the problem.
Anyone reading the list should be able to follow it without detailed knowledge of the quest or situation. There are two ways to do this:
1. Begin with starting a new game from the main menu.

2. Attach a zipped save and begin with "1. Load the attached save."
In either case, it is okay to include console commands to shorten the steps (see the example below).

A one-sentence statement (each) of the observed and expected behaviors.
As with the subject, try to use "should" or "should not" statements. If you don't know what the expected behavior is, write down the negation of the observed behavior.

Your hardware and any notes or additional media needed to understand or reproduce the issue.
Under Notes, include your hardware and anything else you want to add.

If you are reporting a visual problem, include a screenshot using jpg, png, or tga file format only.
You may also attach a video using mp4 file format only

If your game crashed, find the crash dump in Documents\Neverwinter Nights\logs and attach it to your report as a .zip. Also include the savegame that generated the crash dump.
The zip file format is the only permitted file compression format for bug ticket attachments. Please do not use RAR, 7z, bz2 or any other compression format.

Finally, in the Found In Version box, select the specific version you were testing.
Example report




Thanks!

JuliusBorisovDoubledimasCablefishAndarianlolienTorgrimmer

Comments

  • AndarianAndarian Member Posts: 138
    Thanks for the clear guidelines on this. I do have a question, though.

    You say that you "can't fix issues with mods," which strikes me as reasonable for player testing. But what about builder testing? As a mod author testing my work under NWN:EE, it would help me to know what to do if I find something that's broken (or at least, behaving differently from 1.69), from a builder's perspective. And I assume you would want to know about such problems as well. Should I create a standard bug report, or is there another way I should raise those kinds of issues?

    Thanks!

    fkirenicuslolien
  • fkirenicusfkirenicus Member Posts: 327
    edited November 2017
    Good question, @Andarian. At some point I think bug reports when building modules with custom content should be allowed, but for now maybe we should stick to the vanilla content? Was thinking of opening one of my own mods with huge amounts of custom content in the EE, but think I'll wait until Beamdog says it should be safe to do so, if you get my meaning... :-)

  • AndarianAndarian Member Posts: 138
    fkirenicus, Shaiden, thanks for the replies. That all makes sense.

    As with many of my fellow builders, I have a fair bit of experience creating and debugging NWN mods. So if I find such a problem, I'll have already analyzed and diagnosed the source as much as possible before bringing it to your attention. :)

    JuliusBorisovAtrophiederic
  • BradgeBradge Member Posts: 22
    I tried to follow the instructions to report a sound issue, but could not figure out how to create a log in for the bug reporter website.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 16,107
    edited December 2017
    @Bradge https://support.baldursgate.com/account/register What problem exactly do you encounter? You have to register first on that site, sign in and after that hit the "New Issue" tab at https://support.baldursgate.com/projects/nwn-ee-public-bugs

  • BradgeBradge Member Posts: 22
    edited December 2017
    @JuliusBorisov I am encountering the exact same problem as this person below:
    https://support.baldursgate.com/issues/33974

  • sandronejmsandronejm Member Posts: 44
    edited December 2017
    I'm here to report the gui transparent menu and the highlights in the main menu that occurs when you have a processor with integrated videocard in your notebook (in other words, there is no dedicated videocard).

    My lenovo Edge E431 for example has the minimum configurations to play Nwn and here are two screen shots of the issue:

    Note: in others notebooks with integrated videocard happens the same.
    Note 2: I still don't have the nwn:ee all the tests was in the nwn patch 1.69 diamond, but I presume that the problem persists in the nwn:ee and was not fixed as well.
    Screenshot 1



    Screenshot 2





    megamike15TheUncertainMan
  • TheUncertainManTheUncertainMan Member Posts: 49

    I'm here to report the gui transparent menu and the highlights in the main menu that occurs when you have a processor with integrated videocard in your notebook (in other words, there is no dedicated videocard).

    My lenovo Edge E431 for example has the minimum configurations to play Nwn and here are two screen shots of the issue:

    Note: in others notebooks with integrated videocard happens the same.
    Note 2: I still don't have the nwn:ee all the tests was in the nwn patch 1.69 diamond, but I presume that the problem persists in the nwn:ee and was not fixed as well.

    Can confirm that this is still an issue. Playing on a 64bit Ubuntu MATE Laptop with an integrated ATI chipset.

    sandronejm
  • sandronejmsandronejm Member Posts: 44
    edited February 1

    I'm here to report the gui transparent menu and the highlights in the main menu that occurs when you have a processor with integrated videocard in your notebook (in other words, there is no dedicated videocard).

    My lenovo Edge E431 for example has the minimum configurations to play Nwn and here are two screen shots of the issue:

    Note: in others notebooks with integrated videocard happens the same.
    Note 2: I still don't have the nwn:ee all the tests was in the nwn patch 1.69 diamond, but I presume that the problem persists in the nwn:ee and was not fixed as well.


    Can confirm that this is still an issue. Playing on a 64bit Ubuntu MATE Laptop with an integrated ATI chipset.
    Thank you! Please report it.

    I can't report it, because I (still) don't own the game. They refuse who don't own the game.

    @Shadooow check it!
    @JuliusBorisov check it!

  • megamike15megamike15 Member Posts: 1,124
    not sure if this is a bug or if it is due to me using god mode. so i've notice that when my henchmen dies the enemy's stop paying attention to me. allowing me to snipe them very easily [ i'm playing as an archer.].

  • VivienneLVivienneL Member Posts: 21
    That's what god mode does, the enemies stop attacking. You could try making your PC invulnerable instead.

    JuliusBorisovmegamike15
  • XorinaXorina Member Posts: 56
    Shaiden said:

    Step 1: Check for Mods

    For each new issue, click on the "New Issue" tab, and fill in the following details:
    There is no "New Issue" tab, it's just "Overview Activity Roadmap Issues Wiki" tabs. On clicking Issues, there is no new report tab to report my game stopping hard crash.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 16,107
    Xorina said:

    Shaiden said:

    Step 1: Check for Mods

    For each new issue, click on the "New Issue" tab, and fill in the following details:
    There is no "New Issue" tab, it's just "Overview Activity Roadmap Issues Wiki" tabs. On clicking Issues, there is no new report tab to report my game stopping hard crash.

    @Xorina Did you log into your account there? Can you try another browser?

    Xorina
  • XorinaXorina Member Posts: 56

    @Xorina Did you log into your account there? Can you try another browser?

    @JuliusBorosov Ah, I haven't signed in, my bad!

    JuliusBorisov
  • ProlericProleric Member Posts: 344
    edited August 21
    From Tarot Redhand 7 hours ago:

    [Quote]
    Tarot_Redhand7h
    Posting in the threads and sending a pm to the moderators is currently down. When I try, I get the following error message. Posting this here in the hope that someone can contact them directly to let them know.

    Argument 2 passed to Gdn_Cache::makeKey() must be of the type array, null given, called in /var/www/frontend-b755a7995be475/library/core/class.memcached.php on line 443

    TR
    [/Quote]

    Evidently, I can post in a thread, but I don't seem to be able to start a new one.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 16,107
    @Proleric This problem should have been fixed.

Sign In or Register to comment.