Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Beamdog Client exit code: 127

What exactly is exit code: 127? A web search gives this as a result, which is not of any help.

Trying to search the forum is of no help because the forum search feature does not correctly recognize exclamation marks (" ") or plus signs (+).

I updated to the latest Beamdog Client for Linux 64-bit, beamdogClient-2.1.3-x86_64.AppImage. The client launched with no problems. I verified my install of Planescape. The game will not start regardless of me starting it from within Beamdog Client or clicking on the file in the install location. Below is the error code listed within Beamdog Client.

The Beamdog Client encountered an error trying to run Planescape Torment: Enhanced Edition (Retail). Please contact Beamdog support and mention exit code: 127


  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 18,800
    I think the best way would be to create a bug report in mentioning your operating software and attaching all the logs.

    a) Right-click the cog in the bottom right of the Beamdog Client
    b) Select "Open Log folder"
    c) Close the Beamdog Client
    d) Attach (In a .zip) all of the files within this folder to your report.

  • ValamirCleaverValamirCleaver Member Posts: 184
    No one has ever encountered exit code: 127 & no one has any idea how to resolve it???

  • DoubledimasDoubledimas Member, Mobile Tester Posts: 1,180
  • ValamirCleaverValamirCleaver Member Posts: 184
    @Doubledimas thank you for that, I had previously found that via web searches. As far as I can tell there in no information there that would allow one to resolve my issue, that the game will not start from within Beamdog Client or clicking on the file in the install location. There is also no elaboration as to what specifically exit code: 127 is or means.

    No one on Linux has ever encountered exit code: 127 & no one has any idea how to resolve it???

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 18,800

    No one on Linux has ever encountered exit code: 127 & no one has any idea how to resolve it???

    I don't know. The devs can help you resolve it, and the way to get a solution is to report your issue as a separate ticket (as the ticket you mention is closed).

  • ShandyrShandyr Member Posts: 8,263
    I am also using Linux, mine is Ubuntu 16.04.3 LTS 64 bit.

    There are two ways here to address this issue. We have two problems here:

    1.) Start the game in any way.
    2.) Make the Beamdog Client work in Linux (Ubuntu) 64 bit

    Let's tackle 1.) first and let's try to start the game WITHOUT the Beamdog client. For that, go into the folder where you'll find "Torment", "Torment64" and "Torment.exe"

    On my system that folder is in
    ~/Beamdog Library/00827/

    Now, since you are on a 64 bit system, do the following: Open a terminal, change to the above directory (respectively the corresponding folder on your system) and then type


    That should start the game.

  • ShandyrShandyr Member Posts: 8,263
    Now, the post above only works for Planescape because it comes with the 64 bit version. But how would we play the other games? The problem here comes from the fact that we are trying to run 32 bit games in a 64 bit environment.

    I did get the same 127 error as you when I tried to start the game through the Beamdog Client. How did I make it work? By installing missing 32 bit libraries.

    So, now, let's tackle problem 2.) from the post above. Keep in mind that this works for my Linux distribution. I don't know which one you have.

    What I did was the following, open a terminal and then start as described here:

    sudo dpkg --add-architecture i386 sudo apt-get update sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386

    But that was not all, it didn't work yet, for me. I had to do more and type in:

    sudo apt-get install libjson0:i386

    And still, that was not enough yet. I still had to add more libraries as described here:
    sudo apt-get install libxxf86vm1:i386 libglu1-mesa:i386 libopenal1:i386 libssl1.0.0:i386

    And then I could start the games through the Beamdog Client on my Linux. I did not get the 127 error anymore.

    I do not know which of the libraries were the ones that are strictly necessary for this. You may not need all of them, I'm unsure. But at least, this way it works now for me.

  • AnitAnit Member Posts: 1
    I did what you said and now my game boots!!! thank you

Sign In or Register to comment.