Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

HELP!

doshidaniadoshidania Member Posts: 46
I've been trying to mod my BGEE on mac and I can't seem to get past this permissions thing. I'm far from a techie and I'm hoping someone on here can help. Here is the terminal error message :/Applications/Baldur's Gate - Enhanced Edition/Game Data/00777/Baldur's Gate - Enhanced Edition.app/Contents/Resources/OSX-bg1npc-v20/setup-bg1npc.command: line 5: ./setup-bg1npc: Permission denied

Comments

  • WispWisp Member Posts: 1,102
    edited November 2013
    In the terminal, type: chmod +x setup-bg1npc
    (press enter).

    However, note that BG1 NPC is not yet compatible with BG: EE.

    Post edited by Wisp on
  • doshidaniadoshidania Member Posts: 46
    Doesn't work (bg1npc was just a fill in name is was in reference to any mod)

  • mininofgruumshmininofgruumsh Member Posts: 12
    1) While in the directory where the permission-denied file is, enter the following command: "ls -l | grep " Where is replaced by the name of the file with permission issues.

    2) Take note of the permission string (it'll be some composition of r, w, x, and -) and the owner of the files.

    3) If your permission string does not have 3 'x' characters, try "chmod 555 "; this should give execution permission to this file for ALL users (as well as read, but not write since you probably don't want to change the mod file).

    4) Try the install again.

    5) If you're still getting a permission denied issue, it could be that the script/install file is trying to make a change that your user account isn't authorized to do. In which case, put "sudo" in front of the command you used to start the install. So long as your computer account has adequate permissions, it will ask you for your password and will run the command as root (the admin-est of accounts) and will have permissions to make the changes it wants. ((If you are not using the terminal to initiate the mod install, I'm not sure how to help you as I've never tried to run things as root outside of the terminal.))

  • doshidaniadoshidania Member Posts: 46
    Thank you for this info. I don't understand what you are saying in 1). Can you please dumb down that one?(Is not good at using terminal)

  • mininofgruumshmininofgruumsh Member Posts: 12
    Oh... Oh dear, I just noticed some of my characters got translated by the forum stuff to not show up....sorry.

    Let me try that again.

    1) In the directory where the file that is causing the permission issue exists (setup-bg1npc, for instance) enter the command "ls -l | grep [file name]" where [file name] is replaced by the name of the offending file. ("ls -l | grep setup-bg1npc", in this case). You may have to hunt a bit to find it since it's using the '.' shortcut, since '.' means the current working directory, and scripts can change the directory that is being worked out of.

    2) This one came out OK, I think.

    3) If you don't see three 'x' characters in the permission string, try "chmod 555 [file name]".

    4) This came out fine.

    5) This came out fine.

    Hope that clarifies.

  • doshidaniadoshidania Member Posts: 46
    Okay I tried these and it tells me there is no such file or directory?
    "
    Beth-Varnis-MacBook-Pro-2:~ bethvarni$ ls -l | grep setup-bg2fixpack
    Beth-Varnis-MacBook-Pro-2:~ bethvarni$ "ls -l | grep setup-bg2fixpack"
    -bash: ls -l | grep setup-bg2fixpack: command not found
    Beth-Varnis-MacBook-Pro-2:~ bethvarni$ chmod 555 setup-bg2fixpack
    chmod: setup-bg2fixpack: No such file or directory
    "

  • mininofgruumshmininofgruumsh Member Posts: 12
    Right, so it looks like you're running the commands I gave you from your home directory. You'll need to change your directory to whichever directory the file in question is. ("cd" is the change directory command). P.S. You had the ls command right the first time; ls -l will list the entire contents of the directoy in long format, and grep is a command that searches each line of its input for the provided parameter (in this case, the file name). The | operator sends the output of the first command (ls) to the second command (grep). So when that whole call comes up empty, it means that there is no file with that name in the directory.

  • doshidaniadoshidania Member Posts: 46
    So how do I change the directory its seeing? Type cd? Thank you for helping me with this. Feeling like a huge idiot.

  • doshidaniadoshidania Member Posts: 46
    Thanks for all the help! Out of nowhere I figured it all out. I still can't get the fix pack to work as its says the cpu whatever is bad in it but the other mods work now! Thanks so much!

  • AstroBryGuyAstroBryGuy Member Posts: 3,414
    @doshidania - FYI, you don't need the bg2 fixpack with BGEE.

    mininofgruumshFafnir
  • mininofgruumshmininofgruumsh Member Posts: 12
    Yeesh! I get busy for one minute and it days disappear on me! Anyway, I'm glad to hear you got things sorted out. And just to confirm, yes if you typed "cd /opt/Blibble/Bargle/" it would take you to the directory /opt/Blibble/Bargle. :) Keep using command line interface and get more familiar with it; some things are fun and it's *incredibly* powerful.

Sign In or Register to comment.