Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[How to] Install mods on Android

1246717

Comments

  • GusindaGusinda Member Posts: 1,584
    edited January 2018
    No probs, I was confused... Did you try installing the mods from the start (on a clean install) and trying one by one?
    Have you played using these mods before?

    Gus

    Edit: could you upload your WeiDU.log

    StummvonBordwehr
  • CaszidyCaszidy Member Posts: 205
    Yes, I tried clean install and tried only few mods, but still getting invalid lines :(
    I already deleted all files in fury of anger :D I will try new install tomorrow and than post WeiDU.log
    Thanks for your time, and help :+1:

    StummvonBordwehrGusinda
  • CaszidyCaszidy Member Posts: 205
    @Gusinda
    Ok, I installed all of mods I wanted and here is the WeiDU.log
    Now, I must hurry to work :smiley:

  • GusindaGusinda Member Posts: 1,584
    Hi @Caszidy, I installed the mods listed on both clean version of 2.3.x (Windows - with SoD and without) and 1.3.x (Android) where possible. I had an install prob with Aura when installing on BG with SoD but it went OK without. None of the new NPCs worked with 1.3 Android (Valerie seemed to work) but I didn't expect them to... I wasn't sure what components of the mods you were using (until I read your .log) so I installed everything I could.

    Results were that it all went well... Had no problems with selecting any classes and it seemed that there were no conflicts whilst playing (albeit a short play at the end of each mod install with a little longer once all mods were installed for each version of BG).

    Not sure why you are getting the class problems. Were you able to try for each mod install (and try the game at the end of each install)? Sounds like a PitA but this would be the only way to find out what is conflicting/messing with the game.

    Did you get errors with only the first mod installed (NPC Project only) when you tried to play it? This would confirm the process used to install the mod in the first place is working if none of the classes were invalid...

    Hope all went well at work
    Gus

    JuliusBorisovCaszidy
  • IsayaIsaya Member, Translator (NDA) Posts: 737
    @Caszidy Are you using the 2.5 beta version? I'm facing problems with it indeed.

    I tried two things with version 2.5 of BGEE on Android:
    • adding a "centralfixed" archive for the sounds in french (they are not part of 2.5 version on Android): the voices for the main character work, however voices for original NPCs remain in english. This is unexpected as they are all in the zip, although there are differences in the way they are organised: the voices for the PC are in lang/fr_FR/sounds while the other voices are in bif files (LocCha, ..., named as the ones for english in data) in lang/fr_FR/data. The same archive worked fine with version 1.3 of BGEE.
    • adding a mod archive (but only one archive at a time i.e. without the french sounds) with BG1 NPC and Finch (who appears in Candlekeep, and is therefore easy to test), including of course additional texts. When I stard a new game, I indeed meet Finch in Candlekeep, but all the texts are "Invalid". This means the mods files in override are recognized (Finch appears and talk, hence area script patch, character file, portrait and dialog are used) but the obviously the dialog.tlk file used by the game is still the unmodded one. The same archive worked fine with version 1.3. Sure, I didn't reinstall the mods starting from the 2.5 obb files, but that should mainly cause problems with texts added by patch 2.0 to 2.5 missing in my dialog.tlk file (all set to "placeholder").
    I believe this behaviour shows there are specific issues in version 2.5 with some kind of overrides in zip files, notably dialog.tlk (texts) and probably bif files, while other overrides are still working as they were with version 1.3.

    JuliusBorisovGusindaCaszidy
  • CaszidyCaszidy Member Posts: 205
    Thanks for your effort, will try everything right when I will have time (too little now :( )

    Gusinda
  • GusindaGusinda Member Posts: 1,584
    edited January 2018
    G'Day @Isaya. Having a read, you indicated that you are not using the 2.5 version to create the modfiles. You will need to reinstall the mods using the 2.5 Obb Files as the dialog.tlk used would be different (taking into account all of the updates that 2.x does) for 2.5 over the 1.3 version (unless your using the 2.5 beta for PC to create modfile?).

    Best starting point would be a clean modding setup using the 2.5 Obb files and just install Finch for a test... As your prob aware, you don't need to remove any of your current 1.3 modding config on the PC to do this, just use a new folder. I am unsure about the voice (audio) files themselves though.

    Gus

  • CaszidyCaszidy Member Posts: 205
    edited January 2018
    Hmm, I was thinking about it, and came with the same conclusion as @Isaya - I tried to install only BG1NPC mod and while the mod content is there, all the dialogs are producing invalid lines. Meanwhile when I try Tweaks Anthology, the tweaks (stacking arrows) works just fine.

    So the problem must be only with dialog.tlk file, while mod content from override folder is fine (locations, new npcs, items etc.)
    I used clean 2.5beta files for install.
    I have an idea - since I have in game chosen option for my native language (Czech), and I'm 100% sure weidu install uses cs_CZ folder and dialog.tlk, (I checked it) , but maybe the additional lang/cs_CZ folder and dialog.tlk file is not recognized, maybe it requires default language. So I will try use the same moded dialog.tlk file, but put it in Android tablet into folder structure lang/en_US (I'm only guessing now). - sorry for my gritty english grammar :blush: I hope its understandable.

    I tried also not put lang/cs_CZ/dialog.tlk in zip, but it didn't help either.

  • GusindaGusinda Member Posts: 1,584
    Hi @Caszidy, I wasn't aware of the Czech language install... Would you be able to try something then as part of the fault finding then?

    Given that you have an install with just BG1NPC and Tweaks configured, in a new folder (BG1EE Modfile), create the following structure:

    ..\BG1EE Modfile\lang\cs_CZ
    ..\BG1EE Modfile\lang\en_US
    ..\BG1EE Modfile\override

    From the folder where you installed your mods, copy the following files into their corresponding folders:

    \lang\cs_CZ\dialog.tlk
    \lang\en_US\dialog.tlk
    \override (all contents)


    In 'BG1EE Modfile' folder, click on '\lang' and zip it as a store (lang.zip). Apply 'centralfix' to it, then zip lang.zip and the 'override' together etc to move on to the device. Unpack on the device as done previously and try the game again.

    This puts both the default language and your language on the device. It may work, it might not... I will try here to setup a modfile using the Czech language (although it will all be invalid to be not knowing a second language :smile: ) and see what happens on my config.

    For @Isaya, if this works, we might be able to also include the audio files given you are using the french language.

    Thanks
    Gus

    CaszidyStummvonBordwehr
  • CaszidyCaszidy Member Posts: 205
    Will try it immediatelly when I will have time to do it (evening/night/tomorrow morning) and post results :wink:

  • CaszidyCaszidy Member Posts: 205
    @Gusinda @Isaya
    Ok, this is weird.
    I tried procedure which @Gusinda suggested, but unfortunatelly it didn't help.
    Then in most desperation I tried procedure which I outlined - take moded dialog.tlk file from my cs_CZ lang folder, and put it in newly created en_US folder, zip it, centralfix it, in game I changed language to default - english and "heuréka"! It worked - I have game in my czech language with functional mod content text, no invalid dialog files! :smiley:
    Thanks to all of you for your time and willingnes to help :+1:

    Gusinda
  • GusindaGusinda Member Posts: 1,584
    @Caszidy, That is great to hear. Will need to pack that info away in the grey matter for future fault finding. I ended up installing a couple of mods from your list in CZ and ended up with INVALID dialog (as opposed to INVALID Classes). When I installed the same in US, there were no problems. Anyway, good to see you are back in the game (so to speak).

    Gus

    Caszidy
  • alannahsmithalannahsmith Member Posts: 142
    I think I am missing something. I do not know how to "centralfix" the zip. I am not tech savvy enough to figure it out :(

  • CaszidyCaszidy Member Posts: 205
    @alannahsmith
    Look at the first post in this thread, the process is really good described by @Isaya
    If you have Windows 10, than there is default Command line replaced with Powershell and in Powershell centralfix don't work (or I dont figure out, how to get it work), so to use Command line, open in Windows explorer folder where you have zip file and centralfix.exe software. In Windows explorer path line type "cmd" and Command line will open.
    Than you can continue by tutorial described by Isaya - type "centralfix lang.zip" (or whatever your filename is; without quotation marks of course) and your file will be centralfixed ;)

    Gusindaalannahsmith
  • legotaksinlegotaksin Member Posts: 61
    hello, i'm korean bg2 android player. bg2 doesn't support korean language officially. so korean players make custom language mod but it doesn't work in android.
    i'm currently play Android bg2 beta 2.5 version. i attached language mod file. please help me..
    As i know In 2.5 beta pc version, this mod is work. but android version is not.(i have only android version)

    lang folder has korean dialog.tlk and override folder has bgee.lua(it is extracted in v2.3 version bg2ee, to show korean language option) and L_ko_KR.LUA(it is translate menu to korean) and nanum.ttf has font file.

    when bgee.lua is in override folder, game is not working..

    please help me..


  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 19,598
    Looking at the recent comments in this thread and the feedback by @merong in the beta-survey, I've asked the programmers for some help to clarify the situation.

    dialog.tlk has changed between the 1.3 (and even the 2.3, and even the 2.4 (iOS)) and the 2.5 version, and this is most likely the reason for a few problems. If you copy over the mods you have made with versions prior to 2.5 on PC into 2.5 on Android, things will break.

    StummvonBordwehr
  • GusindaGusinda Member Posts: 1,584
    edited January 2018
    G'Day @legotaksin, you didn't mention what the symptoms were (did the game crash/not start, show invalid statements, or other problems), but here goes...

    You could try the solution above where the language dialog.tlk was placed into the en_US folder (which is the default language folder) before centralfix is applied. For you, it would be to rename the ko_KR folder to en_US then use centralfix.

    I am unsure whether you have the required modding setup to make any changes so I renamed the folder, rezipped and 'centralfixed' it into 2 different versions. The reason I made 2 versions is that I have always had more success when the override folder is unpacked with BG2EE (seems to work no problems when packed with BGEE).

    The first (BG2EE-Korean.zip) is made to just replace the current modfile on your device. You end up with ..\files\BG2EE-Korean.zip.

    The second (BG2EE-Korean2.zip) requires you to replace your current modfile, then extract the contents making sure that you extract to the current folder keeping the folder structure (you will end up with ..\files\override and ..\files\lang.zip). The lang.zip contains the dialog.tlk (centralfixed) and the override folder contains the rest.

    Make sure that the old modfile deleted/moved when you replace it with either (only one) of these files.

    Hopefully you know where the modfile is supposed to go, if not let this discussion know and I/someone will respond.

    Of couse, this doesn't overwrite what Julius said above, the dialog.tlk would need to be redone for 2.5. This is just a test...

    You never know your luck in a big city!
    Gus

    JuliusBorisovStummvonBordwehr
  • Luke93Luke93 Member, Mobile Tester Posts: 1,295
    @Gusinda I have a question: is it possible to install UI mods and/or mods add or update areas?

  • legotaksinlegotaksin Member Posts: 61

    Looking at the recent comments in this thread and the feedback by @merong in the beta-survey, I've asked the programmers for some help to clarify the situation.

    dialog.tlk has changed between the 1.3 (and even the 2.3, and even the 2.4 (iOS)) and the 2.5 version, and this is most likely the reason for a few problems. If you copy over the mods you have made with versions prior to 2.5 on PC into 2.5 on Android, things will break.

    -------------------------------------------------
    Sorry for late and really thanks to try to solve my problem.
    But unfortunately, 2 things don't work..
    When i put that zip file in bg2~/file, game doesn't start and show error message.

    Before saying this problem, i already know how to use centralfix and install mod. when game version was android 1.3 version, i installed korea language mod(not this mod file which i uploaded but almost have same structure)

    To try to solve this problem(in 2.5 beta), I did few things but all things are fail.

    When bgee.lua file is in game folder, game is not working(only show error message 'game is not working blar blar')

    I guess that bgee.lua has problem and maybe font is too.But I'm not orginal korean language moder so I don't know how to solve anymore.. (Orginal moder doesn't come korean bg2 community anymore..)

    Installing mod(using dialog change) in 2.5 android version is really difficult. I really hope that beamdog developers teach how to install mod in 2.5 version..

    Anyway really thanks to ur reply . :smile:

  • GusindaGusinda Member Posts: 1,584
    @legotaksin, this is why I use version 2 of the mod and unpack the contents of override. Been a prob for me in BG2EE.

    @Luke93 - I don't actually have 2.5 yet to try (my games are from GoG and didn't want to update from Play as I rarely play on my phone. I will wait for the proper release... But, looking at the UI Mods, I can't see no reason for them not to.

    Gus

    StummvonBordwehr
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 19,598
    @legotaksin Who is the author of the Korean language mod you use? They should update their mod translation for the 2.5 version in order for it to work fine.

  • IsayaIsaya Member, Translator (NDA) Posts: 737
    @JuliusBorisov @Gusinda, I rebuilt the same mod installation as I described based on version 2.5 beta of BGEE on Android. I get exactly the same bad behaviour as explained here.

    I have the same behaviour as @Caszidy and @legotaksin. Texts are properly displaed (instead of Invalid #) if I using my dialog.tlk and dialogF.tlk files in the lang/en_US and switch language to English.

    Mod set used:
    • BG1 NPC
    • BG1 NPC music
    • BG1 Unfinished Business
    • Finch
    • Thalantyr Item Upgrade
    Files transfered to Android in files directory:
    • dialog.tlk and dialoF.tlk in lang/fr_FR in a centralfixed archive (Mods-BG1NPC-UB-Finch-Thalan_txt.zip)
    • override directory content zipped then unzipped on Android
    • additionnal centralfixed file (SoundsFrBeamdog.zip) containing content of lang/fr_FR/data (bif files for french voices) and lang/fr_FR/sounds (french sound sets for main character) from PC version of BGEE V2.5, and a few more sound files in lang/fr_FR/movies, notably ERROR01.WAV ("You must gather your party...") in french
    Texts triggered: Finch in Candlekeep, Imoen talks from BG1 NPC about Tarnesh book and arriving in Beregost
    All displayed as "Invalid " in french language. Original game texts (tutors in Candlekeep) are displayed properly, in french.

    Sounds used by the game: all game voices are in english, except for the main character and "You must gather...".

    Summary of first test:
    • dialog.tlk and dialogF.tlk in lang/fr_FR are not taken into account
    • bif files in lang/fr_FR/data are not taken into account
    • sound files in lang/fr_FR/sounds are used
    • sound files in lang/fr_FR/movies are used (acting as override folder)
    Second test: text files and sounds moved to lang/en_US, english language selected in game

    Files transfered to Android in files directory:
    • dialog.tlk and dialoF.tlk in lang/en_US, data and movies moved from lang/fr_FR to lang/en_US (lang/fr_FR/sounds not moved so as to not override english sound for the main character), all included in a centralized archive (SoundsFrBeamdog_in_enUS.zip)
    • override directory content zipped then unzipped on Android
    Texts triggered: same as before
    All displayed properly, in french language (language chosen to install the mod). Original game texts (tutors in Candlekeep) are still displayed properly, in french.

    Sounds used by the game : all game voices are in english, except for "You must gather..."

    Summary of second test:
    • dialog.tlk (at least, not sure for dialogF.tlk) in lang/en_US taken into account (dialog.tlk made from french game file and from mods properly overriding original english dialog.tlk)
    • bif files in lang/en_US/data are not taken into account (maybe en_US is hard coded to look for them in the data directory together with other bif files)
    • sound files in lang/en_US/movies are used (acting as override folder)

    Summary of both tests (in terms of issues):
    • it seems that dialog.tlk is only handled if in lang/en_US in the centralfixed archive
    • bif files in lang/fr_FR/data are not taken into account (potentially true for all languages other than english): since Beamdog does not release sound files on Android as in the desktop version, this is a big drawback of Android version compared to desktop version

    I'll file a bug report on redmine. This is huge regression compared to V1.3. It's still possible to mod the game, but only in English.
    If Beamdog does not release the sound files for other languages in the final version of the patch on Android, as in the desktop version, this bug will also prevent people from adding them easily into the game (dropping a single archive in files directory).

    CaszidyGusindaJuliusBorisov
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 19,598
    I'd appreciate it if you file it, @Isaya. Sounds not good.

  • El_WrobelEl_Wrobel Member Posts: 2
    edited February 2018
    If anyone wants to install mods right now, just use English as your in game language and when centralfixing the lang folder, remove sounds folder, so you've got only dialog.tlk in en_US directory, if you won't you'll be flooded with invalids, everytime.

    Aside from that, I'll summarise my tests: Don't even bother right now, unless you need like one or two mods tops or you're the zen master.
    Nothing works as it should, doing the same installation the same way will have varying results even with mods that have no conflicts, even if on PC it will run flawlessly if you'll install it the same way, tried numerous times.
    And if the planets align and you actually are able to make it work, strange bugs, not present in the pc versions, will be crashing your game, f.e. BG2 tome and blood, playing as a mage and choosing magic bolt as your cantrip will crash the game. But only on some installations, other times it will work flawlessly, installing the same mods.

    I've tried to make the same mod setup work, installing it around 30 times in different ways, only to add a couple of quest and npc mods and see everything run just fine, with the exact same gameplay mods (for now at least). And it's not a small install as well, around 1GB.
    So if you've got ballz of steel, you can make it work. Balls won't cut it though, you need to have ballz.

    Oh and I've been able to get some of my PC installations to work flawlessly as well, just straight up take the dialog.tlk and override, zip'em,fix'em and drop on your phone, but same random rules apply.

    Same story on icewind dale, can't for the life of mine figure out why T&B makes the game crash when lizard shamans cast silence with some radius. Had a crash on skeleton mage as well, but he was rather easy to get through, don't know if he was casting the same spell.
    But only on some installations of course, on others, while mechanically everything seems fine, you'll get invalids. I don't own iwd on the pc, but I'm pretty sure it wouldn't happen.

    It's like looking at the world with mad mans eyes, only in this case, same things yielding different results.
    Either gameplay aspects are fine, but all added text is invalid, or it works, but breaks something. Or maybe I just started doing something wrong because of my tireless efforts to make this fucking thing work.

    And as a last note, if you want to use BWS, unzip your android files and drop baldur.exe in there, BWS will install files correctly, though only sometimes you won't get invalids.

    EDIT: So it turns out I'm a tit and missed one, as it turns out very important, step, run the command prompt as administrator, didn't think much of it, but tried doing 3 installs, 2 on iwd and one on BG2 and didn't get any invalid text. Crashes are still there, in both BG and IWD, but seems like they're related to T&B, in both games.

    EDIT2: Or maybe not, things still break completely randomly.

    Post edited by El_Wrobel on
    JuliusBorisov
  • CavakCavak Member Posts: 25
    Has anyone had luck with Iwdification and Faith's and powers in BGEE? At the moment when I mod in iwdee spells from Iwdification or faiths and powers any damage dealing spell from iwd crashes the game.

    Tried with both 1.3 and 2.5. debuff spells on enemies and self/team targeted spells work fine from iwdee.

    The same combo of mods installed on my PC work fine.

    Mods are:
    Might and guile
    Faith's and powers
    Iwdification
    SCStratagems
    BG1npc
    Unfinished Biz
    Npc_ee

  • Mantis37Mantis37 Member Posts: 1,040
    I'm still on 1.3 and had few problems doing a BG1 install with various mods. For BG2 is it possible to use BWS?

  • GusindaGusinda Member Posts: 1,584
    @Mantis37, never used BWS so can't answer that, but what sort of problems were you have with BG1 install?

    Gus

  • Mantis37Mantis37 Member Posts: 1,040
    I had few problems = No big problems. Sorry :). I'd just like to install more this time!

    Gusinda
  • Mantis37Mantis37 Member Posts: 1,040
    edited March 2018
    Has anyone found limits for the size or number of files which can be included in the final centralfixed zip file? I have made multiple attempts at installations and found that the game will not start if I include a large number of mods, or something which modifies a large number of files like BG Tweaks. I have 2 or 3 working zips of around 500mb, but haven't been able to pin down any particular mod as causing installations to fail. Has anyone had any luck with much more complex installs?

Sign In or Register to comment.