Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[Mod] The Deratiseur Unused Kits Pack for BG2/BGT and all EE versions in french and english v16

2»

Comments

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 18,717
    @Scourgeofthe7Seas Those are completely off-topic comments. While staying on this forum, please follow the Site Rules, and be respectful to others.

  • ReddbaneReddbane Member Posts: 219
    edited November 2018

    Might be a touch more impressed if some of the descriptions didn't look like they were written by a thirteen-year-old trying to be edgy, but beyond that...

    Most of the Kit descriptions are taken from or based upon the descriptions in the actual Dungeons and Dragons Source books. If you don't like the writing style employed in classic D&D, that's alright, but at that point why even play a classic D&D game anyway? Moreover, why insult a modder proving free content based upon him/her using the words employed in the original D&D source material? If you really have a problem with the writing style why don't you contact Wizards of the Coast, the owner's and publishers of the material, or write a letter/email to the authors of the Sourcebooks?

  • ZaghoulZaghoul Member, Moderator Posts: 3,930
    Fantastic attention to detail, including spells, sounds, and even graphics. You really put alot of work into this. Some of these kits really 'bring to life' ideas I was looking for. :)

  • deratiseurderatiseur Member Posts: 99
    I have 3 unfinished kits, missing spell icons. I'm a purist and i want only BG2 style icons. So it's a shame to have these kits unfinished (a pyromagus inspired by magnus from PST, a meta-archer and a special kit for F/M/T)

    Zaghoul
  • ZaghoulZaghoul Member, Moderator Posts: 3,930
    I can understand wanting the icons to fit just right. Hopefully you'll be able to find what you need to complete them. :) The ones you have used in the kits I have tried so far really make spells and abilities stand out in a great way.

  • deratiseurderatiseur Member Posts: 99
    Zaghoul said:

    Fantastic attention to detail, including spells, sounds, and even graphics. You really put alot of work into this. Some of these kits really 'bring to life' ideas I was looking for. :)

    Thanks for you comment. I enjoy to see that people like my work.

    Zaghoul
  • GusindaGusinda Member Posts: 1,550
    edited April 8
    Hi @deratiseur, First of all, thank you for the kits you have put together.

    I hope you don't mind but I was installing your kits package and found some problems for the english installation so went through to see what was happening and get them installed. I will start by saying that I an new to the dark arts of WeiDU and don't know any French! That just says about everything when it came to fault finding the problems I encountered :smile:

    I am unsure whether the link at the top of this thread is the latest but it is the one that I used.

    I will list the changes I made to get it working and leave it to yourself whether you want to implement some, all, or abandon them (or indeed point me to the latest).


    Changes made:
    ~~~~~~~~~~~~~


    - Updated to v15 in 'Setup-Derats_kits.tp2'. It was downloaded using the link in the OP which indicates it is v15 but internally had it at 14.


    - Align Kits with French version
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    In Setup.tra (English), some lines were commented out due to incomplete or old kits. This introduced translation errors upon install as there was nothing to in setup.tra to call. To remedy this, I compared the french setup.tra with the english version and found a couple of the kits had been given different @calls, so I aligned the english version to the french and change the various linked files to suit; meaning that I renumbered the @calls in both Projectile.tra and Theruge.tra.

    From what I could tell, the changes didn't impact on any of the kits other than some commented lines.

    One of the kits is still French Only (Gnome Shadowmage) but the call for the variable wasn't translated into the english tra, so it was feeding back an install error. I fixed that and informed the english installers not to install the kit because it was French only, so I didn't add 'Ombremage.tra' to the english folder. The only problem is that if the mod user were to use the function at the start to install all kits, it will also attempt to include the Gnome kit.

    To overcome this, I added the following line to just above the LANGUAGE section:
    ASK_EVERY_COMPONENT


    Below are the changes made and the commented (which are still included in the file for archival purposes).
    All changes were made to the Setup.tra.

    @40
    was
    //@40 = Place provided for Kits never finished : Cryomancer and Master of Unlife
    changed to
    @40 = ~Do not install (English only) - Thief (Gnome) Kit : Shadowmage (French Only)~

    @60
    was
    //@60 = Previous place for the improved Beastmaster
    changed to
    @60 = ~Multi-Class Cleric/Mage (human) Kit : Theurgical Explorer~
    [In line with this, I changed the @calls within 'Theurge.tra']

    @90
    was
    //@90 = Previous place for Arcane Blade/Blade Singer v6
    changed to
    @90 = ~Mage Kit (it replaces the summoner) : Savant Artilleryman~
    [In line with this, I changed the @calls in 'Projectile.tra']

    I also commented out
    //@130 = ~Mage Kit (it replaces the summoner) : Savant Artilleryman~
    //@140 = ~Multi-Class Cleric/Mage (human) Kit : Theurgical Explorer~
    which weren't being referenced in 'Setup-Derats_kits.tp2'



    - Mage Kit : Warlord
    ~~~~~~~~~~~~~~~~~~
    The Warlord kit wouldn't install due to a couple of items not being translated or included in 'Warlord - Lumens.tra' resulting in a halt to the install for that component. I grabbed the contents of the French tra and translated them though Google Translate. Reading the result, it all seemed fine (I can't speak/write a word of French so...). Added it to the english .tra and fixed up the STATISTICS component for each.

    The Warlord items were:
    pxl7011.itm - Battleaxe (Death to the Innocent) @7011 and @7012.
    pxl7089.itm - Helmet (Oreyn Griffedours Helmet) @7089 and @7090. Also fixed the COPY command in 'Setup-Derats_kits.tp2' SAY NAME2 @7089 (was @7087)



    - Bladesinger Kit
    ~~~~~~~~~~~~~~~
    Another @call which failed during install was @88 which called 'Added the options to make the Bladesinger less RP and more fun to play'. Neither @88 or @89 was included in 'Chantelameur.tra'. I grabbed the contents from the french version, translated and adjusted a little more (Google couldn't translte Chantelameur to Bladesinger, so I hope that is what it means), then added to the english .tra.


    In the attached file, I have placed all the modified files in the folder structure used for the mod. As I said, I will leave it to you whether you want to implement the changes or not.

    Hopefully this will be fine with you and it now installs all the available components in your mod for english language gamers. It was tested in IWDEE, BG1EE with SOD and BG2EE on PC with the only error being if I tried to install the Gnome Shadowmage. It is also being tested in the Android environment.

    Looking forward to now playing around with the kits in game :)

    Thanks again
    Gus

    RaduzielZaghoul
  • deratiseurderatiseur Member Posts: 99
    edited April 15
    Thanks Gusinda.

    Infact, these errors in english was ever corrected, thanks to an user who signal them to me via emails five days ago.
    Some over things are done for the v16, but not enough for justify a new release.
    But you make up my mind for relasing the tiny v16 soon.

    Post edited by deratiseur on
    Gusinda
  • deratiseurderatiseur Member Posts: 99
    The V16 is up, with the fixes of english translation files.

    Note : Two days after someone signal these problems to me, i've corrected thems. I stay up about my mods.
    the v15 was released one year ago. In one year, i think that many people tried my mod, found it bugged and just leave it. It's a pity that so few people make the effort to report bugs.

    GusindaZaghoul
  • greentoiletgreentoilet Member Posts: 15
    @deratiseur I tried installing the Warlord kit but it didn't seem to work . Look at the following picture.
    cvmtmxsumw1j.png
    It creates a very long list of those empty spots when you select Exalted fighter.
    Maybe it doesn't matter I'll ignore it and start the game but ingame there was nothing special only a regular lvl 7 fighter.

    I thought maybe the mage skills will come when you hit level 10 or something so I used EEkeeper to add 4 million exp and checked. Nothing changed, now there's the same fighter but high level and not a single mage skill.

    All of this was done with clean install no other mods interfered.

  • deratiseurderatiseur Member Posts: 99
    edited June 29
    The exalted fighter is a "standard" fighter with limited proficiencies choise. Maybe the empty slots are the borbidden weapons.
    Check if his kit name is "exalted fighter"/
    The mage spells come when he dual to a mage. Do you have dualed it ? And/Or do you have read the read-me ?

    Post edited by deratiseur on
  • greentoiletgreentoilet Member Posts: 15
    edited April 16
    lol apologies I thought it was a multi class "A fighter paired to a mage kit" left me in doubt a bit on what it really was. I'll try again and let you know.

    edit: No issues, everything works correctly. The HLA screen also has the empty spots but I can just ignore it and play. :)

  • deratiseurderatiseur Member Posts: 99
    "paired" is a bad word ? I don't really know, my english isn't so good so i let Nightfarer translate the mod, and i don't read it in english.

  • ArthasArthas Member Posts: 926
    HEy,
    is this compatible with EET?

  • deratiseurderatiseur Member Posts: 99
    i don't use EET, so i can't confirm. But there's no reasons for not, so try (and please, come give the answer)

  • RangeltoftRangeltoft Member Posts: 73
    Hello.
    Been looking into using this mod for one of my next plays, so started messing around with the Master of Swarms druid kit. It seems that alot of the HLA are unselectable, think there were only 3 of the unique ones that i could select at max XP.
    This is the only mod i have installed on a fresh Bg2EE folder, just wondering if this is a known issue?

  • deratiseurderatiseur Member Posts: 99
    edited July 8
    for the Master of swarm, you have to gain hla 1 (scarabs) AND hla 2 (spiders) for an acces to HLA 3 (Planars) or Hla 4 (uniques). Then you have to master the hlas 1, 2, 3 AND 4 for an acess to hla 5, and so on....
    It's wrote on the readme. Cheat for max xp don't work 100% for this kit, you have to cheat lvl per lvl after 3M until you have the last hla.

  • RangeltoftRangeltoft Member Posts: 73
    Oh, i missed that, will try it out that way then. Thanks :)

  • vxnguyenvxnguyen Member Posts: 1
    edited July 27
    Hi,

    Wonderful job with this pack of kits! I did have one question though...

    I'm using the Bladesinger mod for BGIIEE and was wondering why Elven Chain (all variants), Sylvan Chain, Bladesinger Chain+4, and Aslyferund Chain+5 would be considered not usable by this kit. Aren't they considered lighter than Studded Leather Armor?

    Would it be possible to allow the kit to wear chainmail of the elven type or even chainmail somehow? I think that the offset of losing spellcasting ability while in non-elven chainmail would essentially be the drawback.

    Post edited by vxnguyen on
  • deratiseurderatiseur Member Posts: 99
    edited July 28
    It's not the right place for a comment on the Bladesinger. I reply in the good topic, here.

  • Necromanx2Necromanx2 Member Posts: 1,050
    You have a multi-class Bladesinger in this kit pack. It says no armor heavier than studded leather. Does that mean that the bladesinger from this kitpack cannot use elven chain?

  • deratiseurderatiseur Member Posts: 99
    No, he can't. It's one of his disadvantages: no armor better than Studded leather armor. He has many advantages, so i won't remove this one. And it was made from p&p version.

Sign In or Register to comment.