Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Soulafein, NO VALID LINKS (probable spoilers - seriously stay away if you don't want to see them)

epheweephewe Member Posts: 8
edited March 2017 in Troubleshooting
Hey guys. So I'm on my very first BG2 play-through (and I'm over thirty, holy crap why have I not played this game a decade ago???). Anyway, I am in the Underdark right... I'm about to enter the Temple of Lolth to go steal the dragon eggs. As I'm about to enter, Soulafein teleports in (I was supposed to kill him but I let him go because he's a good drow and he faked his death, etc.). Anyway, he says something like, "so hey I can totally help you with this NO VALID REPLY LINK". There is no option to click. Hitting numbers on the keyboard does nothing. All i can do is ignore him and enter. I do not want to do this, as that would be totally breaking my narrative. I have investigated a little as to what might cause this. I tried uninstalling all mods (reinstalling the game clean) and loading to a point before that... still happens... I have tried installing fixes which are said to resolve this issue (both bg2 fixpack and something called sulaufeinflirtpack). Neither of which will install on my game. Both says files cannot be found and thus the patch rolls back. I do not want to ignore Solaufein. Anyone know anything about this?

*EDIT: Actually I was there to exchange the eggs, I think. I had already gotten them*

Post edited by ephewe on


  • epheweephewe Member Posts: 8
    edited March 2017
  • sarevok57sarevok57 Member Posts: 4,977
    looks like your dialogue file got messed up ( perhaps from mods and such) the problem here is though, your saved game probably "saved" the broken dialogue file lines, and now probably now no matter what you do it will always do that, the only real way to get around this is to use the cheat console or ee keeper because this is what happens:

    solafein is supposed to give you fake dragon eggs to foil phaere's plan, so you can either accept (recommended) or not accept his offer ( not recommended) if you want to accept, you can just EE keeper the eggs into your game (fake dragon eggs solafein's) or use the cheat console to summon them in, the code is: MISC9V ,

    other than that, there is probably no other way to get around this problem

  • Gate70Gate70 Member, Developer Posts: 3,664
    Enable the console and enter one of these commands, or use EE Keeper to set the value in a save.

    (a value of 2 is where he doesn't know what you are doing and 3 is when you told him your plans)

    If you wanted to see what the existing value was before updating it, the command is

  • epheweephewe Member Posts: 8
    Weird it will not let me reply

  • epheweephewe Member Posts: 8
    Actually sarevok, I already got the eggs from someone else when I got to that point (I had them in my inventory even). In any case, I was afraid of hearing exactly what you guys have told me (that my save itself is screwed). At least there's a fix though. Thanks a lot for the information (both of you)!

    I might even be able to offer some insight into how that happened (now that you've put me on the correct route). Earlier, I was told to meet Solaufein near the east tunnel to save Pharae. When I did that, I was instantly captured by illithids (which leads to a whole different thing). When I finished that, I went back to where Solaufein was standing and he would only say something like "I am concerned about my future". That being the case, I had to use the method described above by Gate70 in order to get him to continue with the quest to save Pharae. I bet that is why his behavior was all messed up later on, outside the Temple of Lolth.

    What I ended up doing, since I only got the reply to this *now* (no offense), was this: I walked past Solaufein into the temple and did the stuff I had to do. This caused the entire city to turn hostile, even (oddly) Solaufein. I didn't want to kill him through, so I dominated him and ran him off to a corner for a time-out, then I cleared the rest of the city and moved on with the game. Yeah I know. it's probably broken anyway.

    Ooooh hey... *idea*! How exactly can I make it so that he's not hostile to me? I am thinking he's probably going to pop up again later in SoA or ToB...?

  • TressetTresset Member, Moderator Posts: 7,741
    ephewe said:

    Weird it will not let me reply

    @ephewe I fixed the problem for you.

  • Gate70Gate70 Member, Developer Posts: 3,664
    Solaufein will not appear again (unless you have a Solaufein mod I guess...), and your choices/solution in Ust Natha don't have any further impact on the game once out of the Underdark.

    Enjoy the rest of your game

  • epheweephewe Member Posts: 8
    edited March 2017
    Heey there's my other post. Just to clarify, I was trying to post and it kept showing up as blank. It's here now though. Anyway, thanks Gate! Thanks Tresset!

Sign In or Register to comment.