Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[Kit Pack] I Hate Undead v3.7 [IWD, BG(2)EE and EET]

24567

Comments

  • compostercomposter Member Posts: 24
    edited December 2017
    i found problem. i use russian language, if switch to english - it works fine !

  • compostercomposter Member Posts: 24
    I found problem. I use russian language, if switch to english - it works fine.

  • RaduzielRaduziel Member Posts: 4,716
    @composter Unfortunately this mod only supports English and France for now, but I'm open to receive more translations.

  • compostercomposter Member Posts: 24
    i thought, that untranslated strings replaced english strings.but i remembered that when i choose new class (in russian language) shaman i see "placeholder", and instead shaman dance i see the same )))

  • RaduzielRaduziel Member Posts: 4,716
    Version 1.6 is up with some changes for the Undead Slayer:

    1) Now it gains a d6 hit die.

    2) No longer it gains the extra spell slot for being a "specialist".

    3) You don't need the IWDEE workaround anymore!

    I intend to make a Shaman and a Sorcerer kit and call it a day for this mod, but the Shaman idea that I was drafting is way too similar to @Ulb 's Spiritwalker, so I'm having to start from zero once again.

    The French translation also was updated thanks to @Gwendolyne :)

    I just finished a full IWDEE-HoW-ToTLM run with a party made of the fighter, paladin, cleric, rogue, ranger and druid kits of this mod and it was quite pleasable - to be honest the Undead Redeemer made this game a lot easier (Vale of Shadows, Burial Island, the undeads from Dragon's Eye and Icasaracht's Temple, the Luremaster's castle) just walking through the enemies with Turn Undead and Sanctuary. But, in another hand, playing the whole game without a priest able to ress (and that could not be ressed!) was quite challenging.

    When I'm done with the Sorcerer and the Shaman kits I'll do another run to test the other kits (monk, wizard, bard, sorcerer, shaman). The reason why I'm using IWDEE for my tests are i) it's more combat oriented, ii) lots of undeads, iii) I can test multiples kits at once.

    Hope you guys enjoy playing it as much as I enjoyed!

    Merry Xmas!

    Mirandel
  • GwendolyneGwendolyne Member Posts: 297
    Raduziel said:

    Version 1.6 is up with some changes for the Undead Slayer:

    3) You don't need the IWDEE workaround anymore!

    You should delete the relative lines in the readme file. ;)

  • RaduzielRaduziel Member Posts: 4,716

    Raduziel said:

    Version 1.6 is up with some changes for the Undead Slayer:

    3) You don't need the IWDEE workaround anymore!

    You should delete the relative lines in the readme file. ;)
    Already did it :)

  • GwendolyneGwendolyne Member Posts: 297
    Not in the French readme file!

  • RaduzielRaduziel Member Posts: 4,716

    Not in the French readme file!

    Damn, you're right. I altered the item III and forgot the item IV.

    Fixed it. Thanks for the heads up.

  • RaduzielRaduziel Member Posts: 4,716
    Version 1.7 is up.

    No, it's not the Shaman or Sorcerer kits, but a nice code from @Gwendolyne that now makes the Character Screen shows the "Fallen" title.

    Now you can go through Faerun doing stupid things and killing innocents without fear of having a non-consistent character screen!

    Enjoy :)

  • RVNSRVNS Member Posts: 279
    I am playing through IWD currently with the mod. I noticed that the undead slayer did not install during the bws install and my undead tricker will not allow me to upgrade his set traps skill upon level up. Not a biggie since I can just ee keeper that but thought you might want to know.

  • RaduzielRaduziel Member Posts: 4,716
    edited January 2018
    @RVNS

    Can you please attach your Weidu.log file? What's your OS and which game version?

    1) Couldn't reproduce the issue with the Undead Tricker. Was able to go all the way to 250 Set Traps and had 3 uses at level 12.
















    Sorry about the photos. My Print Screen button is not working at the moment, so I had to improvise.

    2) The Undead Slayer won't install for IWDEE in a version that's behind 2.5 Beta. This kit had a workaround for IWDEE but I removed it when Beamdog launched the patch.

    Thanks for the report, I'll look into it and help you in any way possible.

  • RVNSRVNS Member Posts: 279
    I would be happy to. Please tell me where I can locate this please and I will upload it.

  • RaduzielRaduziel Member Posts: 4,716
    edited January 2018
    @RVNS

    If you want to try the new patch here are the instructions to download the 2.5 Beta.

    The issue you're having with the Trickster is not related to the game version, when I modded it I was using version 1.4. But you'll be able to install the Undead Slayer without any problem.

    On the game root, the same place where you unzipped the IHateUndeadKitPack1.7.zip file, you can find a file called Weidu.log. That's the one I need to take a look.

    Thanks and hope you're enjoying it.

    Post edited by Raduziel on
  • RaduzielRaduziel Member Posts: 4,716
    Ok, I made a mistake and had the wrong 1.7 uploaded. Fixed it.

    The only change is the Undead Slayer: now it has the same spell progression that the generalist mage (as it should be).

    Sorry about that.

  • RaduzielRaduziel Member Posts: 4,716
    Ok, good news: I finally defined what the Shaman and Sorcerer kits will be and have everything pretty much defined and written.

    Bad news: My notebook's keyboard had to be replaced so I'm unable to do the actually coding for now.

    Good news: No one cares :smiley:

  • RaduzielRaduziel Member Posts: 4,716
    More good news: The Shaman kit is 100% ready.

    More bad news: The Sorcerer kit is not showing up at the Character Creation and IDK why. Did a try using AddKit and it is functioning partially: two of its features are not working as intended.

    I'll release v2.0 (final) when I'm able to solve this.

    Gusinda
  • RaduzielRaduziel Member Posts: 4,716
    edited January 2018
    v2.0 is up!

    The French translation is behind this one, but that's because I'm probably driving @Gwendolyne crazy right now.

    What's new?

    1) Renamed most of the kits

    2) Cleaned the code for the Circle Enforcer and gave it a boost

    3) Added two new kits The Dreadful Witch and the Imprisoned Soul

    4) Fixed a bug with the Pallid Mask and gave it a boost too.

    BE AWARE THAT THE DREADFUL WITCH IS A FEMALE-ONLY KIT. I made a timer that will kill any male Dreadful Witch in one minute.

    Post edited by Raduziel on
  • RaduzielRaduziel Member Posts: 4,716
    v2.1 up

    1) Fixed HLAs tables for the Grave Mourner, Circle Enforcer and Spirit Redeemer.

    2) Several fixes for the Circle Enforcer (now he gains immunity to poison, elemental resistance [BG(2)EE only] and immunity to fatigue [IWDEE only]).

  • SolavFSolavF Member Posts: 2
    Hello Raduziel, im playing IWD:EE with your mod and it suits this game amazing. But as a Polish player i feel pain whenever i see English kit/ability names surrounded by Polish language. It breaks immersion. So, i will start doing a Polish translation for your mod. What do you think about it? ATM i finished translation for ranger kit, and tomorrow i will start working at the rest.

    Raduziel
  • RaduzielRaduziel Member Posts: 4,716
    SolavF said:

    Hello Raduziel, im playing IWD:EE with your mod and it suits this game amazing. But as a Polish player i feel pain whenever i see English kit/ability names surrounded by Polish language. It breaks immersion. So, i will start doing a Polish translation for your mod. What do you think about it? ATM i finished translation for ranger kit, and tomorrow i will start working at the rest.

    Be my guest! The more translations, the better!

    I hope one day all the ONU's representatives will talk to each other through my mod!

    SolavF
  • RVNSRVNS Member Posts: 279
    Gotta run a new bg2 team with the new classes to test them out! going to give the mercenary another go over as well. All Raduziel class party.

    Raduziel
  • RaduzielRaduziel Member Posts: 4,716
    v2.2 up.

    - Fixed some typos and other minor grammatical things.

    @Gwendolyne @SolavF nothing that will impact your translation, but just in case:

    Line 621: in -> on

    Line 570: as in the table below -> as shown below

    Thanks!

  • RaduzielRaduziel Member Posts: 4,716
    Version 2.3 is up with custom icons for the custom abilities (like Deceive Undead, Redemption and Soul Sacrifice - and others!).

  • RaduzielRaduziel Member Posts: 4,716
    Version 2.4 is up with better (and cleaner) coding and better cross-mod compatibility (especially with SR).

  • RaduzielRaduziel Member Posts: 4,716
    Version 2.5 is up with the French translation update, kindly provided by @Gwendolyne

  • RaduzielRaduziel Member Posts: 4,716
    Version 2.6 (hopefully the final!) is up with a much better coding.

    As this was my first mod and I learned so much in the past months I had to come back to it and enhance it.

    Enjoy :)

  • RaduzielRaduziel Member Posts: 4,716
    Version 2.7 is up with a fix for the French translation.

Sign In or Register to comment.