Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Crazy long save times

StinaboStinabo Member Posts: 8
I've been noticing longer and longer save times since running recent updates on Win 10. I'm running a 6GB Toshiba with a Intel Processor and have 5.88 GB available, so it's not like the computer is full. I've uninstalled many superfluous programs, but am an amateur so can't tell if the "windows stuff" running in the background (e.g., svchost.exe files, of which there are many) are interfering with this. It is increasingly annoying, and now the save times are up to a minute per try and load times between areas are also super long. Interestingly, it doesn't seem to affect the front-end load of the game itself, just during game play. I thought it might be corrupted, so I uninstalled and reinstalled both enhanced BG1/SOD and BG2 and deleted all former save files, including those in My Documents, but it still isn't helping much. I've also ensured Norton was completely uninstalled as I know that has posed issues with WinDefender. Any ideas on a simple (or even not so simple) fix?

Comments

  • StinaboStinabo Member Posts: 8
    By the way - SOD is insanely slow in the "movement" sequences, i.e., when your character is being marched through Baldur's Gate on the way to confront Caelar, as well. I thought perhaps this was my crappy pre-installed factory grade video card, but is there any way these are related?

  • sarevok57sarevok57 Member Posts: 4,741
    try running the game in compatibility mode, windows 10 has been kind of wonky with some games of late, it runs perfectly on windows 7, so if you can try and run it using windows 7 settings and see if that helps

  • Gate70Gate70 Member, Developer Posts: 3,605
    If that doesn't help could you also zip and attach a sample save (the 0000000nn-savename folder and files within) please so it can be inspected for potential issues within the save.

    Check you've not got any backup / cloud software over your documents folder. e.g. OneDrive
    Plus, if on Steam, whether you have cloudsaves enabled in-game (options, gameplay)

    Thanks

    Gusinda
  • StinaboStinabo Member Posts: 8
    Thanks Gus & Gate! I'll try both. Super annoying. Thought it might be the OpenAI but that wasn't the problem (uninstalled/reinstalled that too). Weird thing is, the initial load time of the game is super fast. The problem is once the game is running, the loads between locations first started, then the Saves, and now even going into a building takes up to a minute to load (or often crashes). Suspect it's probably a driver issue or DirectX (or both) as uninstalling/reinstalling both games didn't help anything (and it's across all games, SOD, BG1 &2) so it has to be related. Will try what you suggest Gus first.

  • StinaboStinabo Member Posts: 8
    @Gusinda here's the dianog for Dx. It says all is ok. Drivers say they're up to date. Will try uninstalling and reinstalling DirectX but suspect this is a Win issue. Ugh! Thanks for all the help!

  • StinaboStinabo Member Posts: 8
    @Gate70 Blocked out OpenDrive as initially that was causing all sorts of problems. I suspect it's still running in the background even though I disabled it so that could be an issue. I also noticed Cortana takes up a bunch of memory, so have it hidden, but nothing has helped. Will try zipping a save.

  • StinaboStinabo Member Posts: 8
    @Gate70 Not on Steam. Suspect I should have started that way - ugh.

  • StinaboStinabo Member Posts: 8
    @sarvevok57 "Amateur" here - how do I run the game in compatability mode?

  • malachi151malachi151 Member Posts: 152
    I have the same problem, but cant' find baldur.lua I installed from GOG.

  • Gate70Gate70 Member, Developer Posts: 3,605
    Hi @malachi151 your lua file should reside in the documents/ folder

    Could you advise which game(s) this is for, and also provide a directx diagnostic summary to help problem determination.
    (Windows/R, type dxdiag, click ok, wait for the green progress bar to comlete, save all information and attach the result here.

    Thanks

  • malachi151malachi151 Member Posts: 152
    I tried this: SetPrivateProfileString('Graphics','Backend','1') and that didn't work.

    I'm on Windows 10. DirectX version 12.

  • GusindaGusinda Member Posts: 1,565
    @malachi151, Although you have DirectX 12 installed, I would also recommend installing DirectX 9.0c . The two can live together in the system. Also (just to be sure), make sure you have the game closed when editing baldur.lua...

    Your video drivers are all good and up to date but your sound card driver is dated 2011. Have a look here for the latest (the 76.9 MB is 32 Bit, the 131.3 MB is 64 Bit). The outdated sound card driver 'shouldn't' cause the prob but it is always good to make sure. My thinking says the DirectX 9.0c...

    To confirm the change to DirectX, when you change the setting to 1 and start the game, close the game again and have a look at baldur.lua. It should have this line:

    SetPrivateProfileString('Graphics','version','DirectX 9.0c')


    Good Luck
    Gus

    Grond0JuliusBorisov
  • malachi151malachi151 Member Posts: 152
    edited October 2017
    Hmm still no improvement. BTW, this all started about 2 or 3 months ago. Prior to that this wasn't an issue. It takes about a minute each time I go through a door into a new area or when I travel.

    Are there any settings I can change, like turning off certain effects or something?

    Post edited by malachi151 on
  • GusindaGusinda Member Posts: 1,565
    @malachi151, that was about the time Windows 10 had a major update... You can check by going into Settings/Update/Update History and you would find the update to Windows 10 1703. Mine occurred in Jun 17. Underlying drivers could have become corrupt during the update.

    Based on that, I believe that it is a system problem and not the game (unless you have some mods that don't play together nicely). You have already done the sound card and installed DirectX 9.0c. For the steps below, make sure you reinstall DirectX 9 after the video card drivers...


    This is a similar problem to one that was fixed earlier so I will repeat what we did there (it worked):

    1. Rename ..\My Documents\Baldur's Gate - Enhanced Edition to ..\My Documents\Baldur's Gate - Enhanced Edition.old if you want to keep all your old settings, portraits and saved games etc...
    2. Uninstall BGEE (or rename until testing is complete).
    - This should get the old BGEE out of the way. Now, in with the new.

    3. Download new video drivers from the Microsoft Windows Catalog. You should see the drivers listed as lines 2 & 3. Look on the version column for 9.17.10.4459. I don't have an Intel HD 3000 (and therefore couldn't test) but downloaded them and found that the 99.6 MB is 64 Bit and 59.2 MB package is the 32 Bit driver. Unpack the .cab file (If you aren't aware how to install from a .cab file, then have a look at this post or post a question here ) , rename the folder to indicate what the driver is etc.
    4. Install the Video card drivers. If they refuse to install due to already being there, uninstall the current set of drivers and install the new package.
    4. Reinstall DirectX 9.0c
    5. Download and Install new version of BGEE (keep vanilla) and run to create baldur.lua. Exit BGEE.
    6. Open baldur.lua and edit to read:
    SetPrivateProfileString('Graphics','Backend','1')
    7. Start BGEE and check if baldur.lua was updated to change graphics engine to DirectX
    SetPrivateProfileString('Graphics','version','DirectX 9.0c')
    8. Start new game and test. If all goes well, then when installing your mods, install one at a time and test again (just to see if it was one of the mods that was a prob). [If you renamed your BGEE install, you could also try and rename everything just to see if your old game works well].
    9. If all is still going well on the new install, try loading one of your old saved games that was known to have the problem.

    Another thought is that the later versions of GOG BGEE have Cloud Saves. If you are not connected to the Internet then this may also present some slow saves but shouldn't impact on moving between screens. You can go into BGEE settings and turn off the cloud save for testing purposes (default is off).

    Hope this helps
    Gus

    Grond0JuliusBorisovAerakar
  • malachi151malachi151 Member Posts: 152
    I still haven't gotten through all this, but I'm working on it. I'll let you know if it works eventually.

    JuliusBorisovGusinda
  • malachi151malachi151 Member Posts: 152
    edited December 2017
    I found this comment which seems to apply to me: https://steamcommunity.com/app/228280/discussions/0/1457328392102700539/

    "i have solved it. it was depending on the gui in ingame settings using directx is workingfine now"

    When I check Options > Graphics it says I'm using OpenGL, but I don't know how to change it to use DirectX. How do I change this setting?

  • Gate70Gate70 Member, Developer Posts: 3,605
    The information is provided above, editing the baldur.lua file to have a backend value of 1 should work.
    As should going into options -> graphics and enabling the alternate renderer then closing and restarting the game.

    You didn't confirm which game this is for, if for IWD:EE the current retail version does not have this option. Also which version of the game it is (e.g. 1.3, 1.4, 2,3).

    I was going to say you could try the public beta for whichever game it is to see if that helps, but that is only available for Beamdog or Steam installs and not GoG.

    Other potential causes could be lack of hard disk space (try and free some up if so), fragmented disk (search the Windows start bar for defragment), disruptive security/antivirus software (temporarily disable to check, or add the game save folder to a list of exclusions).

    GusindaJuliusBorisov
  • malachi151malachi151 Member Posts: 152
    Yep, that fixed it. The graphics are slightly lower quality, but it's barely noticeable.

    JuliusBorisov
  • who_is_danielwho_is_daniel Member, Mobile Tester Posts: 68
    Gusinda said:



    In the meanwhile, you could probably check to see if your drivers are all up to date and reinstall DirectX 9.0c. Change the game engine to reflect directx by modifing the following line in baldur.lua

    SetPrivateProfileString('Graphics','Backend','0')
    to
    SetPrivateProfileString('Graphics','Backend','1')
    (or vica versa)


    Solved my problem perfectly. Thank you

    GusindaJuliusBorisov
  • Thedanman97Thedanman97 Member Posts: 1
    @Gusinda haven't been a part of this conversation but your comments were helpful in trying to sort out my own game which was experiencing the same problems. The steps outlined fix the save time issue, but it causes the frame rate to drop like crazy which is overall worse than the crazy save times

  • GusindaGusinda Member Posts: 1,565
    Hi @Thedanman97, I am guessing here that you are running on a Windows platform. Give this fix a go instead which will look at the opengl driver itself.

    Gus

    JuliusBorisov
Sign In or Register to comment.