Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Issues correctly registering clicks?

Is anyone else experiencing issues with the 2.5.10 betas correctly registering clicks?

1. I often hear the BG "clicking" sound when touching my trackpad to move the cursor.
2. When I do attempt to click on the trackpad, the cursor does the "clicking" animation, but the click will not register or will depress a button not underneath the current cursor location.
3. Getting BGEE to register the click correctly sometimes requires a "hard click" (I am using a trackpad with Force Touch). Even then it does not always register.

Everything works under v2.3. I can adjust the sliders, select options, and click the buttons.

Under v2.5, clicking on the sliders with a normal click does not adjust the slider. It often results in the Assign Keys button depressing (see image below). Only if I use a "hard click" does the slider work. For the radio buttons, pressing them with a normal click resulted in a separate UI element animating (e.g., the Feedback button). I was able to select the Gore option once with a "hard click", but I could not replicate. Even "hard clicks" usually resulted in another UI element animating.



I've submitted a bug report for it (there are videos there that illustrate the issue): https://support.baldursgate.com/issues/34153

Comments

  • pirey4pirey4 Member Posts: 3
    I am having the same problem with the trackpad on my 2016 MacBook Pro (13,1) on MacOS 10.13.2. I ran into this problem when doing some tests for another issue I found in the 2.5.10 beta (Bug #34212) and was referred to your bug by Beamdog. It took me a while to realize it but the game interprets touches of the track as a click in the beta version of the game but requires a hard press to register a click in the production version of the game and outside the game. This is very confusing when trying to use the menus. If you don't lift your finger, you can navigate the menus but this isn't very convenient. I have "Tap to Click" turned off and "Force click and haptic feedback turned on". I tried various options of trackpad settings but none seemed to fix the problem. I hooked up an external USB mouse and it works as expected. Unfortunately, the trackpad does not in the beta.

  • nerdcore9nerdcore9 Member Posts: 7
    Reviving this thread because I'm having same issue with trackpad on an 2011 macbook pro since updating to 2.5 in IWD. It's unplayable. Any fixes out there, besides using a mouse?

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 19,811
    edited May 2018
    This issue is currently being looked at, thanks for the feedback and sorry for the experience!

    Post edited by JuliusBorisov on
    nerdcore9
  • nerdcore9nerdcore9 Member Posts: 7
    Thanks for the quick reply. The Redmine is #37314.

    JuliusBorisov
Sign In or Register to comment.