Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

2.5 beta Polish language bugs

In the 2.5 beta, I've found an incorrect translation string in Polish language.

In BG1 and IWD, on the party creation screen (single player only, multiplayer is fine), the Play button has a translation error. Pictures provided, please do excuse my epic MS Paint skills.







Instead of "Odtwarzaj" (meaning "play" in context of playing a music track or video file), it should be "Graj" (meaning "play" in context of playing a game). It used to be correct in IWD 1.4, picture provided (in that old version, it also said "Wstecz" for "Back", whereas in 2.5 it's "Powrót" for "Return", but that word is just as good and doesn't need to be changed).




For some reason, in BG2, Polish language wasn't available at all (and in general the list of foreign languages was much shorter than in BG1, for example), so I can't test it there, but I'm pretty sure it wouldn't be any different. My understanding is that Polish will be available once the game is out of beta.

The same issue might be present in Siege, but as I don't have that expansion, I can't test it.

I can see how someone would make that mistake, as English uses the same word "play" for playing music, videos or games. However, Polish uses a separete word for these two.

That's not to say the whole string needs to be trashed. I'm sure there are other instances where "Odtwarzaj" would be appropriate (possibly ingame cinematic viewer, if there is one).

This is a single bug I've found so far, but you guys do feel free to hijack the thread and report other Polish translation issues.

O_Bruce

Comments

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 19,705
    Tagging @Cahir so that any translation errors could be fixed in the Translation tool.

  • CahirCahir Member, Moderator, Translator (NDA) Posts: 2,097
    @Sardoc, thank you for report. I'm investigating this issue, it will be corrected before patch goes live.

    For the future, please report all bugs and issues with Polish localization in this thread.

    JuliusBorisov
  • CahirCahir Member, Moderator, Translator (NDA) Posts: 2,097
    @Sardoc I have identified the problem with your request. Actually there are two different issues with this string. I have changed the string from "ODTWARZAJ" to "GRAJ", so it should display correctly on Character Generation screen after the patch goes live.

    Second issue was reported here. The same string is also used for Customized Sounds screen (so in this case it will also be "GRAJ", which shouldn't be the case naturally).

    Anyway, your case (Character creation screen) is fixed, but until the Redmine bug is fixed, the issue is not completely resolved.

    JuliusBorisov
  • SardocSardoc Member Posts: 14
    Ok thanks.

    Will this change affect character import screen too? Only just noticed it has the same bug ("odtwarzaj").

  • CahirCahir Member, Moderator, Translator (NDA) Posts: 2,097
    @Sardoc, it should affect import screen too, yes. The only bug you will see until the Redmine ticket is resolved, is to see "GRAJ" (instead of "ODTWARZAJ") in Customized Sounds screen (because game uses incorrect string there).

    JuliusBorisov
  • lefreutlefreut Member Posts: 1,462
    Cahir said:

    @Sardoc I have identified the problem with your request. Actually there are two different issues with this string. I have changed the string from "ODTWARZAJ" to "GRAJ", so it should display correctly on Character Generation screen after the patch goes live.

    Second issue was reported here. The same string is also used for Customized Sounds screen (so in this case it will also be "GRAJ", which shouldn't be the case naturally).

    Anyway, your case (Character creation screen) is fixed, but until the Redmine bug is fixed, the issue is not completely resolved.

    I think the Character Generation UI should use PLAY_GAME_BUTTON instead of PLAY_IMPORT_BUTTON. This way only the Customized Sounds screen will use PLAY_IMPORT_BUTTON which can be changed back to the new value.

  • CahirCahir Member, Moderator, Translator (NDA) Posts: 2,097
    lefreut said:

    Cahir said:

    @Sardoc I have identified the problem with your request. Actually there are two different issues with this string. I have changed the string from "ODTWARZAJ" to "GRAJ", so it should display correctly on Character Generation screen after the patch goes live.

    Second issue was reported here. The same string is also used for Customized Sounds screen (so in this case it will also be "GRAJ", which shouldn't be the case naturally).

    Anyway, your case (Character creation screen) is fixed, but until the Redmine bug is fixed, the issue is not completely resolved.

    I think the Character Generation UI should use PLAY_GAME_BUTTON instead of PLAY_IMPORT_BUTTON. This way only the Customized Sounds screen will use PLAY_IMPORT_BUTTON which can be changed back to the new value.
    @lefreut as explained by @Hurricane the usage of "PLAY" strings is currently as follows:
    String      Label                   Screen it appears on
    --------------------------------------------------------
    474         PLAY_GAME_BUTTON        Character Generation -> Step 7: Appearance -> Sound Selection
    475         PLAY_IMPORT_BUTTON      Create Party
    475         PLAY_IMPORT_BUTTON      Character Generation -> Select a pregenerated character (only in IWD:EE)
    475         PLAY_IMPORT_BUTTON      Character Record -> Customize -> Sounds
    476         PLAY_MOVIE_BUTTON       Options -> Movies
    In Polish these strings were translated accordingly:
    474 - "ODTWARZAJ"
    475 - "GRAJ"
    476 - "ODTWARZAJ"

    So, as I see it the only issue is with Character Record -> Customize -> Sounds case, where 474 or 476 should be used instead of 475.

    JuliusBorisov
  • lefreutlefreut Member Posts: 1,462
    edited December 2017
    Cahir said:

    @lefreut as explained by @Hurricane the usage of "PLAY" strings is currently as follows:

    String      Label                   Screen it appears on
    --------------------------------------------------------
    474         PLAY_GAME_BUTTON        Character Generation -> Step 7: Appearance -> Sound Selection
    475         PLAY_IMPORT_BUTTON      Create Party
    475         PLAY_IMPORT_BUTTON      Character Generation -> Select a pregenerated character (only in IWD:EE)
    475         PLAY_IMPORT_BUTTON      Character Record -> Customize -> Sounds
    476         PLAY_MOVIE_BUTTON       Options -> Movies
    In Polish these strings were translated accordingly:
    474 - "ODTWARZAJ"
    475 - "GRAJ"
    476 - "ODTWARZAJ"

    So, as I see it the only issue is with Character Record -> Customize -> Sounds case, where 474 or 476 should be used instead of 475.
    Yes 'Character Generation -> Step 7: Appearance -> Sound Selection' and 'Character Record -> Customize -> Sounds' should use the same string. My comment was based on the French 2.5 beta where it's the string for PLAY_IMPORT_BUTTON that was changed. If you choose to change 'Character Record -> Customize -> Sounds' from 475 to 474 (476 is not a good idea as it as a different translation in French), you will need to swap 474 and 475 in French.

    Post edited by lefreut on
    CahirJuliusBorisov
Sign In or Register to comment.