Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

FPS Issues (minor stuttering and sub-optional frames)

CalvinMCalvinM Member, Mobile Tester Posts: 7
I've been getting sub-60 frames (in the region of around 40-60 FPS most of the time, especially if I'm outside) plus minor stuttering when I move my character or camera. My specs seem fine and, given the age of this game, should have no issue running it at a buttery 60 FPS.

- I've disabled Ambient Occlusion which has helped a bit but I'm still not getting a stable 60 FPS
- Disabled Shiny Water
- Checked my CPU/GPU usage which are both low (20%)
- I've set the priority in Windows to high
- I've changed the affinity so NWN only uses 1 core

I've heard there are some issues with 3D sound settings but it doesn't seem like you can change them much in the Enhanced Edition.

Has anyone had this issue/knows anything I could try?

Specs:

CPU: Intel Xeon E3-1231 @ 3.40 GHz
GPU: AMD Radeon R9 290 PCS+ 4gb
Ram: 16 GB

Comments

  • sarevok57sarevok57 Member Posts: 5,485
    did you try running in compatibility mode? i have no problems with windows 7, so if you are running a higher OS try going down to windows7 if you can

  • TressetTresset Member, Moderator Posts: 8,148
    I am getting similar issues I think. I dont know my exact FPS, but it seems slower than the original and movements can get jerky (fast to slow to fast to slow in rapid succession) sometimes. I play with ambient occlusion turned off because if I turn it on things REALLY slow down. A few patches back (I forget which version it was exactly) the shiny water would cause a similar massive slowdown when it was visible on screen, but that seems to work much better now and I always have it on. @JuliusBorisov could you tell me if any additional details I could provide would help?

  • tfoxtfox Member Posts: 87
    I've a similar issue on my second PC, I stopped opening NWN:EE on it because while it can handle 1.69 at 150 + fps on the same area, in EE it struggles to get 55-73 FPS (averages somewhere around 61). The FPS doesn't seem effected by any graphics settings, even dropping everything to the lowest and resolution from 1920x1080 to 800x600 sees no meaning full FPS gains. That PC has a R9 290x in it, the game originally ran at 150 + FPS on this particular PC when I first bought EE back in like December.

    The game works perfectly on my second PC so I've not been all that concerned by it myself, I generally work from the PC with the 290x in it and play on my PC with a 1080 in it. I'd be curious if it's a Radeon issue, can't remember if it started happening after a NWN:EE update or a driver update though, I might try installing some older drivers from like May through to November last year to see how it runs when I can be bothered.

  • CalvinMCalvinM Member, Mobile Tester Posts: 7
    I've tried compatibility mode for Windows XP 2/3 and Windows 7 and it still hasn't improved. There are some area (e.g. inside a small building) that my FPS is buttery smooth, but in places such as the City Core of Neverwinter or the port in the beginning of Chapter two that is around 25~ FPS.

    Anyone else got any other suggestions? The NWN Diamond on GOG seems to run much smoother than the head-start steam version. I've continued to tinker with the graphical settings but even putting everything on low doesn't improve the FPS.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 21,459
    Did you try to turn off Ambient Occlusion?

  • CalvinMCalvinM Member, Mobile Tester Posts: 7
    Yes, I've disabled all the new graphical settings (ambient occlusion, vibrancy, etc), and turned everything else down and it still doesn't restore it to buttery 60 FPS, honestly doesn't even increase the FPS much at all. It just doesn't make any sense.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 21,459
    edited March 2018
    It's a long shot, cosidering you say you have turned everything down, but: you mention outdoor areas as really bad. Skyboxes are still giving known issues. If those are present in the area, and enabled, they could cause this.

    Also, from the Discord: a good idea may be to lower the anti-aliasing, it seems to be one of the biggest hits to framerate.

    In the meantime, we're always looking into optimizations. It just depends on how quickly we can get them in!

    sarevok57
  • CalvinMCalvinM Member, Mobile Tester Posts: 7
    Tried disabling both anti-aliasing and sky boxes yet no avail. However, I've noticed that the game runs quite a bit better through the Beamdog Client than through Steam. Has anyone else reported this issue? Tried reinstalling and it ran ok for a minute and then it started to get low FPS again.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 21,459
    CalvinM said:

    Tried disabling both anti-aliasing and sky boxes yet no avail. However, I've noticed that the game runs quite a bit better through the Beamdog Client than through Steam. Has anyone else reported this issue? Tried reinstalling and it ran ok for a minute and then it started to get low FPS again.

    Can you disable Steam overlay?

  • CalvinMCalvinM Member, Mobile Tester Posts: 7
    edited March 2018

    CalvinM said:

    Tried disabling both anti-aliasing and sky boxes yet no avail. However, I've noticed that the game runs quite a bit better through the Beamdog Client than through Steam. Has anyone else reported this issue? Tried reinstalling and it ran ok for a minute and then it started to get low FPS again.

    Can you disable Steam overlay?
    Yeah, I've already disabled the "steam overlay while in-game" in the game settings. I've no clue what else it could be. I've reinstalled multiple times and I have no other Steam game performances issues -- the Beamdog client game is definitely runs smoother (well, much higher FPS outside but still a little jerky when loading sometimes).

    Edit: I have noticed that NWN:EE through Steam has "patch 1.72" on the home-screen (which I assume is the community patch) whereas the Beamdog client does not have. Could this be what is causing me an issue? If so, how do I remove the patch from the Steam version? I'm reinstalled NWN multiple times since installing the community patch ages ago, I can't find it anywhere in the relevant directories.

    Post edited by CalvinM on
  • CalvinMCalvinM Member, Mobile Tester Posts: 7
    Update: So after reinstalling multiple times and comparing Steam/Beamdog Client I, dare I say it out of embarassment, only just realised I had a couple of workshop items installed (mainly the NWN face-lift) which appears to have been giving me the FPS issues. Now that I've unsubscribed to it my issues seem mostly resolved. I still feel like I should be getting higher FPS but it is playable nonetheless.

    I am an idiot.

    sarevok57JuliusBorisov
Sign In or Register to comment.