Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Lag during saves and between maps

Hi,

I'm experiencing major delays and lags every time I quicksave or when a new map is being loaded. Those lags can take of up to 30 seconds. All my graphic drivers and DirectX are up to date, and other Infinity games run generally smoothly.

I tried playing with different compatibility settings, DirectX versions, and other stuff, but nothing helps.

Any ideas?

«1

Comments

  • GusindaGusinda Member Posts: 1,669
    @gaaaaaaaaaaaaaaar, welcome to the forum.

    A couple of Qs to get started:
    What game are you playing (and version)?
    What operating system are you using?
    Can you describe your system a little bit?
    Does that lag also occur when you save normally as opposed to quicksave?

    Assuming it is Windows, would you be able to run DXDiag (Start/Run/DXDIAG), save the results an upload the text file.
    While we are uploading, could you also upload a copy of baldur.lua renamed to baldur.txt, and a copy of a Zipped version of saved game.

    Thanks
    Gus

    JuliusBorisovlolienRaduziel
  • gaaaaaaaaaaaaaaargaaaaaaaaaaaaaaar Member Posts: 9
    Hi Gus,

    -Icewind Dale Enhanced Edition, v. 1.4.0.

    -Microsoft Windows 10 Home
    -10.0.16299 Build 16299

    -Processor Intel(R) Core(TM) i3-3227U CPU @ 1.90GHz, 1901 Mhz, 2 Core(s), 4 Logical Processor(s)

    -Yes, lag occurs on normal save as well.

    I actually don't have a saved game at the moment since I just had a fresh install from scratch.

    Thanks

  • GusindaGusinda Member Posts: 1,669
    @gaaaaaaaaaaaaaaar, could you confirm that the game is IWDEE 1.4.0. The baldur.txt suggests it is baldur.lua & therefore likely to be the latest IWDEE beta. If it is 1.4.0, then there should be a baldur.ini in the ...\Documents\Icewind Dale - Enhanced Edition folder. Could you upload that?

    If it is the latest beta (2.5.x - should be noted on the opening screen), could you try and download DirectX 9.0c and install. Both DX9 and DX12 can live together on the same system, so you wont have any concern about conflict. Your backend engine is already set to run DirectX but it needs v9.0c, so the engine seems to be still running OpenGL. I don't have the beta version myself and can't confirm that, but v2.3.x of BGEE and BG2EE have a similar prob of lag on on some systems using OpenGL.

    Your sound card drivers are slightly out of date (couple of months) but I am thinkling that this is unlikely to be the problem. Just something to keep in the back of the mind if all else fails.

    See what happens when you install DirectX 9.0c, which I would do regardless of the version of the game. It is always one of the first driver packs I install after rebuilding a system.

    Q. Were you able to run the game previously without problems? I know Windows 10 has had an update recently (3 days ago for me), and some updates require a reinstall of some video drivers. Another thought to keep in mind.

    Gus

    JuliusBorisovlolien
  • gaaaaaaaaaaaaaaargaaaaaaaaaaaaaaar Member Posts: 9
    edited April 2018
    Yes, v1.4.0. Says so right in the game.

    I installed the DirectX 9.0c driver but it didn't do much.

    I've first ran the game a few days ago and it was already lagging.

    Here's the .ini file.

  • GusindaGusinda Member Posts: 1,669
    edited April 2018
    @gaaaaaaaaaaaaaaar, thanks, that one is the ini. As another test, would you be able to rub the game in a Window (as opposed to Full Screen) and test the game then? Coud you also try turning off the Scaled Interface in your Graphics Options as a seperate test?

    Any chance you have a saved game now you could post?

    I have uploaded my baldur.ini for you to have another test with. You have a line in yours that may cut your ini short or does absolutely nothing at all. Better to take it out. The only thing this ini doesn't do is to remap the assigned keys or auto pause stuff, but wait until it the lagging is gone before reassigning. It is running the game with the scaled UI turned off and in full screen. Debug mode is set.

    If you want to, you could also rename you ini to something else and restart the game. This will rewrite your ini from scratch with no additions.

    The line in your current ini that wont do much are:
    'Program Options', 'Debug', '1',
    ')', '', '',


    Gus

    Edit: Where ddi you buy the game? Does it support cloud saves and if so, could you turn that off and try? Another thought along the cloud save is something like Google / Onedrive etc. Are you running those and do they synch your documents folder?

    JuliusBorisovlolien
  • gaaaaaaaaaaaaaaargaaaaaaaaaaaaaaar Member Posts: 9
    No difference between fullscreen and windowed mode, as far as I can tell. The edited .ini doesn't change much either unfortunately.

    From playing quite extensively now I noticed that the delay is determined by the size of the map. Smaller maps save much faster (the catacombs in Dorne's Deep which are a tiny map save basically at normal speed), while larger maps take forever (over 30 seconds). The interstitial loading time doesn't change, though.

  • GusindaGusinda Member Posts: 1,669
    Thanks @gaaaaaaaaaaaaaaar, will have a look at the saved game file and try to repeat your problem. Did you have some sort of cloud synch going on with your system (related or unrelated to the game saves)?

    Gus

    JuliusBorisovlolien
  • gaaaaaaaaaaaaaaargaaaaaaaaaaaaaaar Member Posts: 9
    Dropbox, completely unrelated.

    Thanks

  • GusindaGusinda Member Posts: 1,669
    @gaaaaaaaaaaaaaaar, has a bash at trying to get the same problem (although I don't have dropbox) but had no success (eerrr, should that be failure). There have been problems previously in the forum where a similar lag has occurred. Some were related to corrupt saved games and others related to synching... Could you try somethings.

    The game that you sent forward seems to be good, so could you remove all other saved games and just run with this one?

    The other is to stop your dropbox from synching, restart the PC, and try the game?

    Gus

    JuliusBorisovlolien
  • Llama741Llama741 Member Posts: 2
    I'm having the same experience in BGEE and BG2EE. My Windows 10 updated last night, and now things are slow. I downloaded the Direct X 9.0c and turned off Dropbox, but still have the slow quicksaves and time between maps that wasn't there 2 weeks ago when I played. I'm running Windows 10-64 bit With an Intel Core i5-3230M CPU @ 2.60GHz, 16 GB RAM, Intel Graphics HD 4000. Any thoughts?

  • GusindaGusinda Member Posts: 1,669
    Hi @Llama741, and welcome to the forum.

    I am guessing that you are playing the latest version (not the beta or v1.3.x) which would be v2.3.67.3.

    With the install of DirectX 9.0c, you also need to change the way the game engine uses it. Open your game, select options, graphics and make sure Alternate Render is highlighted.

    If this doesn't work, would you be able to post your baldur.lua (make a copy and rename to baldur.txt, upload by selecting the icon that looks like a page with the corner turned in the toolbar above). If your not sure where the file is, have a look in your documents folder under ..\Baldur's Gate - Enhanced Edition.

    Another thought if the above didn't work, you might try and update/reinstall the drivers for your video card. Windows Update may have written over them.

    Whilst you are uploading, it makes good sense to also provide a summary of you system. To do this, from a Run Command, run 'dxdiag', save the results and post the save (this will provide details as to how old your system drivers are etc).


    Gus

    ronaldoJuliusBorisovlolien
  • Llama741Llama741 Member Posts: 2
    That seemed to have worked by using the Alternate Render. Now the lag is ~3 seconds vs. 28. Thanks so much for your help. I haven't updated the video card drivers yet, I'll try that next.

    lolien
  • GusindaGusinda Member Posts: 1,669
    edited May 2018
    @Llama741, I take it that the baldur.lua uploaded is after you made the change to Alternate Render. If so, with the game closed, can you open your baldur.lua with Notepad and find the line:
    SetPrivateProfileString('Graphics','Backend','0')

    and change it to:
    SetPrivateProfileString('Graphics','Backend','1')

    When you save, make sure it doesn't add .txt to the filename...

    This will allow the game to properly use DirectX 9.0c.

    Your video drivers appear to be the latest (although if the above doesn't fix the prob, I would still reinstall just in case the Windows Update did something).


    Gus

    Edit: Forgot to mention your Audio. You may need to update your audio drivers. They are a couple of years out of date. Have a look here for the latest.

    JuliusBorisovlolien
  • ClubbothClubboth Member Posts: 60
    "By the Gods! A pearl to You!", Gusinda.

    The "SetPrivateProfileString('Graphics','Backend','1')" did the trick for me. I have no idea, what divine magic is going on here, but after the new Windows 10 update saving EE-games lasts for more than 40 seconds on my system. So I made my way through your troubleshooting and with the DirectX 9.0c renderer saving is like it was before that update.

    Thank You so much, Sire.

    Gusinda
  • gaaaaaaaaaaaaaaargaaaaaaaaaaaaaaar Member Posts: 9
    Just a quick update: I've tried changing to an alternate renderer, which does solve the lag issue, but makes the entire game run a bit slower (like 20-30% slower), which is also quite annoying. I've updated DirectX and all that, but no cigar.

    So all in all, I'm stuck between a rock and a hard place!

  • RaduzielRaduziel Member Posts: 4,716
    @Gusinda First I wanna thank you for this quick fix.

    As @gaaaaaaaaaaaaaaar my game now runs a little bit slower.

    Any new ideas?

    Thanks!

  • GusindaGusinda Member Posts: 1,669
    @Clubboth, glad this worked for you. Enjoy.

    @gaaaaaaaaaaaaaaar, unfortunately updating DirectX doesn't work as there were some functions removed when MS went to version 10. Is this still for the 1.4.0 version of IWDEE? If so, you could update to 2.5 which by now should be out for all sellers, at least for Windows (I updated mine the other day from GOG). Did you end up stopping Dropbox as part of fault finding?

    @Raduziel, which game (and version) are we talking about. Could you run dxdiag from command prompt or from WIN-R, and upload the results? Also, can you upload a copy of your baldur.lua (renamed to baldur.txt) to the thread as well? From when did you notice the problem?

    My immediate thoughts for both is the video driver. Windows 10 had a major update over the past couple of weeks and I get the feeling they smashed some drivers. I had to reinstall my video drivers due to not playing with some games (althoguh BG & IWD was working well). I also had to reinstall a NIC driver... If you reinstall you video card driver, then do a reinstall of DirectX , then ave another bash at the game and see if it improves any.

    Best of luck
    Gus

  • RaduzielRaduziel Member Posts: 4,716
    edited May 2018
    @Gusinda

    IWDEE, v2.5.16.3 (the newest release).

    Noticed it yesterday, when I took the dust off IWDEE to test a kit I was developing.

    I've downloaded the DirectX 9.0c from the link you provided and made the changes in the Lua file (actually I altered it in-game). Today I reinstalled IWDEE, so IDK if the changes remain.

    Again, thank you.

  • gaaaaaaaaaaaaaaargaaaaaaaaaaaaaaar Member Posts: 9
    Hi,

    Forgot to mention that the new problem is with BG2EE, latest version, installed via Steam.
    I actually gave up on IWD some time ago due to this issue.

  • GusindaGusinda Member Posts: 1,669
    edited June 2018
    @Raduziel,You .lua looks good and has the DirectX component working. Your video driver seems up to date but your audio driver is out of date. You can grab an update here. There are in cabinet files which can be open using WinRAR. Just unpack and update driver from Device Manger. The 6.0.1.8061 version is small but it is only the driver and not the rest, so should be good to use (and is 64 bit).

    @gaaaaaaaaaaaaaaar, would you be able to post your baldur.lua? I am guessing that the dxdiag.txt above still holds true?

    For both, are you running any mods at all. If so, could you upload your WeiDU.log and I will try to get the problem to occur on my system. Could I also grab a saved file?

    One thing I forgot to ask. What is actually slow. Is it only the walking? When you cast a spell, is the animation also slow? What about in battle or moving the screen around? Have you tried to start a new game with the changes made?

    If it is only the walking, try playing around with your zoom. I have found that when I am zoomed out, the movement is slow (it still takes the same amount of time to get from A to B, but the toon has to be slow due to a (what would seem to us as) shorter distance.

    Thanks
    Gus

  • RaduzielRaduziel Member Posts: 4,716
    edited June 2018
    @Gusinda Again, thank you. I wasn't able to update any sound driver because Windows kept telling me that the newest driver is installed already.

    My IWDEE is clean at the moment. The spellcasting seems to be fine, only the walking speed was affected apparently.

    I'm attaching the save you required.

    Thanks!

    Edit: Windows is telling me that an update is pendent. I'm doing it ATM and will let you know if it presents any impact on the game.

  • RaduzielRaduziel Member Posts: 4,716
    edited June 2018
    @Gusinda Apparentely the new update made everything worst. From the moment I open IWDEE it runs so slowly that I can't even click on Resume Game.

  • GusindaGusinda Member Posts: 1,669
    edited June 2018
    @Raduziel, For the new update, make sure you restart the machine (even after it has restarted itself as part of the install). You may also need to reinstall some drivers. As I mentioned above, I have to reinstall Video and network card drivers because they were possibly corrupted during the update.

    I used your save and baldur.lua and was getting what seemed to be a slowness in walking. I played around with a couple of options and want to see what happens when you try them on your beast.

    Seperately try these:
    - Disable Zoom lock and zoom in half a mouse wheel.
    - Disable Dither Always
    - Disable Alternate Render with Dither Off

    Let me know how you go.

    Gus

    lolien
  • RaduzielRaduziel Member Posts: 4,716
    @Gusinda

    - Alternate Render on. Saved and quit.

    - Opened the game again;

    - Disable Zoom Lock and altered the zoom as instructed;

    - Disabled Dither option

    - Disabled Alternate Render

    Results: moving normally, saving slowly again.

  • GusindaGusinda Member Posts: 1,669
    @Raduziel, sorry, what I meant was to test after each change.

    Gus

  • RaduzielRaduziel Member Posts: 4,716
    @Gusinda

    With Alternate Render On:

    - Disable Zoom Lock: still moving slowly.

    - Disable Dither Always: still moving slowly.

    Quick saving normally on both.

    With Alternate Render Off:

    - Disable Zoom Lock: moving normally.

    - Disable Dither Always: moving normally.

    Did I get it right this time?

    Thanks!

  • gaaaaaaaaaaaaaaargaaaaaaaaaaaaaaar Member Posts: 9
    Everything is slow, movement, actions, cutscenes, videos, the entire program.

    Here are the .lua, WedDU.log, and a recent saved game.

    Thanks

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 20,507
    To attach a save, you need to zip the whole folder with the appopriate save (including portraits and .gam files).

    I see a lot of mods in your WeiDU.

    Copy and paste the whole game folder to another place. In that second copy - uninstall all the mods.

    In the game Options (Graphics), disable Sprite outlines and Highligh Selected Sprite. Uncheck the Nearest Neighbour Scaling method.

    In the lua file (make sure your game is not open) find and change the following lines:

    'Game Options', 'Weather', '0',
    'Game Options', 'Area Effects Density', '10' ,
    'Program Options', 'Translucent Shadows', '0',
    'Program Options', 'Sprite Mirror', '1',

    lolien
  • gaaaaaaaaaaaaaaargaaaaaaaaaaaaaaar Member Posts: 9
    It can't be the mods, since the problem occurs in vanilla as well (and even in IWD:EE)

    I tried playing with the config as you suggested, but it does nothing.

    The problem is probably due to some basic incompatibility between the Infinity Engine and the video driver.

  • GusindaGusinda Member Posts: 1,669
    @gaaaaaaaaaaaaaaar, I shall have a look at the game today.

    @Raduziel, @gaaaaaaaaaaaaaaar, it appears that you both have the same GPU and driver set. I wonder what would happen if we downgrade the drivers to a previous version. I think that I have a notebook that has this GPU so I could try. If you want to have a bash yourselves, then have a look here for a version.

    Gus

    lolien
Sign In or Register to comment.