Skip to content

Odd descriptions and seemingly random joining levels

ElysaeElysae Member Posts: 5
My most recent mod setup of BG2EE has a couple of weird issues. I have no idea if these are related at all, but in case they are, I'm posting them together. I'll provide a Weidu.log at the bottom.

- Some spells have the wrong descriptions (i.e. priest's haste seems to Mazzy's bio or at least part if it)
- On the class description screen in game sorcerers show the monk's text instead of their own
- Xan's class description shows him as a spelfilcher, but he progresses and function as the bladesinger he' s supposed to be. (bladesinger seems to failed to install, so this one's solved)
- Straight out of Chateau Irenicus mod NPC join at ridiculous levels (Kelsey and Adrian at 21, Xan at Coran at either 13/13 or 16/16) Bioware NPC seem fine.

So far, none of these seem to have any real effect on gameplay, but I'd still like to figure out where I'm going wrong. I'm on Linux, so no BWS. I did use it to select and download mods though. I also tried to check for incompatibilities with BWS and while it found some, I couldn't really tell what's what because the color coding doesn't work.

Anyway, any insight on what's at fault here would be greatly appreciated.

Oh, and in case it matters:
Steam version latest beta (Windows through Wine because I need Windows Steam for other games and don't want separate instances) installed on an NTFS formatted external HDD.


  • GusindaGusinda Member Posts: 1,818
    @Elysae, I am not sure whether this is related to your problems but... I found when installing additional kits, having more than available slots created problems. Reducing the number of kits to that which is available had a more stablising effect (things were happening that couldn't be explained).


  • The user and all related content has been deleted.
  • GusindaGusinda Member Posts: 1,818
    edited April 2018
    @subtledoctor, Interesting. I have no doubt about the amount of kits you install. I have seem one of your WeiDU.logs... How do you get access to the kits that are below those that are shown? The limit I had was on v1.3.x, and it seemed to introduce text errors within the dialog.tlk. When I reduced the kits to 9 or less or each class, the text errors disappeared.

    Does 2.x allow for scrolling to show others (more than the 9 showing) when accessing the kits?


    Edit: OK. Ignore that, I just tried installing more kits into 2.x and was able to scroll. Good times ahead.

    Well. Doesn't fix @Elysae's problem... It could be order of mods install?
    Post edited by Gusinda on
  • The user and all related content has been deleted.
  • ElysaeElysae Member Posts: 5
    @subtledoctor I started this setup with a clean install of the game after I broke the previous one to the point where it refused to uninstall mods. So, the only thing that's been uninstalled on this one is Generalized Biffing.

    Then again, I installed all those mods back to back except for Biffing. That I added a few days later, then immediately uninstalled it again after realizing it caused a crash on trying to start a new game. Any chance I "overtaxed" the system? Or caused some sort of file lag by straining my actual system? This laptop is a bit past its prime.

    Regardless this is still the least broken setup I've had in over a decade.
  • The user and all related content has been deleted.
  • ElysaeElysae Member Posts: 5
    Yup, I realized that now. It's just a really hard habit to kick.

    As this run is still in its infancy, I might convince myself to start fresh this weekend and see how that goes.
Sign In or Register to comment.