Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Merek and Lothander, possible bug?

Just wanted to share my recent experience with the Merek and Lothander quest (poisoning in BG city). On my last two play throughs since the update, picking up Merek’s antidote after killing him does not cure the poison, nor award exp or finish the quest. Manually drinking it also does nothing. The only way I was able to get the quest to complete was to charm Merek and have him give me the antidote.

Note that I am running an EET install, so I cannot be certain if this is a base game bug or one introduced with a mod. But I thought I’d post about it to see if anybody else was running into the same problem.

Comments

  • bleusteelbleusteel Member Posts: 470
    I have a different experience with unmodded 2.5.

    Marek and Lothander’s antidotes no longer combine and the poison is no longer cured after picking up Marek’s half. However, I can manually drink Marek’s potion and get cured and XP but then I’m stuck with Lothander’s half which you can’t interact with and no longer appears to have a purpose.

    Pokota
  • WatchForWolvesWatchForWolves Member Posts: 158
    edited October 2018
    I confirm the above. Lothander's antidote does nothing, and the fact that the description mentions how it just looks like "colored water" I actually assumed this is deliberate and that Lothander duped you to get the Geas off of him.

    Marek "gives"(dies) you the real antidote and the quest ends/you get the XP when you drink it.

  • The_CheesemanThe_Cheeseman Member Posts: 175

    I confirm the above. Lothander's antidote does nothing, and the fact that the description mentions how it just looks like "colored water" I actually assumed this is deliberate and that Lothander duped you to get the Geas off of him.

    Marek "gives"(dies) you the real antidote and the quest ends/you get the XP when you drink it.

    Weird, seems like there is definitely something fishy going on. Just a wild guess on my part, but I’d assume either there is a script attached to one of the antidote bottles that isn’t triggering properly, or there was some kind of change to an item or variable involved that broke said script.

    Didn’t the most recent patch notes mention something about making the poison status more visible for the player, or something? Anybody know what was actually changed?

  • velehalvelehal Member Posts: 203
    Same bug. I´ve cured Lothander from his geas, then killed Marek but the quest is not finished (no experience) even if I´ve drunk Marek´s part of the antidote. This is game breaking bug because after ten days my party will die (I´ve tried it).
    Maybe some mod is interfering, but I have very few of them (SCS, NPC Projecet, Rogue Rebalancing, Atweak and Item Revision).

  • velehalvelehal Member Posts: 203
    edited October 2018
    I´ve tried to charm Marek but it doesn´t work for me, he gives me the antidote but the quest is still unfinished (even if I drink the antidote). Does anybody know how to solve it, because I can´t proceed futher.

  • ShashakiroShashakiro Member Posts: 24
    Lothander’s “half” has always done nothing whatsoever, as the text hints.

    The quest worked fine in my 2 unmodded playthroughs.

  • bleusteelbleusteel Member Posts: 470

    Lothander’s “half” has always done nothing whatsoever, as the text hints.

    The quest worked fine in my 2 unmodded playthroughs.

    Generally, in the EEs prior to 2.5, Lothander’s half disappears once you get Marek’s half and you are cured and get XP without manually drinking anything. You are normally left with 10 of Marek’s antidotes in your inventory.

    I’ve only done one playthrough since 2.5 was officially released so I don’t have a broad sampling. I don’t currently have SoD installed. Just vanilla 2.5 - not even an XP cap remover.

  • velehalvelehal Member Posts: 203
    Does anybody know how to solve it with the help of console, how to cure my party and finish the quest? Thank you.

  • Grond0Grond0 Member, Moderator Posts: 5,013
    I've done the quest multiple times in unmodded v2.5. I believe that it is deliberate that Lothander's antidote now does nothing and I've always been cured after drinking Marek's (though you do have to actually drink it now). I'm not sure about the journal resolving I'm afraid as I almost never look at those entries these days anyway.

    JuliusBorisov
  • velehalvelehal Member Posts: 203
    Drinking doesn´t help me. The group dies even if I drink Marek´s antidote. The quest remains unfinished and party gains no experience.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 18,011
    @velehal Please zip and attach your save at support.baldursgate.com for investigation and help.

  • Grond0Grond0 Member, Moderator Posts: 5,013
    I don't suppose it's relevant, but just in case the issue arises I'll mention that the potion has to be drunk by the PC to cure Marek's poison as it is now specifically the PC that is poisoned.

  • BalquoBalquo Member, Developer Posts: 2,728
    @velehal I tested your save and it works as expected. Make sure Aran is the one drinking the potion. If it's still not working for you, then likely one of your mods is interfering somehow.

    I've attached a new save with the quest complete.

    JuliusBorisov
  • velehalvelehal Member Posts: 203
    Thank you very much. Even if Aran drinks the potion, he is still poisoned, so I used your save.

  • subtledoctorsubtledoctor Member Posts: 10,954
    Little bump here. I'm playing on iOS - with mods, but I can't see how a mod would affect this?
    - I was poisoned by M&L
    - I met Lothander at the fair
    - The Diviner told me J Mystmyr could lift the geas
    - Mystmyr wanted me to get the tome
    - I got the tome and gave it to her
    - She gave me a scroll to lift the geas
    - I gave the scroll to Lothander at the Blade & Stars, and he gave me a single potion, which I cannot interact with
    - I found Marek and confronted him; he said "you're only hastening your demise" and went hostile
    - I killed him
    - I picked up 10 "Marek's Antidotes" from the floor (via quickloot button, if that makes a difference)
    - I still have Lothander's potion; it did not disappear from my inventory
    - My journal has not updated, I have received no XP reward
    - Drinking Marek's antidotes does nothing
    - I get sick and die no matter what

    I'm playing BGEE standalone, v2.5.17, on iOS. I have no access to the console and for some reason I cannot export savegames. :cry:

    Is there some kind of very particular way this needs to be done? Is there a trick to it? I find it pretty disturbing that a quest with such game-stopping implications is coded in such a finicky way... :rage:

  • Grond0Grond0 Member, Moderator Posts: 5,013
    edited May 18
    In the current version Lothander's potion does do nothing. To resolve the quest the PC (not a party member) does now need to actually drink one of Marek's potions, rather than that happening automatically.

    Reading your summary of actions, the only thing I can think of (other than a bug) is that you may have attacked Marek before talking to him. I agree that doing that should not affect the quest, since that should be tied to just using the antidote, but it's not uncommon in BG to have to talk to someone to complete a quest. There are instances where that's not necessary in similar situations, e.g. you can attack and kill Tranzig without talking to him, but I think those are exceptions to the general rule.

  • benibielbenibiel Member Posts: 8
    @subtledoctor This nearly always happens to me. I *think* Item Revisions is the culprit. Ages ago I found a thread somewhere where someone had the same problem with EET and were given the attached file to put in the override to fix it - it's always worked for me on BGEE too. (I don't know anything about iOS stuff or how different anything is or even if this is a stupidly unnecessary disclaimer, if things break it weren't my fault, guv)

    It *does* do something weird with importing/exporting the character - once you've used it and import the character (even over to BG2EE) you'll get another 10 000xp and the "You have been cured of Marek's poison" journal entry.

  • subtledoctorsubtledoctor Member Posts: 10,954
    edited May 18
    @benibiel thanks for the reply! That's very helpful. I'll take a look at that file, see if I can spot a meaningful difference between it and my current version. I can't see how the scripted end of the quest should have anything to do with changes in an .itm file - Beamdog, it would be really useful to know more about how the end of the quest is actually triggered! :rage:

    If dropping a file into the game fixes things that would be ideal, because I can do that easily. Messing with scripts and variables would be harder. (I could probably make some kind of hotfix mod, but I don't know what it would actually have to do...)

  • ThacoBellThacoBell Member Posts: 8,844
    Don't you need to have charname use a charge of the 10 use antidote item? I seem to remmeber that being the case.

  • subtledoctorsubtledoctor Member Posts: 10,954
    That file worked! :smiley:

    The operative difference was, drinking Marek's potion sets a local variable, "BDMAREK," to 1 on Charname when you drink it. Then baldur.bcs picks up on that and finishes the quest.

    The potn47.itm in my modded install was not setting that variable. I'm not sure if it was really Item Revisions that changed it, but it should be easy enough to find out. If so, I can submit a fix to the IR github project, or worst-case scenario, make a hotfix add-on mod. Then this problem should be fixed for good.

    Grond0ThacoBellMathsorcerer
Sign In or Register to comment.