Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

mouse pointer not visible

Can't see the mouse pointer. I can't interact with the GUI at all.

Comments

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 20,522
    Close the game down and change the value of this line from 1 to 0 in your baldur.lua file (found in Documents -> Baldur's Gate - Enhanced Edition), or vice versa:

    SetPrivateProfileString('Graphics','Hardware Mouse Cursor','1')

  • kipski42kipski42 Member Posts: 8
    My Baldur.lua file doesn't have this line.

    This is the whole file:
    SetPrivateProfileString('Window','Full Screen','1')
    SetPrivateProfileString('Window','Maximized','0')
    SetPrivateProfileString('Fonts','zh_CN','SIMSUN')
    SetPrivateProfileString('Fonts','uk_UA','PERMIAN')
    SetPrivateProfileString('Fonts','Zoom','112')
    SetPrivateProfileString('Fonts','ko_KR','NANUM')
    SetPrivateProfileString('Fonts','ru_RU','PTSERIF')
    SetPrivateProfileString('Fonts','ja_JP','MEIRYO')
    SetPrivateProfileString('MOVIES','LOGO','1')
    SetPrivateProfileString('Graphics','version','OpenGL version 4.5.0 NVIDIA 353.24 - build XXXX')
    SetPrivateProfileString('Graphics','vendor','NVIDIA Corporation')
    SetPrivateProfileString('Graphics','renderer','GeForce GT 755M/PCIe/SSE2')
    SetPrivateProfileString('Program Options','Volume Music','40')
    SetPrivateProfileString('Program Options','Font Name','')
    SetPrivateProfileString('Program Options','Maximum Frame Rate','30')
    SetPrivateProfileString('Program Options','Volume Movie','90')
    SetPrivateProfileString('Program Options','Drop Capitals','1')
    SetPrivateProfileString('Program Options','Sprite Mirror','0')
    SetPrivateProfileString('Program Options','3D Acceleration','1')
    SetPrivateProfileString('Program Options','Tooltips','15')
    SetPrivateProfileString('Program Options','Volume SFX','80')
    SetPrivateProfileString('Program Options','Volume Voices','100')
    SetPrivateProfileString('Program Options','Volume Ambients','40')
    SetPrivateProfileString('Program Options','Path Search Nodes','32000')
    SetPrivateProfileString('Program Options','Translucent Shadows','1')
    SetPrivateProfileString('Language','Text','en_US')

    I'd really like to get this working, but haven't had any luck with the options I've found on google/steam/here so far. Other ideas?

    Thank you!

  • kipski42kipski42 Member Posts: 8
    Perhaps I should add the "hardware mouse cursor" line?

  • Grond0Grond0 Member Posts: 6,150
    kipski42 wrote: »
    Perhaps I should add the "hardware mouse cursor" line?
    Indeed - it won't do any harm and might well solve your problem.

    JuliusBorisov
  • kipski42kipski42 Member Posts: 8
    Unfortunately, that didn't have any effect that I could see. Still no mouse visible.

  • Grond0Grond0 Member Posts: 6,150
    Sorry to hear that. By the way, you can also change / check that setting within the game (options / graphics / hardware mouse cursor).

    You could try stopping all other programs running on your computer at the same time - to see whether something else is interfering. You could also try changing the settings on your mouse driver to see if that makes a difference (though I wouldn't expect it to).

  • kipski42kipski42 Member Posts: 8
    I'd love to get this game working. Any other ideas out there?

  • GusindaGusinda Member Posts: 1,676
    Hi @kipski42, would you be able to run DXDIAG from the command prompt, save and upload the results? Just save the file as a .txt file for upload.

    I am guessing here that you are using Windows so another thing you could try is to start the game, remove the mouse from the PC (disconnect the cable) and plug it back into another port, wait for the PC connection sounds to finish and see what happens. When you do that, have a look at the screen and see if the mouse cursor shows up at all while it is reloading the driver (and of course if it disappears again).

    Good Luck
    Gus

    JuliusBorisov
  • kipski42kipski42 Member Posts: 8
    Thanks for the ideas! I will give both of those a shot and get back to you!

  • kipski42kipski42 Member Posts: 8
    Sorry for the delayed response. Life got in the way.

    Unplugging the mouse and plugging it back into a different port after the game started didn't fix the issue.

    Here is the DXDIAG file:

  • kipski42kipski42 Member Posts: 8
    So, Does anyone see anything in the DXDIAG file that might be the culprit? Or are there other ideas I should try? Thanks!

  • Grond0Grond0 Member Posts: 6,150
    Did you try not having other programs running? You could for instance see what happens if you start the computer in safe mode and only load what's necessary. If the mouse works on a minimal setting, try adding other programs until you find what's causing the problem.

    JuliusBorisov
  • GusindaGusinda Member Posts: 1,676
    HI @kipski42,

    Sorry about the delay myself...

    Some driver updates are required:
    - Your video drivers are out of date. Yours are 10.18.0013.5324, with the latest Windows version being 21.21.13.6909. You can use either the latest from MS (dated 2016).
    Or the NVidia driver is currently at 425.31 (dated 2019). You can choose either one to update with; I would go with the NVidia driver...
    I have a video card that is the same vintage (NVidia 770M) and my driver line show as 'OpenGL version 4.6.0 NVIDIA 425.31 - build XXXX'. Yours currently shows as version 'OpenGL version 4.5.0 NVIDIA 353.24 - build XXXX').


    Another thought is to try the DirectX engine (called Alternate Render in game: Options, Graphics) to see if the mouse problem only occurs with OpenGL.

    To switch, make sure the game is not running and that DirectX 9.0c is installed.

    Open Baldur.lua and change the line (if it doesn't exist then add):
    SetPrivateProfileString('Graphics','Backend','0')
    to
    SetPrivateProfileString('Graphics','Backend','1')

    Try the game. If it starts and mouse is showing, it may well be just an OpenGL driver problem (maybe due to the out of date driver?).


    I haven't played around much with Mac hardware so couldn't say whether this will fix it or not...

    [Casts Bless]
    Gus

    JuliusBorisovGrond0
  • kipski42kipski42 Member Posts: 8
    SUCCESS!!!

    Adding the line
    SetPrivateProfileString('Graphics','Backend','1')
    did the job!

    This was the last thing I tried, so perhaps doing this and updating the NVIDIA drivers and adding the mouse hardware line all contributed, but whatever the reason, the mouse cursor has returned!

    My deepest appreciation to all the forum members who helped figure this out, especially Gusinda and Grond0!

    Time to get rolling!

    ThacoBellGusindaGrond0JuliusBorisov
  • GusindaGusinda Member Posts: 1,676
    @kipski42, I am guessing here that it was the OpenGL driver. Try revert it back to Backend of 0 and see if that works... If not, oh well!

    Gus

    JuliusBorisov
  • SoidoSoido Member Posts: 172
    I see this has been solved, but for those who have this problem with the mouse there is one extremely easy solution. Just Alt-Tab from the game and back. It may take 2 tries or 3 tries, just keep Al-Tabing

    Gusinda
Sign In or Register to comment.