Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Android BG1EE.2.5.17.0, BGSOD.2.5.17.0 & BG2EE.2.6.16.6 Modfiles

GusindaGusinda Member Posts: 1,808
edited January 2020 in General Modding
Hi All,

The aim of these modfiles are to have a similar set of mods that are installed for all of the trilogy(+); for forumites that don't have the resources to do it themselves. The mods requested as content came from another thread of which it outgrew.



Modfiles Content
~~~~~~~~~~~~~~~~
BG1EE & BGSOD
=============

Override Fixes:
- Whispers of Silence (Non-Detection that works)
- Icestorm Spell (number of Rounds = 4)
- Beserker Rage spell
- Beserker Rage for Minsc
- Horror spell (duration = 1 turn)
- Broken doors and Area Transition (Area 3300)

Homemade Addon:
- GUI Console access

Mods:
- Animal Companions v1.5.7
% - Wandcase v1.3
%!- Thrown Hammers v6.0.3
%!- Convinient Ammunition v2.0
% - More Style for Mages v1.55
- Shadow Magic v1.9.8a
- Tomb and Blood v0.8.37
- Tweaks Anthology v8.0
- aTweaks v4.51
- One Pixel Production v4.0.1 (Smart Avatar and Armour Switching Only)
- Continuous Portraits v1 (Set for BG2EE portraits)

% - If you start a new game, the items would need to be consoled into the game. If coninuing from an import, the new items should come in with the saved game if on the PC.
If Wandcase doesn't appear with saved game import, it may need to be consoled: C:CreateItem("WANDCASE"). For me, it is sometimes there and sometimes not...
! - Not installed in BG2EE.


BG2EE
=====

Override Fixes:
- Whispers of Silence (Non-Detection that works)
- Beserker Rage spell
- Beserker Rage for Minsc
- Horror spell (duration = 1 turn)
- Flail of Ages +4 (Damage Order correct)
- Flail of Ages +5 (Damage Order correct and modified to allow Haste)

Homemade Addon:
- GUI Console access

Mods:
- Animal Companions v1.5.7
- Wandcase v1.3
- More Style for Mages v1.55
- Shadow Magic v1.9.8a
- Tomb and Blood v0.8.37
- Tweaks Anthology v8.0
- aTweaks v4.51
- One Pixel Production v4.0.1 (Smart Avatar and Armour Switching Only)

For the exact components of each mod, there is the WeiDU.log attached for the modfiles.

----

To install the mod BG1EE:
- Download the files to your device and place into a folder other than the games folder.

- Unpack 'BG1EE.2.5.17.0_Modfile_Trilogy1.7z' into the following folder:

'Android/data/com.beamdog.baldursgateenhancededition/files'

- The Android File Manager you are using will determine the way to unpack the file, but unpack the file into the root of it's current folder keeping the file structure so you will end up with something like:

'Android/data/com.beamdog.baldursgateenhancededition/files'
'Android/data/com.beamdog.baldursgateenhancededition/files/override' (folder)
'Android/data/com.beamdog.baldursgateenhancededition/files/save' (folder)
'Android/data/com.beamdog.baldursgateenhancededition/files/baldur.lua' (File)
'Android/data/com.beamdog.baldursgateenhancededition/files/lang-en_US.zip' (File)
and any other folders you may already have like portraits etc.

If your file manager can't handle .7z files, I know that 'RAR for Android' or 'ZArchiver' have no problems.

----

To install the mod BGSOD:
- Download the files to your device and place into a folder other than the games folder.

- Unpack 'BG1EE-SOD.2.5.17.0_Modfile_Trilogy1.7z' into the following folder:

'Android/data/com.beamdog.siegeofdragonspear/files'

You will get a similar folder/file view as BG1EE except in the SOD folder.

To install the mod BG2EE:
- Download the files to your device and place into a folder other than the games folder.
- Unpack 'BG2EE.2.5.16.6_Modfile_Trilogy1.7z' into the following folder:

'Android/data/com.beamdog.baldursgateIIenhancededition/files'

You will get a similar folder/file view as BG1EE except in the BG2EE folder.

----

You are now ready to test, if the games crash, then make sure you don't have the modfile itself as it will clash with the unpacked mod. If the game plays, then you are good to go.

I did a quick test for each game by generating a character (Shadow Monk) and examining the text to make sure there weren't any invalids (at least in the char gen section...). If there are any problems that arise during game play, let me know and I will see if I can do something.


----

To uninstall (for All):

- Delete 'override' folder
- Delete lang-en_US.zip
You are now back at vanilla...
----

Attached are the files for BG1EE. Below will be the files for BGSOD and BG2EE.


Happy Gaming
Gus

Edit: These modfiles are created for the English version of the game.

Post edited by Gusinda on
LoldrupStephburnDjasko_Amsterdam
«13

Comments

  • StephburnStephburn Member Posts: 4
    Shows Invalid and bunch of numbers in character creation for sorcerer and mage class, Bgee version 2.5.17.0.

  • GusindaGusinda Member Posts: 1,808
    Hi @Stephburn, and welcome to the forum. I just tried the modfile and had no problems and was able to create both a Mage and Sorcerer (I used the Shadow variants).

    This problem you describe is usually about lang-en_US.zip; where it is located, not unpacked and if you have another *.zip in either of the game's folders (where the data is and where the .obb files are located).

    Could you make sure that there is only 1 lang-en_US.zip located in:
    'Android/data/com.beamdog.baldursgateenhancededition/files'
    (It needs to be in the internal storage and not any external SDCard of sorts)

    Could you also make sure that lang-en_US.zip wasn't unpacked. This can be done by checking to see if there is a 'lang' folder under files. 'lang-en_US.zip' has been treated to allow the game to read it within the Android file system.

    The last thing I that could be a problem is that the modfiles are made for the English version of the game. I just reread the OP and noticed that it wasn't mentioned... It wouldn't work with other languages due to the dialog.tlk that is being modified. If you are running another language, I could attempt to create the same modfile content but I wouldn't be able to test it!

    Gus

    Stephburn
  • StephburnStephburn Member Posts: 4
    Oh I have unpacked the 'lang-en_US.zip'. Tried and it's working perfectly now. Thank you @Gusinda.

    Gusinda
  • StephburnStephburn Member Posts: 4
    A little help please, I want to remove the following tweak anthology mods -
    ~CDTWEAKS/SETUP-CDTWEAKS.TP2~ #0 #4140 // Don't Auto-Assign Advanced AI Scripting to Party: v8.
    Can I delete a override file to remove that mods?

  • GusindaGusinda Member Posts: 1,808
    Hi @Stephburn, all you should need to do is delete 'partyai.2da' from the override. I am unsure however what happens with members that are all ready in the party. The mod config might remain with the saved game file.

    Gus

  • StephburnStephburn Member Posts: 4
    Thanks and what about the Smart avatar and armor switching?l

  • ball_manball_man Member Posts: 5
    I get the invalid error if I play as male character. It works fine if I play as female tho. Strange🤔

    Kaldur
  • GusindaGusinda Member Posts: 1,808
    edited March 2020
    Hi @ball_man, yes very strange. Let me have a look at it. Had something similar recently.. Better ask, is this on all of them or just BG2EE (this was where the recent problem was).

    Gus

  • GusindaGusinda Member Posts: 1,808
    @ball_man, could you let me know exactly what was the class selected and which game (and version) you were playing?

    Thanks
    Gus

  • ball_manball_man Member Posts: 5
    @Gusinda The error was showing for mage and sorcerror. Various items in the game were showing the error as well.

  • GusindaGusinda Member Posts: 1,808
    Hi @ball_man, can't seem to replicate the problem. Can you make sure that you don't have two dialog.tlk (either unpacked or zipped) in the same folder, which includes the modfile download itself?

    Tried with both Sorcerer's and various Mage types (incl vanilla) on both BG1EE and BG2EE games.

    Thanks
    Gus

  • dipsetdipsetdipsetdipsetdipsetdipset Member Posts: 9
    @Gusinda would you by any chance be able to add the banter pack and SCS to the BG2 version of this? I do not have access to a windows machine anymore to try and create it myself. I would appreciate it a ton. I found one that you did for BGEE with the NPC project, SCS, and some cool bard kits so I want to take a character through the entire saga!

  • GusindaGusinda Member Posts: 1,808
    Hi @dipsetdipsetdipset, and welcome to the forum. Sorry for the delay but times have been busy.

    I just uploaded a version that I made a while ago for another forum member. Try that and see if it fits what you would like. If it doesn't, let me know what mods you would like installed and I can try and put something together.

    Happy Gaming
    Gus

  • dipsetdipsetdipsetdipsetdipsetdipset Member Posts: 9
    Hi @Gusinda! Thank you so much for your response and for all of the modding work that you have done for everyone on this forum. I saw that modfile for BG2EE and it is exactly what I am looking for. I hate to ask for more, but I am wondering if you could add the shadow magic mod to the modfile with SCS that you made for Pholisma in this post?

    https://forums.beamdog.com/discussion/73872/bg1-npc-pack-mod-for-android-2-5-17-without-windows/p1

    Once again thanks so much for everything you have done.

    Dipset

    Gusinda
  • GusindaGusinda Member Posts: 1,808
    Hi @dipsetdipsetdipset, I have uploaded the requested modfile, just kept it in the original thread so that others know what it contains...

    Thanks for the comment and enjoy
    Gus

  • noodlesoupstrainernoodlesoupstrainer Member Posts: 10
    Hi @Gusinda. Thanks for all the help you've provided here and elsewhere. I've been trying to get some mods working on BG2EE (Android version from the Play Store, running on an HP Chromebook; no issues running vanilla BG2EE), so far without success. I tried carefully following your instructions above, but the game doesn't seem to recognize the override folder.

    Is it necessary to follow the instructions in this post before installing these modfiles? If so, do you happen to know if this can be accomplished without the use of a Windows machine to run centralfix? My main pc is in storage, and I don't currently have access to it.

    I've thought about trying the gemRB engine instead if I can't get this to work, but I figured the touch controls would be better optimized in the android version. Any advice would be appreciated.

  • GusindaGusinda Member Posts: 1,808
    Hi @noodlesoupstrainer, and welcome to the forum.

    Are you talking about the modfiles that I have uploaded? If so, then you wont need to run centralfix as I already have applied it against the lang.zip file before uploading. I have a mate who has a Chromebook and is able to run the modfiles, so I am sure we can get it to work.

    When you say it wont recognise the override folder, exactly what is the game doing? Is the text showing as INVALID, or is the game not starting at all, or is it starting, but there is no change to the game itself? When upacking the modfile, which FM did you use?

    If you haven't used GemRB before, then you might find it a bit disappointing. I ran it for about 18 months prior to the EE series coming out and although I still have it sitting around all configured, I hope never to put it back on... It did the job pre-EE, but now I would find it just frustrating...

    All the best
    Gus

    noodlesoupstrainerKaldur
  • noodlesoupstrainernoodlesoupstrainer Member Posts: 10
    edited April 2020
    Hey @Gusinda, thanks for the response! I thought that was the case, but I couldn't figure out why it wasn't working. Maybe the file manager was the culprit. I used 7zipper to unpack. Maybe I'll try again with something else.

    By not recognizing the override folder, I meant that the game runs normally. I never proceeded past character creation, but I gathered that the modfile should add extra classes. I can see only the vanilla options, and none of the kits I've seen specifically referenced here e.g. Shadow Monk, different Sorcerer variants. Based on that, I assumed that the game was ignoring the override folder.

    UPDATE: Deleted override folder and lang-en.zip, extracted with RAR, and hey presto! I've got a bunch of sorcerer bloodlines. Thanks for the tip about the file manager :)

    FURTHER UPDATE: Don't suppose I could prevail upon you to include this in a modfile? Either way, many thanks!

    Post edited by noodlesoupstrainer on
    Gusinda
  • GusindaGusinda Member Posts: 1,808
    Hi @noodlesoupstrainer, no probs... Will have a go at including RE, just not sure when I will get the opportunity.

    Gus

    noodlesoupstrainer
  • KaldurKaldur Member Posts: 17
    Hi Gus, i am having the same problems with mods that needs lang archives. It sees override mods, but doesn't lang files, maybe it has something to do with default language(Russian is main lang, when i clear the game data, thanks.
    1jqcifsnjto3.png

  • KaldurKaldur Member Posts: 17
    edited May 2020
    I tried with 1.3 version and any mod has no probs with lang files(also it doesn,t use russian as a main language, maybe it is the problem?)
    Thanks.
    UPD: somehow when i play as a female character lang files works and has no probs as invalid banters and classes with every mod, but still as a male it has these problems.

    Post edited by Kaldur on
  • GusindaGusinda Member Posts: 1,808
    edited May 2020
    @noodlesoupstrainer

    Sorry about the delay, with the lockdown, the family used the office as a work environment so I don't get much of an opportunity to use it during the week.

    Attached is a new BG1EE modfile that contains all of the above in the OP with the following:

    Updated:
    Shadow Magic v2.0
    Tomb & Blood 0.8.49
    Tweaks Anthology 9.0

    Added:
    BG1 Romantic Encounters 2.7

    Hope this works out as I haven't done much testing other than to create a Fighter/Sorcerer and wandered around a little bit and increased in level checking on the spells allocation and text.

    Happy Gaming
    Gus


    Edit: Files removed. Updated version below.

    Post edited by Gusinda on
    noodlesoupstrainer
  • GusindaGusinda Member Posts: 1,808
    edited May 2020
    Hi @Kaldur, you are correct in the assumption about the languages in the modfile. Unless specified, they are all created with the English language (en_US) in mind.

    I have attempted to create a modfile for the Russian language (ru_RU). Unfortunately, I didn't test much (can't read Russian) at all other that the character creation using 'reflex memory' to get through the menus.

    Any mod that didn't have a translation for Russian was left as English, so you will see a mixture. For the installation instructions, check the OP. I will emphasise though that the lang-ru_RU.zip file needs to remain in its container (.zip) and kept in the root of:

    Android/data/com.beamdog.baldursgateenhancededition/files/

    Hope all that makes sense. If it doesn't, let me know and I will see if I can expand further.

    Not sure why it would allow for the female, this has happened before (as in problems with the male char and not the female). I haven't experienced that yet but when I do, I shall see if I can find how it is happening.

    Let me know how it goes, and I will see if I can do the same for SOD and BG2EE.

    Удачи
    Gus

    Edit: This is for BG1EE 2.5.17.0 and contains the same mods as the file above.

    Edit: Files removed, english version updated below

    Post edited by Gusinda on
  • noodlesoupstrainernoodlesoupstrainer Member Posts: 10
    You're my flipping hero, @Gusinda. Thanks a bunch! Still stuck out here with my chromebook. Lemme know if you have a Patreon or some such.

  • GusindaGusinda Member Posts: 1,808
    Thanks @noodlesoupstrainer, I am not sure what a Patreon is, so I am guessing here that I don't :smile:

    Out of interest, what variant of Chromebook (ARM/Intel) do you have and have you tried any Linux games/apps on it yet? I put ChromeOS onto an Intel Notebook to see what it can do and read about the ability to install Linux Games on it. Have a mate who only has a Chromebook as well so trying to expand his gaming horizon.

    Gus

  • KaldurKaldur Member Posts: 17
    edited May 2020
    Hi @Gusinda i was hoping to play English version, but that's not a problem 🙂, anyway when i start a new game,game crushes and it changes main menu to BG1 ,i also tried to use BG2 modfiles with BG1 LANG you shared it didnt work with both languages 😶 9hdrfqbrxqso.png

    Post edited by Kaldur on
  • KaldurKaldur Member Posts: 17
    @Gusinda thank you anyways, also you didn't had to struggle with russian, i prefer english( and as i can see it has the same problems as english)

  • GusindaGusinda Member Posts: 1,808
    Hi @Kaldur, yeah, the BG1 lang file can't work with BG2. Just want to make sure that the game you are running has the language set to English (Options, Language, English). I downloaded both BG1 and BG2 modfiles and tried them having no problems creating a Male fighter.

    If the language is set to English, can you make sure that lang-en_US.zip is located in Files folder and that there isn't a Files/lang folder. Also, lang-en_US.zip is the only other file apart from bladur.lua in the root.

    With the game crashing, it is a symptom of having 2 lang files in the Files folder.

    Once we get this sorted, we will have a look at the other thread.

    Thanks
    Gus

Sign In or Register to comment.