Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Display Problem

Using Nvidia's latest display Driver 416.94 on Windows 10 64bit, the image has flickering black shapes on the display. Switching to the alternate renderer fixes the problem but I didn't have this issue with previous drivers. I'm using version 2.5 of BGEE and an Nvidia 1080TI SLI system. I've tried in both single card and dual card mode with no change in the results. The alternate renderer fixes the problem in both single card and dual card mode. The default renderer has major artifacting and looks like the display is having a hard time getting a solid digital signal.

Torgrimmer

Comments

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 20,187
    edited November 2018
    Hi! I fixed that myself by going to the Nvidia panel and creating special rules for the games (don't forget - create settings for each of the game, not for everything).

    https://steamcommunity.com/app/228280/discussions/0/864972399642318316/#c864972399672389755

    I actually think this one solved the flickering for me: https://forums.beamdog.com/discussion/comment/150863/#Comment_150863

    Torgrimmer
  • the_sexteinthe_sextein Member Posts: 711
    edited November 2018
    I appreciate the comment and I don't mean any offense but I would never play a game without V-sync. The screen tearing would be unbearable. It's clear that you guys have a problem with your renderer on the latest drivers from Nvidia. Most likely it's a frame timing issue since turning off V-sync seems to stop it from occurring. I'll just use the alternate renderer since it seems to be working correctly with V-sync enabled. My control panel is set to use the application's V-sync setting and Beamdog has V-sync set to "on" by default with a default renderer that cannot work properly with it on. Something should probably be done about it.

    Also, I should mention that I have played this game with my current hardware without issue in the past. I installed BGEE 2.5 and it worked perfectly. Either Windows update or Nvidia's drivers have caused this just recently on my machine. I have used the default renderer with V-sync since BGEE was released without problem. I never had a problem with the alternate renderer on my system either and it continues to work properly even now.

    Being that your default renderer is Open GL and Microsoft only focuses on it's own Direct X standards, it's probably a problem caused by the fall update for Windows. Direct X is the alternate renderer and it still works properly. It could be a problem with Nvidia's Open GL implementation or it's possible that Beamdog needs to update their software to work with the latest standards from Nvidia and Microsoft.

    Post edited by the_sextein on
    Torgrimmer
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 20,187
    @the_sextein If possible, can you upload a short video of what you see in the game (or two) with different renderers, and file a bug at support.baldursgate.com. Please try to attach your DxDiag file as well, and any screenshots of your Nvidia settings.

    Torgrimmer
  • the_sexteinthe_sextein Member Posts: 711
    edited November 2018
    Unfortunately, I can't record a video of the problem because the frames are being rendered correctly by the game and the card. The problem is with the timing of those frames when they hit my monitor. That is why the problem goes away when I disable V-sync. I recorded a video of it but the problems do not show up in the video for the reasons stated above and so there is no point in me posting it.

    I rolled back my Nvidia drivers to 416.81 which used to work but the problem still persists. I did a clean install of the drivers with all settings left at their default values.

    I have doubled checked my HDMI cable and my TV settings. I have checked my Amplifier settings as well to make sure the problem is not occurring between the card and my display because of a faulty connection or a bad setting. I would blame myself or my own hardware but the thing is,

    GTA 5
    Dying Light
    Hitman 2016
    Hitman 2018
    Stalker COP

    are all installed on my system and they all work without any issue. The problem only occurs with Baldur's Gate.

    I have now reinstalled the latest drivers from Nvidia and I will post my DXDiag which also shows a clean install with no problems.

    I played this game a few months ago, possibly even weeks ago without noticing any problems. Only thing I can think of is windows update. Nothing else has changed on my setup that I am aware of.

    I uninstalled BGEE and did a clean install with no mods for testing purposes and the problem remains.
    One last thing, the problem actually does occur using Direct X and Open GL. It's less noticeable with DX but the problem is with the EE in general it would seem. All system overclocks were set back to their default values for the purposes of testing also. I did notice some things are coming up unknown in my DXdiag file. I could try to install Direct X again just to make sure. Can't think of much else to do.

    I did enable software support for surround sound in openAL. I could try to uninstall open AL and reinstall the generic Open AL option if you think that may be the problem.

    Torgrimmer
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 20,187
    Does the problem happen when you switch off those graphical settings I've linked above?

  • the_sexteinthe_sextein Member Posts: 711
    Well, I just tried them all and I did find an odd solution.

    The first thing I tried was disabling the mouse hardware acceleration and it didn't help.
    I then disabled V-sync which did fix the problem but screen tearing is just not going to work for me.
    Oddly enough, forcing AA to override the game and setting it to 2X fixed the problem. Using any other AA setting such as 4X or 16X SLI will cause problems. Leaving AA at it's default value (which uses BGEE's default setting) also has problems.

    S0 forcing 2X AA on the game fixes it for some reason. Maybe you guys should force 2X AA on the game engine by default? Seems very strange especially since AA doesn't actually work on this game and I have played it at the default settings for years without problems previously. I am at a loss as to why this might be but at least it is working with v-sync now that I have forced 2X AA on it. Thanks for your help!

    JuliusBorisovhook71
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 20,187
    Well, thanks for the feedback, I've passed it to the developers. In the meantime, create a special rule for each of the EEs, set AA to 2x (as this is what did the thing for you), and play. For me - it was disabling the triple buffering which did the trick. Nvidia Panel is a very nice tool - you can customize your settings for all kinds of situations.

    Torgrimmer
  • the_sexteinthe_sextein Member Posts: 711
    Have you tried forcing 2X AA instead of disabling v-sync? Maybe you are using a free sync or G-sync monitor? I am using an HDTV so V-sync is a must on all games otherwise the screen wobbles around and creases form all over the screen when ever you move the camera.

    A few more notes on the situation.

    MSAA will break the game at it's default value of "Application controlled"
    MSAA will work if it is forced at 2x,4X, or 8X.
    SLI MSAA 16X will break the game
    Temperal AA can be set at off 2x, 4x, or 8x without issue
    Temeral SLI 16X supersample will break the game
    FXAA will break the game
    All Anisotropic filtering settings work fine.

    In conclusion on my system:

    For best visuals you should leave V-sync alone (which will enable it as per beamdog default) and force any MSAA option you want just don't leave it at default. 16X AF will improve the visuals without breaking anything and Temperal AA can be used at any setting. All SLI AA options should not be used in this game.

    JuliusBorisovhook71
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 20,187
    Yes, I have a G-sync monitor.

  • the_sexteinthe_sextein Member Posts: 711
    edited November 2018
    That would explain it, you can bypass the screen tearing and whatever problem Baldur's Gate has with frame timing is auto corrected by your display since you do not need V-sync to time it to your monitors refresh rate. I agree that the Nvidia control panel is a very useful tool. I also use NV inspector as it has more options. Being an SLI user I have to mess with it all the time. Looks like Baldur's Gate tells the drivers to use single card mode even if SLI is enabled which is why SLI AA modes cannot be used. I am still at a loss why MSAA being forced on the engine would fix the problem. So bizarre especially since I have never forced AA on the game in the past other than for testing purposes and I never encountered the problem until now.

    JuliusBorisovTorgrimmer
  • the_sexteinthe_sextein Member Posts: 711
    edited November 2018
    I experimented by forcing lower refresh rates from the GPU and it makes the problem worse so the problem is certainly with the refresh rate not matching the monitor when V-sync is active. Lowering the refresh rate to 30Hz or below blacks the entire screen out almost. If my monitor could go beyond 60Hz it wouldn't be a problem I am willing to bet. It's a 4K panel and not many of them support true 120Hz yet. Forcing MSAA on the engine through the Nvidia control panel will fix the timing issue and allow v-sync to be used on a 4K panel or non G-sync monitor without issues.

    JuliusBorisovTorgrimmer
  • sarevok57sarevok57 Member Posts: 5,049
    i've noticed that with the rtx 2080 ti there is also graphical issues with the EE games as well, although they arent unbearable, they are noticeable

    i thought originally it was my card since these cards have been known to crap out very early, but when i run doom 2016 at max settings just trying to destroy my PC hardware load wise, everything is fine

    for me there is sometimes graphic anomalies in the character sheet and when i look at the area map, there will be flickering squares on it, but other than that it works perfectly fine

    im running my monitor at 1920x1080 res and 74 Hz

  • the_sexteinthe_sextein Member Posts: 711
    edited February 2019
    Congrats on the new card! I went big last gen so I'm waiting on the 7nm cards next year before I upgrade again. I'm kinda pissed about the pricing on those though. That card almost costs as much as a dual card SLI setup from the previous gen. Ngreedia. Have you tried setting AA to override the game settings and then manually setting it to 2X MSAA in the control panel? That fixed all of my problems with Baldur's Gate.

    That card is kind of overkill for a 1080P monitor. Might as well set 4K DSR in the control panel for everything you play. Doom can be maxed out on a single 1080TI at 4K resolution so that 2080TI is probably not even breaking a sweat.

  • sarevok57sarevok57 Member Posts: 5,049
    it definitely is not breaking a sweat, i was able to room doom at 2560x1440p with max settings and it was still averaging 170 fps ( i think it dropped below 100 for half a second at the lowest before jumping back up to around 170 or so )

    the thing is, i want to get 2 165Hz 1440p monitors but its 800 bucks for them at this time, and to be perfectly honest i dont really need them at the moment, even though i have the money to buy them, i would rather invest that money right now, then waste it on those monitors

    and the only reason why i even bought a brand new PC was because my other one's motherboard died, and the hardware was so obsolete in there i pretty much had no choice but to do everything new ( although i could have kept the same power suppy buy oh well, i guess that was only 100 bucks or so ) but yeah, the price for that card, wowzers, 1800 bucks before tax, it pretty much cost 1/3rd of my PC, and normally to build a pimpin' gaming rig i could do it with around 3 grand, this time around it was double oi

    as for manually setting the MSAA, i will give it a shot and see if i still get those graphic anomalies

  • sarevok57sarevok57 Member Posts: 5,049
    so tried turning on the AA stuff and it doesnt seem to be working, but on the flip side, the graphical glitches that i am getting arent breaking the game play, so i can live with them for the time being

  • the_sexteinthe_sextein Member Posts: 711
    Interestingly, I upgraded my GPU driver tonight to driver 419.17 and the game works without any problems now even without AA being forced on the game. If you have not done so already, upgrade your drivers to the latest version. Most likely Nvidia was having some problems with certain programs and games on the latest updates for Windows.

    GusindaJuliusBorisov
  • sarevok57sarevok57 Member Posts: 5,049
    ah, i will give that a try then, because even IWD EE was having some graphical issues as well

  • sarevok57sarevok57 Member Posts: 5,049
    so i downloaded the new driver and it has not fixed the problem, oh well, it doesnt really affect my game play too much, so hopefully some time in the future it will get fixed on beamdog's part or perhaps one day a driver will come out that agrees more with the EEs

    the_sextein
  • the_sexteinthe_sextein Member Posts: 711
    It may not be a huge problem but when you pay that kind of money you should get quality graphics. Hopefully this will get sorted. We will all move on to newer tech eventually and the game needs to display properly.

    sarevok57
Sign In or Register to comment.