Skip to content

Cheat codes not able in Steam?

SamuelVargSamuelVarg Member Posts: 598
Hi there.

I have noticed that I cannot enter coded in the steam-version. Seems that more have the same trouble.
That is a shame since my Rasaad quest will not trigger ...

Anyone who knows anything about this?

Comments

  • CaeDaresCaeDares Member Posts: 182
    I have the steam version and cheat codes work perfectly fine.
    Did you follow the process of enabling cheats to the letter? You might have done something wrong / misspelled something.
    SamuelVarg
  • HeindrichHeindrich Member, Moderator Posts: 2,959
    I wasn't sure what you meant. But if you mean cluaconsole, then yes I can confirm that it does work for Steam, as I have BG:EE on Steam too.

    Remember that if you have Windows 7, you need to edit a copy of the .ini file outside of the game folder, and then move and replace the original. If you just edit the original, the changes don't stick.
    SamuelVargMagpieRandoms
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 22,496
    Hi, Samuel, nice to see you back!

    Before actually typing console commands, you should edit your baldur.ini file.

    1. Enabling the CLUA Console

    C:\User\My Documents\Baldur's Gate - Enhanced Edition
    Open up the Baldur.ini with a text editor. I suggest ConTEXT as its free and will also enable you to easily edit scripts too.

    Add these lines 'Program Options', 'Debug Mode', '1', You can put it right at the top if you like
       
    CREATE TABLE options (
    section string,
    name string,
    value string
    );
    INSERT INTO options ROWS (
    'Program Options', 'Debug Mode', '1',
    check http://forum.baldursgate.com/discussion/8317/general-bgee-customization/p1

    This works for the Steam version just fine, see https://steamcommunity.com/app/228280/discussions/0/828935672770927114/?l=french for example

    SamuelVargmlnevese
  • SamuelVargSamuelVarg Member Posts: 598
    Thank you for the welcome back. :-)

    I have added the text as I did last time on my last computer. Did work then when I used the gog-version.

    I have a MacBook. Maybe that't why it don't work?
  • SamuelVargSamuelVarg Member Posts: 598
    Ok. I seem to have found the problem ...
    the ini-file won't save the text for some reasen. Will try with another program.
    JuliusBorisov
  • HeindrichHeindrich Member, Moderator Posts: 2,959
    I suspect it is the same problem as I mentioned with Windows 7. It's a bit of a pain for me to set up as well, but basically I copied the .ini file to desktop, made the changes there, and then moved it back to the game folder, making sure to "move and replace". Even "copy-paste-replacement" does not appear to work. I don't know why it works like that, I don't question our AI masters. :smile:
    SamuelVargMagpieRandoms
  • SamuelVargSamuelVarg Member Posts: 598
    Thanks everybody. Now it works.
    It's good to have computer nerds (it's a compliment!) close by. I know squat about codes and this kinda things ...
    HeindrichJuliusBorisovmlneveseMagpieRandoms
  • MarkLopiccolaMarkLopiccola Member Posts: 4
    Try this format:
    C:CreateItem("boot01") for Boots of Speed

    It's changed from the old format of CLUAConsole:CreateItem("boot01") with the latest update. This also works in BGEE2
  • randomhero890randomhero890 Member Posts: 86
    edited July 2016
    What's weird for me is I was able to edit the lua with the debug mode '1' line in, so when I hit ctrl+space it brought up the console

    From there I could type things like C:ExploreArea() and it would work. But every cheat code would not. For example if I tried to do C:Cheats:DrizztAttacks() it would give a "nil string" error

    Not a big deal but I was hoping to be able to eventually see how we would do against drizzt, and having already did the "defend drizzt" quest....now I can only fight him on bg:ee with the console
  • AwakenedTreeAwakenedTree Member Posts: 2
    Hi, I'm having the same problem as SamuelVarg, but haven't been able to solve it. I'm running it through steam on macOS sierra (10.12.1).

    I've tried editing on the desktop, but whenever I launch the game it reverts the file to it's unedited version. No clue where to go from here. I've been unable to get any changes to stick without locking the file itself, and even then the console won't work.

  • Vorlianth93Vorlianth93 Member Posts: 1
    hi, i dont have an ini-file but i do have a lua-file...is that the same thing or what?
  • DoubledimasDoubledimas Member, Mobile Tester Posts: 1,286
    @Vorlianth93 check this thread.
    [Deleted User]Gate70JuliusBorisov
  • Lyon7474Lyon7474 Member Posts: 1
    So what if you have Baldur.lua file instead of a Baldur.ini?
  • DoubledimasDoubledimas Member, Mobile Tester Posts: 1,286
    Lyon7474 said:

    So what if you have Baldur.lua file instead of a Baldur.ini?

    If you have a .lua file it means you are using a v2+ version of the game(s). And you need to use the instructions in the link mentioned in my previous post.

    JuliusBorisov
  • CodeKillerCodeKiller Member Posts: 20
    I saw that in fact the main question did not get any answer.

    Is there a way to use "Cheats" command like the standard CLUAConsole ?

    Because as said, DrizztAttacks() for example does not exist anymore.
  • GilveronGilveron Member Posts: 3
    Ok guys, I initially got the Cheat Codes to work fine by adding the ('Program Options','Debug Mode','1') line to the Baldur.lua file using WordPad. Then one day the console simply stopped opening. I have tried EVERYTHING to get the console to open again and no luck. Does anyone have any advice or solutions?
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 22,496
  • GilveronGilveron Member Posts: 3
    Unfortunately, I did not. I didn't own the game (except for the original cd copies) until after the 2.0 roll out. I put the line exactly as I posted in the .lua file, not the .ini file. Interestingly enough this happened to me once before, and I uninstalled and re-installed the game, re-edited the file, and the console worked fine. Then it happened again, but this time that didn't fix the problem. I am at an utter loss.
  • Gate70Gate70 Member, Developer Posts: 3,837
    Did you also add the SetPrivateProfileString part?
    SetPrivateProfileString('Program Options','Debug Mode','1')
    JuliusBorisov
  • GilveronGilveron Member Posts: 3
    Gate70 said:

    Did you also add the SetPrivateProfileString part?
    SetPrivateProfileString('Program Options','Debug Mode','1')

    Yes I did.
  • GusindaGusinda Member Posts: 1,847
    Hi @Gilveron, would you be able to post your baldur.lua (need to rename it to baldur.lua.txt)?

    Gus
    JuliusBorisov
Sign In or Register to comment.