Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Weidu .ITM Description by .Tp2 File

NK1990NK1990 Member Posts: 26
So I have made my Item mod install with Weidu, it took some time to figure out but finally had some succes with help from some of the guides online.
However now that I actually have made the Weidu.exe install the mod with the right description, put in rightly, so it stands like the original vanilla descriptions. I have myself a problem with the line symbol used by the vanilla description (–), for some unfathomable reason Weidu cannot put this symbol into the game, but makes a square instead. I can put in the one from the keyboard, but it is not the same, it is shorter.
I know it is the one I used as and example but this webpage changes it when I copy paste. If anyone know a fix for this so I can get the right line, it would be very much appreciated.
I will upload the item mod install so you can see my problem.

In advance thanks

Comments

  • GusindaGusinda Member Posts: 1,608
    @NK1990, haven't had a problem using copy and paste. What editor are you using? I use Notepad++.

    The other thought is the font used in your editor (and maybe language).

    Gus

  • NK1990NK1990 Member Posts: 26
    Gusinda wrote: »
    @NK1990, haven't had a problem using copy and paste. What editor are you using? I use Notepad++.

    The other thought is the font used in your editor (and maybe language).

    Gus

    I use notepad++ and it register the symbol fine.

  • NK1990NK1990 Member Posts: 26
    NK1990 wrote: »
    Gusinda wrote: »
    @NK1990, haven't had a problem using copy and paste. What editor are you using? I use Notepad++.

    The other thought is the font used in your editor (and maybe language).

    Gus

    I use notepad++ and it register the symbol fine.

    srry not notepad++, just notepad. I will try the ++ version.

  • NK1990NK1990 Member Posts: 26
    NK1990 wrote: »
    NK1990 wrote: »
    Gusinda wrote: »
    @NK1990, haven't had a problem using copy and paste. What editor are you using? I use Notepad++.

    The other thought is the font used in your editor (and maybe language).

    Gus

    I use notepad++ and it register the symbol fine.

    srry not notepad++, just notepad. I will try the ++ version.

    It did not work.

  • GusindaGusinda Member Posts: 1,608
    @NK1990, I am not much of a modder, but I rewrote the mod into the format that I would write it and it worked. All I did was to TRAify it by removing all the text from the tp2 and placing it into a .tra file along with a couple of small changes (backup location and gave it a version number) which I noted in the mod files.

    It was all copy and paste so I still used the text that you had (except where I placed the notes into a readme file) and didn't change any of the - signs.

    WeiDU isn't included in this package

    Gus

    NK1990
  • kjeronkjeron Member Posts: 2,151
    @NK1990 You have the tra file encoded using ANSI. You either need to use UTF-8 encoding, or use the ANSI equivalent: – (all 3 characters).

    When using "Save As" in Notepad, it gives you the option of which encoding to use (ANSI and UTF-8 among them).
    You can change it in Notepad++ by selecting: "Encoding" -> "Convert to UTF-8"

    GusindaNK1990
  • NK1990NK1990 Member Posts: 26
    Gusinda wrote: »
    @NK1990, I am not much of a modder, but I rewrote the mod into the format that I would write it and it worked. All I did was to TRAify it by removing all the text from the tp2 and placing it into a .tra file along with a couple of small changes (backup location and gave it a version number) which I noted in the mod files.

    It was all copy and paste so I still used the text that you had (except where I placed the notes into a readme file) and didn't change any of the - signs.

    WeiDU isn't included in this package

    Gus
    kjeron wrote: »
    @NK1990 You have the tra file encoded using ANSI. You either need to use UTF-8 encoding, or use the ANSI equivalent: – (all 3 characters).

    When using "Save As" in Notepad, it gives you the option of which encoding to use (ANSI and UTF-8 among them).
    You can change it in Notepad++ by selecting: "Encoding" -> "Convert to UTF-8"

    Thank you for your help to both of you, yeah found out kjeron took 20 minuts before I found the error. it's a good way to learn smaller things trial by combat ;).

    Gusinda
Sign In or Register to comment.