Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[Not an Issue] [Reboot] Can't make a custom party in Black Pits 2

idrocketidrocket Member Posts: 15
edited September 2014 in BGII:EE Bugs (v1.2.2030)
Two separate dump files for the two times I tried. If I use the starting party, I can start black pits. I shall do all that though command to try to resolve this problem. Thanks!

Post edited by Gate70 on


  • Troodon80Troodon80 Member, Developer Posts: 4,110

    Nothing I can do with those. That would need a developer to take a look.

    It seems to work fine for me, so some generic questions (if you've answered some of these before, forgive the repetition):
    1. Are you using any mods?
    2. Are you using single player or multiplayer?
    3. Are you importing any characters or starting fresh?
    4. Are you using a full party, or less than six?
    5. Can you list the character builds you are trying to use, as close as you can remember?
    6. Does this crash happen every time you try to use a custom party or is it intermittent?
    If this can be reliably reproduced, then I can add those crash dumps to a report.

  • idrocketidrocket Member Posts: 15

    I have not answered any of these, so no repetition!

    1. No mobs at all Panda thing.

    2. Single player.

    3. Fresh characters. When I start a new game, I see 6 characters already selected/generated. I delete all six and create six new ones for black pits 2.

    4. Full party.

    5. Not only can I list the builds, but I can also list the order I create them in.

    Male shapeshifter
    Male Dragon Disciple
    Female dark moon monk
    male sun soul monk
    male monk (no subclass)
    Female fighter (no subclass)

    If further details are needed such as portrait selection, spells, weapon prof. etc I can give a pretty good detail on it.

    6. The crash happens when I attempt to create a party from scratch. I attempted to delete 1 character and create just one custom, and that worked. I then went to create a new full custom party and experienced the same crash.

    HOWEVER. This was all done between 12:00am and 3:00 am, this morning.

    As of now, I was able to recreate a new party from scratch. Sadly, this means I can no longer reproduce this error at this time. Sorry about all that. In the future, if I experience a crash I think I'll just leave the game alone for a day or two and see if it clears up before I start posting about it.

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    @Gate70, I can't be sure since I can't check the crash dump. I don't think that's the same issue here. I'll take a further look into it, though.

    @idrocket, extra detail would be great since I cannot reproduce it either. Don't need to worry about portraits, but additional details of spells, proficiencies, abilities, and races would be ideal for the above-listed characters.

    Any other details such as the order you tried to create the characters in - this more applies to things like, for example, clicking the sixth 'Create' button when you only have one character already there; when the character is created they will appear in the second slot, but clicking on odd combinations might confuse things. Did you delete a character at any time during the Create Party process, then perhaps try to recreate it? Any details you can provide, no matter how small or insignificant it may appear, might be useful in tracking down the issue.

  • idrocketidrocket Member Posts: 15

    I'm afraid I've recreated the party, as far as I'm aware, the exact same way I have been previously, but can no longer reproduce the crash.

    Some examples:

    I select delete from the first character, so that I never have to move the mouse and can just keep clicking delete. I also never deleted a character I've previously made.

    I always click the create button on the sixth open character slot.

    I always reroll all characters until they get a stat combo of at least 82.

    So! On with the list, though I'm unsure how helpful it will be if even I can't reproduce it anymore.

    Race for all - human

    Shapeshifter created first

    Rerolled stats until 84

    Prof: single weapon style, scimitar, club, spear, quarterstaff

    Dragon Disciple (created second)

    Prof: dagger and quarterstaff

    Mage book: 1 (magic missile, shield, burning hands, shocking grasp, protection from petrification)
    Mage book: 2 (Melf's acid arrow, vocalize, mirror image, blur, resist fear)
    Mage book: 3 (flame arrow, haste, ghost armor, remove magic)
    Mage book: 4 (spider spawn, stoneskin, ice storm)
    Mage book: 5 (conjure lesser air elemental, conjure lesser earth elemental)

    Note for all three monk characters. I ensure all three have 18 str, dex, and con. I make sure move silently is 65 and hide in shadows is 60. For prof, I make sure all have single weapon style, long sword, short sword, and katana

    Dark Moon Monk (created third)
    Sun Soul Monk (created fourth)
    Monk (created fifth)

    Fighter (created sixth)
    True neutral
    str (18/25, dex, con 18 (I always make sure these three are 18)
    Prof: spear 5, two-handed weapon style 2

    But, I can't recreate the problem, so I have no idea what could have caused the whole thing. I also can't think of anything I did differently. Same creation order, same skills, same spells, it just works now.

    I apologize for being unhelpful.

  • idrocketidrocket Member Posts: 15
    @gate70 I had not installed the game prior to December 23. I suppose that would explain why it seems to work like a charm now!

  • idrocketidrocket Member Posts: 15
    edited December 2013
    Sure @Gate70. Windows XP and I'm using Beamdog (not steam).

    Post edited by idrocket on
Sign In or Register to comment.