Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[BUG] Serious Mouse Bug

SerpentearSerpentear Member Posts: 11
So I have been playing for a bit now, and I have several saves all of which give me limited to no control over my characters.

I cannot change my party formation, at it automatically changes it back to the triangle shape. I cannot order my main character to move anywhere, he won't move unless i have the entire party selected.

Whenever I select an individual character, they start drinking potions non stop. I cannot order my main character to search for traps. It says:

Detecting Traps
Stopped Detecting Traps

I also cannot order him to lock pick, it won't even highlight the mask when I click it.

I almost as if the game is continuously reading my mouse clicks in the portion of the screen where the potions and party formation triangle are, but I still have control of my mouse. What happened? Then is on all of my saves at this point.


  • SerpentearSerpentear Member Posts: 11
    Also when I minimize and maximize the game, I receive temporary full control of my mouse again. I can even change my party formation, but it goes right back to the way it was in about 10 seconds.

  • TressetTresset Member, Moderator Posts: 7,596
    It almost sounds like you have a stuck button or key on your computer somewhere. Do you notice anything odd anywhere other than BG? What kind of OS do you use?

  • SerpentearSerpentear Member Posts: 11
    It's Windows 8, and I feel the same way. I'm going to reboot, and if that doesn't work. Re-install. I'll keep everyone posted.

  • Gate70Gate70 Member, Developer Posts: 3,598
    The original game used to have this sort of behaviour with wireless mouse / keyboard and their associated hotkey software. No idea if the enhanced version is similarly afflicted.

  • SerpentearSerpentear Member Posts: 11
    So far no luck. Uninstalled and re-installed. Nothing. Saves are corrupt.

  • TressetTresset Member, Moderator Posts: 7,596

    Saves are corrupt.

    Does that actually mean that if you were to start a new game that the issue would not happen? Is it only those saves that have the issue and others are unaffected?

    If it is only those specific save files that exhibit this behavior and not the whole game then could you upload one of them so it could be looked at? If the whole game is affected then it probably wouldn't help to do so.

    Also isn't Windows 8 the one that you can control with eye movements? I don't know much about that but would it be possible for that to be somehow related?

  • SerpentearSerpentear Member Posts: 11
    I have fixed the issue. To answer your question, no starting a new game did not help.

    I rebooted my computer and it fixed the issue. However, before I did that I took a screen cap, and it was capping the desktop. For whatever reason the desktop was being viewed as the active window, thus the mouse issue (somehow). I don't know why.

    In the attached file you can see the issue. The second to last party formation became the only available, this is also the potion slot.

    So in the end I have no idea what caused this issue but rebooting fixed it.

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    @Serpentear, that's really interesting. I noticed this issue with BG:EE as well when I was running it through Wine on openSUSE 13.1. I've never had any problems like that running on Windows Vista or 7.

    When I tried it though Wine, I couldn't control the party and I couldn't even quick-save or quick-load (because the window was not in focus/hadn't grabbed the mouse cursor).

    Since you fixed it by restarting, I'll move this topic to Not An Issue. If you experience this issue again please post and someone will look into it further. :-)

Sign In or Register to comment.