Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

*IMPORTANT* Regarding Intel Hardware! Driver issues, slow game performance

1181920212224»

Comments

  • bigern77bigern77 Member Posts: 1
    I have Windows 8 with an Intel Series 4 Integrated Graphics (an HP tm2 laptop), and the "Royal BNA Driver" worked for me:

    http://teknogods.com/phpbb/viewtopic.php?f=47&t=9645

    It basically fixes OpenGL on Intel gfx chips. Before I installed it I was getting a white screen upon starting the game, and then the graphics on the menu screen were totally corrupted. Now it plays with no problems.

    Try it out, hope it helps.

  • DLiteDLite Member Posts: 53

    I'm one of the folks who originally pre-ordered this BGEE back when it first came out. Needless to say, I was disappointed when it turned out my hardware was outdated: the game lagged horribly and was virtually unplayable.

    After diving into the Beta today, though, I'm happy to say that the lag issues are completely gone. The new render works like magic. On a related note, the game is gorgeous! I guess patience really is a virtue: it took a year longer than I anticipated, but good things come to those who patiently bide their time.

    For those who are curious, here are the specs for my 7-year old laptop:

    Operating System: Windows Vista Home Premium (6.0, Build 6002)

    CPU: Intel(R) Core(TM)2 Duo CPU T5250 @ 1.50GHz (2 CPUs), ~1.5GHZ

    GPU: Mobile Intel(R) 965 Express Chipset Family

    If the game works for me, I'm willing to wager that it'll work for most everyone else who was having problems similar to mine.


    This sounds promising. Was this the BG2:EE Beta you tested? I haven't been in here in a year, I just shelved BG:EE. Is the Intel-problem now fixed? I was thinking about buying BG2:EE, but I need to know of it works first.

    I've got a Dual core T4500 @ 2.30Ghz 2.30 GHz, 4GB RAM, Windows 7 Home Premium,
    and a Mobile Intel(R) 4 Series Chipset Family, with Intel driver: 8.15.10.2869


    D.




  • AbsoluteFallAbsoluteFall Member Posts: 25
    edited December 2013
    Please add support for "Intel(R) 82865G Graphics Controller, Driver Version 6.14.0010.4544", movie still stutters and gameplay is still unbearably slow, even hardware acceleration is 'enabled.'

  • zlygosczlygosc Member Posts: 1
    Hi,
    when I launch the game and it just shows a blank screen. The music is playing in the background and i can see and move and click mouse, but i can't see menu

    - Intel Atom CPU N455 @ 1.66GHz
    - Intel Graphics Media Accelerator 3150
    - 1GB RAM
    - Windows 7 Pro

    I've updated drivers, i changed .ini file (added 'Graphics','OpenGL Version','1', ).
    Do you know how to fix my problem?

  • shadedenmityshadedenmity Member Posts: 11
    Hey guys, I think I have finally figured out the whole lag thing. I am running Gateway AMD Athlon 64 X2 Dual Core Processor 6000 + 3 ghz. 2942 MB of ram, Windows Vista 32 bit, and NVidia Geforce 6150 SE nForce 430. I have had the worst time with the game lagging and I have tried EVERYTHING except something VERY basic.

    Go to your resolution settings for your monitor and change it to 800x600. Yes, the graphics aren't the best but now the game works great. So, if running Windows VISTA, right click on desktop, choose personalize, click on display settings, slide the resolution all the way to the left. Last but not least, right click on your BG2.exe file and click on compatibility and then choose to run in windows 98/me mode. Now i am playing the game with zero lag. Hope this is some help. I will spread this around to the other posts

    AbsoluteFall
  • AbsoluteFallAbsoluteFall Member Posts: 25
    @shadedenmity Thanks it worked for me too but in a different way! I set my reso to 800x600 then windows 98 stuff according to your post, ran the game, tested it (still lags), turned-on [UI SCALING] exited the game, set to 1024x764 (native), ran the game, voila I received no lag at all except for a small but unnoticeable video stuttering. My graphics card is kinda way - way - way too old... but it works now thanks again!

  • shadedenmityshadedenmity Member Posts: 11
    @AbsoluteFall Oh wow interesting, that's awesome it worked for you. I am going to trying messing with the UI Scaling and see if I can improve the performance. My graphics card is onboard and sucks, but even my most computer savvy friends said there was no way this game shouldn't run just fine on my PC. Hell, even back in 2001 it only needed Direct X 7 support!!

  • shadedenmityshadedenmity Member Posts: 11
    One other thing I noticed that might be really important. As I was playing the game in Windows 98/ME compatibility mode, I noticed that it was randomly deleting my saves and quick saves and so I actually lost 2 hours of game play when I went to reload. I was frustrated by this, but then I found another post on this board of a member talking about his saves getting deleted when running in a compatibility mode other than the one that you use as your primary. So, I turned off the run compatibility 98/me, I have still kept my resolution at 800x600 , and I have not had any problems so far either with lagging or saves getting deleted.

  • AbsoluteFallAbsoluteFall Member Posts: 25
    To fix the save issue try this, right-click Baldur.exe, left-click run as, choose the administrator account, (you must have a password or it won't run as admin), click OK. The BG saves will be stored on your administrator profile acct. Now then with my issue, I thought I solved it with your post, but actually I'd just overclocked my End from 1.6ghz to 3.4ghz, and that seemed to run BG at smooth speed.

  • AbsoluteFallAbsoluteFall Member Posts: 25
    edited December 2013
    Ughhh, my CPU is just Celeron D, and the graphics card is an intelchipset not even near with intelGMA, so it really sucks. Try to overclock your cpu or graphics card, but be warned its not really recommended, and it may cause you real problems soon, if you didn't do it carefully.

    EDIT: PLUS it seemed that BG II EE won't run at 16-bit colors, it would crashed continuously from every execution, which is a bad thing. Way back from the old BG EE renderer, I used the 16-bit trick to remove the performance/slowdown issue...

  • shadedenmityshadedenmity Member Posts: 11
    @AbsoluteFall , thank you for the run as administrator tip. That worked perfect.

    I haven't tried overclocking. I have an onboard Nvidia crappy graphics card but it works. So far, my best option at getting this game to work has been to change my computer res to 800x600 which is kind of a pain in the ass because whenever i exit the game I have to manually change it back.

    One other thing I am not sure if you have tried. A couple days ago when i was experimenting I tried running the game in windowed mode and not full screen, and that definitely improved the performance, but then you have to use the arrow keys to navigate around the screen.

    I have heard that Intel chipsets have a very difficult time running the game, I might actually go out and buy a different graphics card in hope of maybe running the game on that? It's rough with my onboard ge force, but obviously there are plenty of people on this forum who have had no problems playing this game!

  • AbsoluteFallAbsoluteFall Member Posts: 25
    Should you update your card to it's latest driver, won't you give it another shot? You might have missed some important update that would address your slowdown issue. May you also try changing your desktop colors to 16-bit, this would prove very helpful 'if worked.' Anyway, my brother's msi rig run BG EE just smooth and fine.

    Can you elaborate for me, what type of slowdown you're receiving? Is it in terms of i.e. walking, fighting, casting spell. Slowdown is a bit general for me, and it's a really good idea to replace your old graphics card with a new one. BG is a game that needs to be enjoyed, not to be frustrated with. Goodluck! :)

  • shadedenmityshadedenmity Member Posts: 11
    I manually went in to the manufacturers websites and downloaded and installed the latest drivers for my card and computer. I will try changing the desktop colors as well to 16 bit but so far 800x600 is the only way I have gotten it to work.

    The slowdown I am experiencing makes the game unbearable in the other modes. Walking is extremely slow, the speech is fine, but when Irenicus casts his opening spells in the intro, it goes really slow, and when I had 4 people in my party then game lagged even slower in all aspects, fighting, casting spell, walking.

  • AbsoluteFallAbsoluteFall Member Posts: 25
    Every computer must have a built-in intel chipset graphic driver, by chance do you have one? Can you temporarily swap your video card with the integrated one, by disabling Nvidia and enabling the chipset? Try downloading the chipset driver from the manufacturer's website (intel), this might work atleast for you.

  • AbsoluteFallAbsoluteFall Member Posts: 25
    While the new renderer has no perf. impact on my end, I believe that the introduced transparency in the GUI caused the sluggish perf. on old ends. You can disable the GUI by pressing ctrl+H, this will improve your gameplay performance.

  • iso12000iso12000 Member Posts: 9
    I still get some serious FPS lag when casting multiple spells.

Sign In or Register to comment.