Skip to content

No Sound

I did a google search and tried the following:

1) Installed OpenAL32.dll and OpenAL64.dll
2) I am not sure where they are suppose to go.

I am running Windows 7 64-bit.

Any assistance would be much appreciated.

Thank you


  • Gate70Gate70 Member, Developer Posts: 3,799
    Some basics first @Shadowhawke‌

    Presumably sound works on other applications.
    It should go somewhere like c:\windows\system32 - would expect it to install there correctly unless you just downloaded the dll's? & the 64 bit version into c:\windows\syswow64 too.
    Have you opened up the options > sound menu in the game and checked all the volume sliders are right of the minimum.

  • ShadowhawkeShadowhawke Member Posts: 15
    Thank you for responding.

    Turns out I already have OpenAL32dll in c:\windows\system32.

    I added OpenAL64.dll in c:\windows\syswow64.

    All my sliders are to the right of the minimum. I still have no sounds.

  • ShadowhawkeShadowhawke Member Posts: 15
    More info about my rig.

    Windows 7 - 64 Bit
    Creative Sound Blaster Titanium HD (driver 3.0.2015)
    Astro A40 Headset and Mixamp.
  • Gate70Gate70 Member, Developer Posts: 3,799
    There appear to be a few items relating to lack of sound on the archived forum area, link attached.


    Have a read through them and see if any of them are similar to your situation.
  • ShadowhawkeShadowhawke Member Posts: 15
  • ShadowhawkeShadowhawke Member Posts: 15
    This solved my problem.

    By Kruno

    Quick fix: Skip all this text and look to the bottom.

    Guys. None of these solutions mentioned in this thread worked for me, however I did notice something about X-Fi cards not doing so well in the hardware compatibility FAQ on the forums. I use Beyerdynamic T1 with a Luxman P-200 and DA-200 amp, and DAC, and so SPDIF/TOSLINK output is essential.

    What I did back, when I had just installed Windows 8, was allow the automatic update to install sound card drivers, I use an onboard X-Fi that comes with my G1 Assassin 2 mobo, and everything seemed to work post update, until yesterday. The odd thing about Windows' recommended drivers were a year old, which seemed odd to me. Anyhow, the default drivers installed under Windows 8 are recent and never gave me an issue. I should not have installed Creative's drivers through Windows update.

    1. Go into device manager.
    2. Select the X-Fi device under "Sound, ... controllers".
    3. Update driver.
    4. "Browse my computer..."
    5. "Let me pick..."
    6. "High Definition Audio Device".

    Problem should fix itself. By default this is not an issue with Windows 8, but with user error.
  • Gate70Gate70 Member, Developer Posts: 3,799
    Glad to hear it, & enjoy the game :)
  • Swifty_MageeSwifty_Magee Member Posts: 222
    I know this is an old thread, but I just wanted to say that I also use an old X-Fi Creative audio card and Shadowhawke's method both fixed my in-game audio problems in Icewind Dale EE and the static problems I was having with all the audio in the cutscenes. So glad I found this thread. Thanks again, Shadowhawke!
  • sarevok57sarevok57 Member Posts: 5,877
    I can also confirm that Shadowhawke's solution works, had the no sound problem myself but did Shadowhawke's 6 step solution and now it works perfectly
  • FicjuszFicjusz Member Posts: 20
    For folks who don't even use SoundBlaster sound card or hardware acceleration (like me) this could be helpful: Of course you should try to instal the "official" Open AL first.
Sign In or Register to comment.