Skip to content

#6629 Rasaad should not be duplicated (encountered before updating to 1.3 patch)

geddoegeddoe Member Posts: 27
edited December 2014 in BG:EE Bugs (v1.3)
I had Rasaad in my party for like 5 minutes, then booted him (I think I was still in Nashkel when I kicked him out). Now I went to go recruit him and again, he asks if we are to travel together one more. I say sure. He joins, then immediately says his little farewell dialogue about the moon waxing and waning and whatnot, then leaves the party, wanders into the nearby inn, disappears inside, then immediately reappears and initiate's his own dialogue asking if we are to travel together again. I say sure. He joins, then immediately leaves again, wanders off, disappears, reappears, etcetera, etcetera, in an endless loop. What's up with that? I'm still on version 1.2. Should I update to 1.3? I looked through the bug fixes and didn't really see anything addressing this issue.
Post edited by Gate70 on


  • geddoegeddoe Member Posts: 27
    Oh, it's the Beamdog version for PC, if that helps at all. I haven't updated yet cause I'm playing on a old laptop without internet access.
  • wubblewubble Member Posts: 3,156
    I can't help you myself but stating your operating system will probably help get the problem solved quicker when the devs see it. (it could just be Rasaad he's a weird guy)
  • geddoegeddoe Member Posts: 27
    Windows 7 Intel Core Duo 2 CPU. It's not a very good laptop, but it runs BGEE just fine.
  • geddoegeddoe Member Posts: 27
    OK, so updating to the new patch seemed to help. It just created a new Rasaad, though, with 3 new commoners standing around gawking at him. So now there's two standing around in Nashkel with 6 onlookers. I talked to the 'new' Rasaad and it was like I was meeting him for the first time again, dealing with the stupid commoner calling him a chicken and whatnot. So now I've got him in the party and I'm wondering if this might effect him initiating the dialogues to start his quest. I've read how his quest was pretty buggy to start off with (but they may have been talking about his quest is BG2:EE), so just wondering if anyone else has any experience with this.
  • elminsterelminster Member, Developer Posts: 16,305
    I don't think its an issue anymore with a new game made in 1.3. You probably are still only experiencing this issue because you are using an old save game.
  • geddoegeddoe Member Posts: 27
    Yeah, I saw that one of the bug fixes was duplication of Rasaad. The save I had was my party standing right next to Rasaad, so that's probably why he was still duplicated. I had the conversation with him about his brother getting killed in Athkatla a couple of days ago (game time). I'm pretty sure the next conversation is what starts his quest? What's the trigger exactly? Just a certain amount of time spent with the party? Level of protagonist? Chapter progression?
  • FranpaFranpa Member Posts: 637
    Since you still seem to be quite early in to the game, I would restart from the start after updating to v1.3.
  • VakarianVakarian Member Posts: 94
    edited December 2014
    I'm having a few problems with Rasaad in my game. First, after fighting Nimbul in Nashkel early in the game (long before the attached save), Rasaad (not in the party at the time) joined in the fight. After the dialogue following the fight, a second Rasaad started appearing outside the inn (I think I might have had him join my party momentarily, but immediately kicked him out - the second Rasaad appeared after this).

    Much later, I returned to recruit him so that I could do his quest. Both copies of Rasaad were still in Nashkel and had the same dialogue, so I picked one of them to join my group. After about a day of traveling together, he triggers his leaving the party dialogue and takes off back to Nashkel (I have a reputation of 20, so that should not be an issue). When I return to Nashkel, both copies of Rasaad are there. When I ask him to rejoin (either copy), he does, but then immediately leaves.

    Any ideas of what happened on or how to fix it? [save file attached]
  • Gate70Gate70 Member, Developer Posts: 3,800
    @Vakarian‌ it sounds like you either your game doesn't have the 1.3 patch installed or you encountered Rasaad before updating.

    I've attached a couple of saves which I think may work - had to create a 3rd copy of him. I'm not sure how many xp you were expecting him to have so 1 has him at the start and the other has him with 27k which is what the other 2 showed. Also handed some gear to your main character as one of the two had it.
  • VakarianVakarian Member Posts: 94
    edited December 2014
    @Gate70 Thanks for the fix. FYI, I do have the 1.3 patch installed (1.3.2053), and I'm fairly certain that I started this character after the patch was installed. Playing on steam/Win 8.1. I've got another game that is nearing the point where the copy showed up, so I'll see if I can reproduce the duplication.
  • Gate70Gate70 Member, Developer Posts: 3,800
    OK, will remove the tag if you confirm.
  • AdsoAdso Member Posts: 122
    Ok, after running into the the duplicate Rasaad bug, post Nibul, Firewine etc on a 1.3.2053 GoG MacOSX I have come up with a hotfix (see attached image).

    1) recruit both Rasaads into party, in my case I had to drop Minsc+Dynaheir
    2) Pause then, invoke flaming fists with each
    3) select attack with both and click on each
    4) the strongest of the two will survive, the weaker one will die. problem solved.

    I think this might be an Easter egg actually for those of us that enjoy this sort of thing, yet I'm playing a NG Ranger this time through.
  • thelovebatthelovebat Member Posts: 218
    elminster said:

    I don't think its an issue anymore with a new game made in 1.3. You probably are still only experiencing this issue because you are using an old save game.

    Feels kinda bad because one of my evil characters is affected by this bug cus I started the playthrough before the 1.3 patch, but it's still something annoying to deal with cus I planned on trying to do Rasaad's quest with them. Any way to deal with or fix the issue so there aren't two Rasaad's in town next time I continue along with that character? I'm far along enough with them where I didn't really want to start over, but the save files I have with them have this issue present.
Sign In or Register to comment.