Skip to content

[Resolved] BGEE and BGIIEE do not run with Intel 4 Series chipset on Windows 10

TypicalhumanTypicalhuman Member Posts: 8
edited July 2016 in Troubleshooting
So heres the problem. I have an Acer 2012 model PC and for the last year both games ran smoothly until last week. Any time I try to load either game I get this error message:

There was an error. A crash report was saved to:
C:\Garrett\Documents\Infinity Engine-Enhanced Edition/crash/dump.2.3.67.0010.dmp
Please Contact support@beamdog.com

Now I contacted them and the person told me to switch to the 1.3 beta. It runs on both games now however they are both horrendously slow. Now normally I'd chalk this up to a graphics card issue however I have Mideval 2 and Shadowrun: Hong Kong and they run smoothly. My only guess would be the Windows 10 upgrade-that took place a few weeks ago-might have screwed something up but Im not an expert and I was hoping someone on here could help me.
Post edited by Gate70 on

Comments

  • Gate70Gate70 Member, Developer Posts: 3,829
    Could you attach a dxdiag report please @Typicalhuman by dropping the output into the leave a comment box here
    (Windows/R, type dxdiag into the run box, click ok, wait for it to complete, save all information)

    Thanks
    JuliusBorisov
  • TypicalhumanTypicalhuman Member Posts: 8
    I'm not sure what you mean. I'm not very computer savvy. Sorry..
  • Gate70Gate70 Member, Developer Posts: 3,829
    OK, do the steps below help

    Hold the Windows key http://en.wikipedia.org/wiki/Windows_key) and press R. Then release both keys.
    That should open a run prompt such as http://en.wikipedia.org/wiki/Run_command

    From there, type dxdiag and click ok
    That should launch the directx diagnostic utility, e.g.http://en.wikipedia.org/wiki/DxDiag
    Wait while it runs, progress is shown by a green bar on the lower left
    Once finished, click the save all information button and save to your desktop as dxdiag.txt

    Position your web browser so you can see both it and the file on your desktop.
    Click the file, and drag it into the "leave a comment" box
    Wait a second or two so the file is copied
    Click post comment
    TypicalhumanJuliusBorisov
  • TypicalhumanTypicalhuman Member Posts: 8
    Here goes nothing
  • Gate70Gate70 Member, Developer Posts: 3,829
    Yep, that's good. Could you try this for Baldur's Gate please.
    n.b. I'm not on a Windows PC at present so going from memory,

    Make sure the game is closed.
    Open Windows Explorer (hold Windows key, press E key, release both).
    Find the Documents -> Baldur's Gate - Enhanced Edition folder.
    Right click the baldur.lua file in there and rename it e.g. to balduroriginal.lua.

    Download this file, and right-click it.
    Click Extract All.
    Click Browse.
    Navigate to your Documents -> Baldur's Gate - Enhanced Edition folder.
    Click extract.

    Once the file is extracted, launch the game.
    TypicalhumanJuliusBorisov
  • TypicalhumanTypicalhuman Member Posts: 8
    Hey awesome it worked! Now can you help me do the same with BG2EE?
  • Gate70Gate70 Member, Developer Posts: 3,829
    Try this @Typicalhuman

    The key part is the addition of this line.
    SetPrivateProfileString('Graphics','Backend','1')

    Your graphics card is not supported under Windows 10 and is using a generic driver.

    BG:EE and BGII:EE are able to use the alternate renderer. If you have purchased IWD:EE, your options are to use another computer, change your graphics card or revert to whichever of Windows 7/8 you had.
    mf2112JuliusBorisov
  • TypicalhumanTypicalhuman Member Posts: 8
    Ok boss your gonna have to walk me through this because I tried the steps for BGEE for BG2EE and so far its not working. I keep getting that same error message when ever I load BG2EE.
  • Gate70Gate70 Member, Developer Posts: 3,829
    edited July 2016
    OK, you need to download that file to the BGIIEE location. If you overwrote the BGEE file, redo that and then do the below for BGIIEE

    Make sure BGIIEE is not running :)
    Download the BGIIEE file, and right-click it.
    Click Extract All.
    Click Browse.
    Navigate to your Documents -> Baldur's Gate II - Enhanced Edition folder.
    Click extract.
    mf2112JuliusBorisov
  • TypicalhumanTypicalhuman Member Posts: 8
    It works !!!
    Thanks alot @Gate70 I appreciate your patience and your willingness to help a brother out.
    JuliusBorisov
  • AgenesiaAgenesia Member Posts: 2
    Gate70 said:

    OK, you need to download that file to the BGIIEE location. If you overwrote the BGEE file, redo that and then do the below for BGIIEE

    Make sure BGIIEE is not running :)
    Download the BGIIEE file, and right-click it.
    Click Extract All.
    Click Browse.
    Navigate to your Documents -> Baldur's Gate II - Enhanced Edition folder.
    Click extract.

    The problem I am having is upon install my Documents/gamename/ folder does not exist. I see the folder for BG:EE but nothing is created for BG II: EE. I am using steam version of the game.
  • GusindaGusinda Member Posts: 1,818
    Hi @Agenesia, welcome to the forum.

    For the 'Documents BG2EE' folder to appear, the game has to be started first. When started, the game will create the folder and determine the .lua configuration. Once that is done, you can edit the file (or overwrite if you need to). If you are trying to overwrite with the file above, are you having problems with the game?

    Gus
    JuliusBorisov
Sign In or Register to comment.